[PATCH] gnu: python-pyflakes: Update to 3.0.1.

  • Open
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Vincent Prat
Owner
unassigned
Submitted by
Vincent Prat
Severity
normal
V
V
Vincent Prat wrote on 20 Jun 2023 11:21
(address . guix-patches@gnu.org)
CAH9Ak7JWSUw6JmyNSY79u+qM+u9RcVAJW519uiB1Kc4f+EfUXA@mail.gmail.com

From 65a7d76dfd30c92bef07f529676909fe51f12638 Mon Sep 17 00:00:00 2001
From: Vincent Prat <vprat@deeplinks.com>
Date: Tue, 20 Jun 2023 11:15:14 +0200
Subject: [PATCH 2/2] gnu: python-pyflakes: Fix style.

* gnu/packages/python-xyz.scm (python-pyflakes): Fix style.
---
gnu/packages/python-xyz.scm | 15 +++++++--------
1 file changed, 7 insertions(+), 8 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 57b5feb6df..f8e35420e1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12198,18 +12198,17 @@ (define-public python-pyflakes
(package
(name "python-pyflakes")
(version "3.0.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pyflakes" version))
- (sha256
- (base32
- "1zfhbwbd90v26jdzs2l5cjgc30cq8dzdsnnjzvg81gb0ddm2g2zc"))))
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyflakes" version))
+ (sha256
+ (base32
+ "1zfhbwbd90v26jdzs2l5cjgc30cq8dzdsnnjzvg81gb0ddm2g2zc"))))
(build-system python-build-system)
(home-page "https://github.com/PyCQA/pyflakes")
(synopsis "Passive checker of Python programs")
(description
- "Pyflakes statically checks Python source code for common errors.")
+ "Pyflakes statically checks Python source code for common errors.")
(license license:expat)))
(define-public python-pyflakes-2.2
--
2.39.2
From 3d9b29f927b4d3605738bee83fcab0bb67fdb704 Mon Sep 17 00:00:00 2001
From: Vincent Prat <vprat@deeplinks.com>
Date: Tue, 20 Jun 2023 10:52:46 +0200
Subject: [PATCH 1/2] gnu: python-pyflakes: Update to 3.0.1.

* gnu/packages/python-xyz.scm (python-pyflakes): Update to 3.0.1
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index af9dd45d6e..57b5feb6df 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12197,14 +12197,14 @@ (define-public python-pep621
(define-public python-pyflakes
(package
(name "python-pyflakes")
- (version "2.4.0")
+ (version "3.0.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pyflakes" version))
(sha256
(base32
- "0k5jn8jpxni264wxf6cc3xcd1qckc0pww30bsd77mwzdf8l5ra05"))))
+ "1zfhbwbd90v26jdzs2l5cjgc30cq8dzdsnnjzvg81gb0ddm2g2zc"))))
(build-system python-build-system)
(home-page "https://github.com/PyCQA/pyflakes")
(synopsis "Passive checker of Python programs")
--
2.39.2
M
M
Maxim Cournoyer wrote on 6 Sep 2023 16:25
(name . Vincent Prat)(address . vprat@deeplinks.com)(address . 64189@debbugs.gnu.org)
87y1hj5qfd.fsf@gmail.com
Hi,

For me, rebuilding the dependents (guix refresh -l python-pyflakes),
this appears to break the following packages, e.g.:

Toggle quote (4 lines)
> $ ./pre-inst-env guix build -k 389-ds-base anki audio-to-midi autokey awscli beets-bandcamp breezy caja-extensions ccwl celluloid conda cozy cura curseradio c-vise dbxfs dialect docker-compose electron-cash electrum emacs-calibredb emacs-elpy emacs-emms-mode-line-cycle emacs-helm-emms emacs-lemon emacs-org-emms emacs-pyimport emacs-py-isort emacs-waveform fanc fdroidserver gdc-client gfeeds giara gpodder guix-jupyter hangups ibus-theme-tools ikiwiki komikku linuxdcpp magic-wormhole mdpo mpdris2 mpv-mpris nikola nototools nyx offlate openfoam-com openfoam-org pandoc-include pantalaimon pgcli picard pipe-viewer plasmatube postorius python-altair python-argopt python-arpeggio python-astroalign python-autoflake8 python-baltica python-bash-kernel python-behave-web-api python-biom-format python-bulkvis python-captum python-cleanlab python-clinguin python-codespell python-cooltools python-deepxde python-diff-cover python-django-taggit python-docx python-duckdb python-enoslib python-falcon-cors python-fanc python-fastapi-csrf-protect python-flake8-continuation python-flake8-debugger python-flake8-isort python-flake8-pyi python-flake8-quotes python-flask-combo-jsonapi python-flask-oidc python-flask-restx python-furl python-goatools python-h3 python-harmony python-iml python-ipdb python-ipympl python-ipython-cluster-helper python-ipython-documentation python-jaraco-packaging python-jinja2-cli python-jupyter-sphinx python-jupytext python-jwst python-liana-py python-mailman-hyperkitty python-mgatk python-minio python-mt-940 python-nb-clean python-nbdime python-nox python-ovh python-pari-jupyter python-poliastro python-pyee python-pygmsh python-pymc python-pystitcher python-pytest-check-links python-pytest-csv python-pytest-perf python-pytorch-lightning python-qstylizer python-rasterio python-regions python-scikit-fem python-scikit-rf python-scm-sr-ht python-scrapy python-slurm-magic python-spacy python-sparqlkernel python-sunpy python-telethon python-telingo python-textdistance python-tldr python-transient python-trio-websocket python-tslearn python-tweepy python-woob python-wsgi-intercept python-yq qtile quodlibet r128gain rfcat r-nbconvertr rtv scregseg sdkmanager smplayer snakemake sshuttle synapse tgcli tractor trytond-currency-rs trytond-stock-package-shipping-dpd trytond-stock-package-shipping-mygls tuir vorta weasyprint weechat-matrix whoogle-search xeus ytfzf yubikey-manager-qt yubikey-oath-dmenu

> guix build: error: build of `/gnu/store/0a3w3yg4sjkdnqvmf3mmby0f23wqi75f-tuir-1.29.0.drv', `/gnu/store/125b0hhswz1z0ybw75fpdkx3qw26dp7z-smplayer-21.10.0.drv', `/gnu/store/14al8da9r9jj5yis81mzxz12bas5s9l5-rfcat-1.9.6.drv', `/gnu/store/1skqzjsdq1m16aqgsb6mx99cqa57k432-xeus-2.4.1.drv', `/gnu/store/27avbzc48c198np947g8269wcy3hinjw-trytond-stock-package-shipping-dpd-6.2.3.drv', `/gnu/store/2w881knxnd3r8vnya6vaqif3k68rimrk-ytfzf-2.6.0.drv', `/gnu/store/4inggfp3wl0xzzvkaqvhbl531n3gd9rb-snakemake-7.7.0.drv', `/gnu/store/4r7wysl1j4gv64hkdh8wb4ckmqwm7z3a-python-trio-websocket-0.9.2.drv', `/gnu/store/4zswadx2497n2rrv6g3092brj30gvf4z-python-wsgi-intercept-1.2.2.drv', `/gnu/store/522g3fkk71l6942a0d9fdjvsykn12n6q-python-transient-0.12.drv', `/gnu/store/5cfxlwil7fkxijkawfvfzj1f39plmxx1-python-tslearn-0.6.1.drv', `/gnu/store/61b5fxba2s2p7k75gjx6m7857dlii6hk-scregseg-0.1.3.drv', `/gnu/store/634nh343bi1ax5wn35w0iq2ny6wk170a-tgcli-0.3.1.drv', `/gnu/store/6bm12by5nnspw7r3igcfhgqxd3d1rncp-python-tldr-3.1.0.drv', `/gnu/store/7pmvsjpz2wvfzjam0mkkdjqr8rbnvpzc-qtile-0.18.1.drv', `/gnu/store/8982qafjadk1w8dzdkqiih3v8a67q7y6-python-tweepy-4.4.0.drv', `/gnu/store/8wb0fyg9n0r82gyhcvqrgkaagqz4nsfb-trytond-currency-rs-6.2.0.drv', `/gnu/store/f6a0xyh7kv7svbhqb3ir4qf9w738zc1z-sdkmanager-0.6.5.drv', `/gnu/store/gbvs34a55a8xrv9j0mgpyq33893js3gj-trytond-stock-package-shipping-mygls-6.2.1.drv', `/gnu/store/i8qq6qfgyk372257zsj0mb70b3njrq1s-python-woob-3.0.drv', `/gnu/store/ixxcapsbhdx2jmdb3nrhkqvk8fn48z80-rtv-1.27.0.drv', `/gnu/store/jzlmg4cjbwlqqzb3hn50798z5m9vrbkh-r128gain-1.0.7.drv', `/gnu/store/k3p1wcv8xy2y1s51q9daglay6q3584kz-sshuttle-0.78.5.drv', `/gnu/store/kd581pvvimh44bbc9qg3wlwqh7zyz53y-weechat-matrix-0.3.0.drv', `/gnu/store/lj8vnrlgsmyackdrkqpd0navdb6fnl0j-whoogle-search-0.8.2.drv', `/gnu/store/nll35q050475abrrbg23y4l6np42apa9-yubikey-oath-dmenu-0.13.0.drv', `/gnu/store/pckk0qffrwhwfh4mxkxdb55grbb0wi2k-weasyprint-56.1.drv', `/gnu/store/q06scz3n3v12gfbwhvdmiihaf30wvs8j-r-nbconvertr-1.3.2.drv', `/gnu/store/qxb7wl8yzhmwdfx4wzrhdcad83xwlisl-synapse-1.29.0.drv', `/gnu/store/vz24zxmdwipxxx8rw2arlj8wsjzsnvxa-yubikey-manager-qt-1.2.5.drv', `/gnu/store/w65pkgdymkiln8xvv6giagh8vxq32j0r-quodlibet-4.5.0.drv', `/gnu/store/xvb003pyil7a3nhwqr0fm9gyqv7523km-python-yq-3.1.0.drv', `/gnu/store/xzzi956isbdchgrjp3ibinppfhfn3jgj-vorta-0.8.7.drv' failed

Could you look into it?

Thank you,

Maxim
V
V
Vincent Prat wrote on 7 Sep 2023 13:52
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 64189@debbugs.gnu.org)
CAH9Ak7+YCjXnBD6QBa4yV4+gdU=kN+95U1FNV1Nx1kciQwcE_Q@mail.gmail.com
Hi,

Obviously, version 3 of python-pyflakes introduced some breaking changes.
I guess that most of these build failures are due to other packages
not being up-to-date.
For instance, some of them can be fixed by updating python-flake8

What is the procedure in such a case?

Regards,
Vincent

Le mer. 6 sept. 2023 à 16:26, Maxim Cournoyer
<maxim.cournoyer@gmail.com> a écrit :
Toggle quote (15 lines)
>
> Hi,
>
> For me, rebuilding the dependents (guix refresh -l python-pyflakes),
> this appears to break the following packages, e.g.:
>
> > $ ./pre-inst-env guix build -k 389-ds-base anki audio-to-midi autokey awscli beets-bandcamp breezy caja-extensions ccwl celluloid conda cozy cura curseradio c-vise dbxfs dialect docker-compose electron-cash electrum emacs-calibredb emacs-elpy emacs-emms-mode-line-cycle emacs-helm-emms emacs-lemon emacs-org-emms emacs-pyimport emacs-py-isort emacs-waveform fanc fdroidserver gdc-client gfeeds giara gpodder guix-jupyter hangups ibus-theme-tools ikiwiki komikku linuxdcpp magic-wormhole mdpo mpdris2 mpv-mpris nikola nototools nyx offlate openfoam-com openfoam-org pandoc-include pantalaimon pgcli picard pipe-viewer plasmatube postorius python-altair python-argopt python-arpeggio python-astroalign python-autoflake8 python-baltica python-bash-kernel python-behave-web-api python-biom-format python-bulkvis python-captum python-cleanlab python-clinguin python-codespell python-cooltools python-deepxde python-diff-cover python-django-taggit python-docx python-duckdb python-enoslib python-falcon-cors python-fanc python-fastapi-csrf-protect python-flake8-continuation python-flake8-debugger python-flake8-isort python-flake8-pyi python-flake8-quotes python-flask-combo-jsonapi python-flask-oidc python-flask-restx python-furl python-goatools python-h3 python-harmony python-iml python-ipdb python-ipympl python-ipython-cluster-helper python-ipython-documentation python-jaraco-packaging python-jinja2-cli python-jupyter-sphinx python-jupytext python-jwst python-liana-py python-mailman-hyperkitty python-mgatk python-minio python-mt-940 python-nb-clean python-nbdime python-nox python-ovh python-pari-jupyter python-poliastro python-pyee python-pygmsh python-pymc python-pystitcher python-pytest-check-links python-pytest-csv python-pytest-perf python-pytorch-lightning python-qstylizer python-rasterio python-regions python-scikit-fem python-scikit-rf python-scm-sr-ht python-scrapy python-slurm-magic python-spacy python-sparqlkernel python-sunpy python-telethon python-telingo python-textdistance python-tldr python-transient python-trio-websocket python-tslearn python-tweepy python-woob python-wsgi-intercept python-yq qtile quodlibet r128gain rfcat r-nbconvertr rtv scregseg sdkmanager smplayer snakemake sshuttle synapse tgcli tractor trytond-currency-rs trytond-stock-package-shipping-dpd trytond-stock-package-shipping-mygls tuir vorta weasyprint weechat-matrix whoogle-search xeus ytfzf yubikey-manager-qt yubikey-oath-dmenu
>
> > guix build: error: build of `/gnu/store/0a3w3yg4sjkdnqvmf3mmby0f23wqi75f-tuir-1.29.0.drv', `/gnu/store/125b0hhswz1z0ybw75fpdkx3qw26dp7z-smplayer-21.10.0.drv', `/gnu/store/14al8da9r9jj5yis81mzxz12bas5s9l5-rfcat-1.9.6.drv', `/gnu/store/1skqzjsdq1m16aqgsb6mx99cqa57k432-xeus-2.4.1.drv', `/gnu/store/27avbzc48c198np947g8269wcy3hinjw-trytond-stock-package-shipping-dpd-6.2.3.drv', `/gnu/store/2w881knxnd3r8vnya6vaqif3k68rimrk-ytfzf-2.6.0.drv', `/gnu/store/4inggfp3wl0xzzvkaqvhbl531n3gd9rb-snakemake-7.7.0.drv', `/gnu/store/4r7wysl1j4gv64hkdh8wb4ckmqwm7z3a-python-trio-websocket-0.9.2.drv', `/gnu/store/4zswadx2497n2rrv6g3092brj30gvf4z-python-wsgi-intercept-1.2.2.drv', `/gnu/store/522g3fkk71l6942a0d9fdjvsykn12n6q-python-transient-0.12.drv', `/gnu/store/5cfxlwil7fkxijkawfvfzj1f39plmxx1-python-tslearn-0.6.1.drv', `/gnu/store/61b5fxba2s2p7k75gjx6m7857dlii6hk-scregseg-0.1.3.drv', `/gnu/store/634nh343bi1ax5wn35w0iq2ny6wk170a-tgcli-0.3.1.drv', `/gnu/store/6bm12by5nnspw7r3igcfhgqxd3d1rncp-python-tldr-3.1.0.drv', `/gnu/store/7pmvsjpz2wvfzjam0mkkdjqr8rbnvpzc-qtile-0.18.1.drv', `/gnu/store/8982qafjadk1w8dzdkqiih3v8a67q7y6-python-tweepy-4.4.0.drv', `/gnu/store/8wb0fyg9n0r82gyhcvqrgkaagqz4nsfb-trytond-currency-rs-6.2.0.drv', `/gnu/store/f6a0xyh7kv7svbhqb3ir4qf9w738zc1z-sdkmanager-0.6.5.drv', `/gnu/store/gbvs34a55a8xrv9j0mgpyq33893js3gj-trytond-stock-package-shipping-mygls-6.2.1.drv', `/gnu/store/i8qq6qfgyk372257zsj0mb70b3njrq1s-python-woob-3.0.drv', `/gnu/store/ixxcapsbhdx2jmdb3nrhkqvk8fn48z80-rtv-1.27.0.drv', `/gnu/store/jzlmg4cjbwlqqzb3hn50798z5m9vrbkh-r128gain-1.0.7.drv', `/gnu/store/k3p1wcv8xy2y1s51q9daglay6q3584kz-sshuttle-0.78.5.drv', `/gnu/store/kd581pvvimh44bbc9qg3wlwqh7zyz53y-weechat-matrix-0.3.0.drv', `/gnu/store/lj8vnrlgsmyackdrkqpd0navdb6fnl0j-whoogle-search-0.8.2.drv', `/gnu/store/nll35q050475abrrbg23y4l6np42apa9-yubikey-oath-dmenu-0.13.0.drv', `/gnu/store/pckk0qffrwhwfh4mxkxdb55grbb0wi2k-weasyprint-56.1.drv', `/gnu/store/q06scz3n3v12gfbwhvdmiihaf30wvs8j-r-nbconvertr-1.3.2.drv', `/gnu/store/qxb7wl8yzhmwdfx4wzrhdcad83xwlisl-synapse-1.29.0.drv', `/gnu/store/vz24zxmdwipxxx8rw2arlj8wsjzsnvxa-yubikey-manager-qt-1.2.5.drv', `/gnu/store/w65pkgdymkiln8xvv6giagh8vxq32j0r-quodlibet-4.5.0.drv', `/gnu/store/xvb003pyil7a3nhwqr0fm9gyqv7523km-python-yq-3.1.0.drv', `/gnu/store/xzzi956isbdchgrjp3ibinppfhfn3jgj-vorta-0.8.7.drv' failed
>
> Could you look into it?
>
> Thank you,
>
> Maxim
M
M
Maxim Cournoyer wrote on 7 Sep 2023 15:13
(name . Vincent Prat)(address . vprat@deeplinks.com)(address . 64189@debbugs.gnu.org)
8734zqnn33.fsf@gmail.com
Hi,

Vincent Prat <vprat@deeplinks.com> writes:

Toggle quote (11 lines)
> Hi,
>
> Obviously, version 3 of python-pyflakes introduced some breaking changes.
> I guess that most of these build failures are due to other packages
> not being up-to-date.
> For instance, some of them can be fixed by updating python-flake8
> (https://github.com/PyCQA/pyflakes/pull/751) and python-pylama
> (https://github.com/PyCQA/pyflakes/issues/721).
>
> What is the procedure in such a case?

Since Python doesn't support mixed versions, at least for libraries,
this implies that the complete Python distribution in Guix must be
updated to work with the new version. That may sounds bad, but as you
pointed, it typically involves upgrading the packages broken post
update, which shouldn't be too difficult (but is time consuming).

guix refresh --upgrade and etc/committer.scm are your friends here.

Since the number of rebuilds is a bit large for master, a dedicated
branch could be created (or the python-team branch reused) to build and
QA the new work.

--
Thanks,
Maxim
?