guix locate: unsupported manifest format

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 20 Jun 2023 09:25
(address . bug-guix@gnu.org)
87jzvy1tn0.fsf@elephly.net
I ran “guix locate” on the HPC cluster where we generally don’t ever run
“guix gc”. Here’s what I got:

Toggle snippet (10 lines)
$ time guix locate ls
guix locate: indexing files from /gnu/store...
guix locate: traversing local profile manifests...
guix locate: error: unsupported manifest format

real 2m24.029s
user 3m11.519s
sys 0m5.617s

It would be good if it printed the location of the problematic manifest
and ignored it.

--
Ricardo
L
L
Ludovic Courtès wrote on 21 Jun 2023 16:41
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 64187@debbugs.gnu.org)
87jzvw7u8r.fsf@gnu.org
Hi!

Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (8 lines)
> I ran “guix locate” on the HPC cluster where we generally don’t ever run
> “guix gc”. Here’s what I got:
>
> $ time guix locate ls
> guix locate: indexing files from /gnu/store...
> guix locate: traversing local profile manifests...
> guix locate: error: unsupported manifest format

Oooh no…

Toggle quote (7 lines)
> real 2m24.029s
> user 3m11.519s
> sys 0m5.617s
>
> It would be good if it printed the location of the problematic manifest
> and ignored it.

Yes.

However, how can it happen? ‘guix locate’ knows all the manifest format
version, so maybe it mistook a file for a manifest when in fact it’s
something else?

Could you ‘strace -o /tmp/log.strace guix locate ls’ to get the name of
the offending file for now?

Thanks for reporting it!

Ludo’.
R
R
Ricardo Wurmus wrote on 4 Jul 2023 08:16
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 64187@debbugs.gnu.org)
87mt0ctd2e.fsf@elephly.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (7 lines)
> However, how can it happen? ‘guix locate’ knows all the manifest format
> version, so maybe it mistook a file for a manifest when in fact it’s
> something else?
>
> Could you ‘strace -o /tmp/log.strace guix locate ls’ to get the name of
> the offending file for now?

The last manifest it reads is
/gnu/var/guix/profiles/per-user/wneuber/guix-profile-1-link/manifest
with the following contents

Toggle snippet (10 lines)
(manifest
(version 1)
(packages
(("gcc"
"4.9.2"
"out"
"/gnu/store/ym7sybrdifnm3g0rafhclv891niaczcv-gcc-4.9.2"
()))))

--
Ricardo
L
L
Ludovic Courtès wrote on 7 Jul 2023 16:03
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 64187@debbugs.gnu.org)
87h6qfkedi.fsf@gnu.org
Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (22 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> However, how can it happen? ‘guix locate’ knows all the manifest format
>> version, so maybe it mistook a file for a manifest when in fact it’s
>> something else?
>>
>> Could you ‘strace -o /tmp/log.strace guix locate ls’ to get the name of
>> the offending file for now?
>
> The last manifest it reads is
> /gnu/var/guix/profiles/per-user/wneuber/guix-profile-1-link/manifest
> with the following contents
>
> (manifest
> (version 1)
> (packages
> (("gcc"
> "4.9.2"
> "out"
> "/gnu/store/ym7sybrdifnm3g0rafhclv891niaczcv-gcc-4.9.2"
> ()))))

Woow, this profile predates May 2015 and commit
dedb17ad010ee9ef67f3f4f3997dd17f226c8090. And indeed, it’s no longer
recognized since e7e04396c0e91569bf493e1352d6539babc15327 (July 2022).

I’ll work on a fix…

Ludo’.
L
L
Ludovic Courtès wrote on 11 Jul 2023 18:22
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 64187-done@debbugs.gnu.org)
87edle2zai.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (30 lines)
> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>> However, how can it happen? ‘guix locate’ knows all the manifest format
>>> version, so maybe it mistook a file for a manifest when in fact it’s
>>> something else?
>>>
>>> Could you ‘strace -o /tmp/log.strace guix locate ls’ to get the name of
>>> the offending file for now?
>>
>> The last manifest it reads is
>> /gnu/var/guix/profiles/per-user/wneuber/guix-profile-1-link/manifest
>> with the following contents
>>
>> (manifest
>> (version 1)
>> (packages
>> (("gcc"
>> "4.9.2"
>> "out"
>> "/gnu/store/ym7sybrdifnm3g0rafhclv891niaczcv-gcc-4.9.2"
>> ()))))
>
> Woow, this profile predates May 2015 and commit
> dedb17ad010ee9ef67f3f4f3997dd17f226c8090. And indeed, it’s no longer
> recognized since e7e04396c0e91569bf493e1352d6539babc15327 (July 2022).
>
> I’ll work on a fix…

Fixed in commit e1c2c2f042e8741c0759e21e634cd2271e078177!

Ludo’.
Closed
R
R
Ricardo Wurmus wrote on 13 Jul 2023 08:46
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 64187-done@debbugs.gnu.org)
87bkggi9z5.fsf@elephly.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (21 lines)
>>> The last manifest it reads is
>>> /gnu/var/guix/profiles/per-user/wneuber/guix-profile-1-link/manifest
>>> with the following contents
>>>
>>> (manifest
>>> (version 1)
>>> (packages
>>> (("gcc"
>>> "4.9.2"
>>> "out"
>>> "/gnu/store/ym7sybrdifnm3g0rafhclv891niaczcv-gcc-4.9.2"
>>> ()))))
>>
>> Woow, this profile predates May 2015 and commit
>> dedb17ad010ee9ef67f3f4f3997dd17f226c8090. And indeed, it’s no longer
>> recognized since e7e04396c0e91569bf493e1352d6539babc15327 (July 2022).
>>
>> I’ll work on a fix…
>
> Fixed in commit e1c2c2f042e8741c0759e21e634cd2271e078177!

Thank you! I confirm that it is now successfully indexing all packages
on the cluster.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64187@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64187
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch