[PATCH] gnu: Add nscde

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
48b10d297346a9edcbedf8a34fa489650545db0b.1687200595.git.atai@atai.org
* gnu/packages/fvwm.scm (nscde): New variable
---
gnu/packages/fvwm.scm | 63 ++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 62 insertions(+), 1 deletion(-)

Toggle diff (99 lines)
diff --git a/gnu/packages/fvwm.scm b/gnu/packages/fvwm.scm
index 872810c658..6201ed0622 100644
--- a/gnu/packages/fvwm.scm
+++ b/gnu/packages/fvwm.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,17 +21,30 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages fvwm)
- #:use-module ((guix licenses) #:select (gpl2+))
+ #:use-module ((guix licenses) #:select (gpl2+ gpl3))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages compton)
+ #:use-module (gnu packages dunst)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fribidi)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages gkrellm)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages shells)
+ #:use-module (gnu packages stalonetray)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))
(define-public fvwm
@@ -81,3 +95,50 @@ (define-public fvwm
window manager for the X Window system.")
(home-page "https://www.fvwm.org/")
(license gpl2+)))
+
+(define-public nscde
+ (package
+ (name "nscde")
+ (version "2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/NsCDE/NsCDE/archive/refs/tags/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "15xjars33k16w1sn6xlmbdfrn6183ah3yj5p8igqc6whdgqxakzw"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config mksh))
+ (inputs (list gettext-minimal
+ fvwm
+ font-dejavu
+ fribidi
+ dunst
+ gkrellm
+ gtk+
+ imagemagick
+ libxpm
+ libxext
+ libxft
+ libxt
+ rofi
+ picom
+ python
+ python-pyyaml
+ python-qtpy
+ stalonetray
+ xclip
+ xdpyinfo
+ xorg-rgb
+ xprop
+ xrefresh
+ xscreensaver
+ xset
+ xsettingsd
+ xterm))
+ (synopsis "Not so Common Desktop Environment")
+ (description "Modern and functional CDE desktop based on FVWM.")
+ (home-page "https://github.com/NsCDE/NsCDE")
+ (license gpl3)))
+

base-commit: dc90c0807d0a46cdd4b0a2c2b3f9becca9f97285
--
2.40.1
Ludovic Courtès wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 64176@debbugs.gnu.org)
874jmvxly7.fsf@gnu.org
Hi,

Andy Tai <atai@atai.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/fvwm.scm (nscde): New variable

Could you address ‘guix lint’ warnings? (Also visible at

Toggle quote (3 lines)
> + (synopsis "Not so Common Desktop Environment")
> + (description "Modern and functional CDE desktop based on FVWM.")

Andy Tai wrote 2 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 64176@debbugs.gnu.org)
CAJsg1E-s3moNM+XvvsVP2FGYuvsgwm-FePNmqmGySvByeomDTQ@mail.gmail.com
will do

On Sun, Jun 25, 2023 at 2:37 PM Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (22 lines)
> Hi,
>
> Andy Tai <atai@atai.org> skribis:
>
> > * gnu/packages/fvwm.scm (nscde): New variable
>
> Could you address ‘guix lint’ warnings? (Also visible at
> <https://qa.guix.gnu.org/issue/64176>.)
>
> > + (synopsis "Not so Common Desktop Environment")
> > + (description "Modern and functional CDE desktop based on FVWM.")
>
> Please see
> <https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html>.
>
> Could you send a v2?
>
> Thanks,
> Ludo’.
>


--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2023 民國112年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Attachment: file
Andy Tai wrote 2 years ago
[PATCH v2] gnu: Add nscde
(name . Andy Tai)(address . atai@atai.org)
723fbb5d03a213c717aca6b87b182a55a991f574.1687740373.git.atai@atai.org
* gnu/packages/fvwm.scm (nscde): New variable
---
gnu/packages/fvwm.scm | 70 ++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 69 insertions(+), 1 deletion(-)

Toggle diff (106 lines)
diff --git a/gnu/packages/fvwm.scm b/gnu/packages/fvwm.scm
index 872810c658..6bda61b6d6 100644
--- a/gnu/packages/fvwm.scm
+++ b/gnu/packages/fvwm.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2023 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,17 +21,30 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages fvwm)
- #:use-module ((guix licenses) #:select (gpl2+))
+ #:use-module ((guix licenses) #:select (gpl2+ gpl3))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages compton)
+ #:use-module (gnu packages dunst)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fribidi)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages gkrellm)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages shells)
+ #:use-module (gnu packages stalonetray)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))
(define-public fvwm
@@ -81,3 +95,57 @@ (define-public fvwm
window manager for the X Window system.")
(home-page "https://www.fvwm.org/")
(license gpl2+)))
+
+(define-public nscde
+ (package
+ (name "nscde")
+ (version "2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/NsCDE/NsCDE/releases/download/"
+ version "/NsCDE-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bm607dvqfdc3ir7l1aswfsfyb2la7rgp0g3023b9v2iksaal5mr"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config mksh))
+ (inputs (list gettext-minimal
+ fvwm
+ font-dejavu
+ fribidi
+ dunst
+ gkrellm
+ gtk+
+ imagemagick
+ libxpm
+ libxext
+ libxft
+ libxt
+ rofi
+ picom
+ python
+ python-pyyaml
+ python-qtpy
+ stalonetray
+ xclip
+ xdpyinfo
+ xorg-rgb
+ xprop
+ xrefresh
+ xscreensaver
+ xset
+ xsettingsd
+ xterm))
+ (synopsis "Modern and functional CDE desktop based on FVWM")
+ (description "NsCDE or Not so Common Desktop Environment is a retro but
+powerful UNIX desktop environment which resembles the CDE look (and partially
+feel) but with a more powerful and flexible framework beneath-the-surface,
+more suited for 21st century unix-like and GNU/Linux systems and user requirements
+than original CDE. NsCDE is a heavyweight FVWM theme on steroids, but combined
+with a couple other free software components and custom FVWM applications and
+a lot of configuration, NsCDE can be considered a lightweight hybrid desktop
+environment")
+ (home-page "https://github.com/NsCDE/NsCDE")
+ (license gpl3)))
+

base-commit: 269cfe341f242c2b5f37774cb9b1e17d9aa68e2c
--
2.40.1
Ludovic Courtès wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 64176@debbugs.gnu.org)
878rbn8o5m.fsf@gnu.org
Hi,

Andy Tai <atai@atai.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/fvwm.scm (nscde): New variable

[...]

Toggle quote (5 lines)
> + (method url-fetch)
> + (uri (string-append
> + "https://github.com/NsCDE/NsCDE/releases/download/"
> + version "/NsCDE-" version ".tar.gz"))

Upon closer inspection, I noticed an unexpected size distribution:

Toggle snippet (52 lines)
$ du -s /tmp/NsCDE-2.3/*|sort -k1 -n
0 /tmp/NsCDE-2.3/LICENSE
4 /tmp/NsCDE-2.3/autogen.sh
4 /tmp/NsCDE-2.3/Makefile.am
4 /tmp/NsCDE-2.3/TODO
8 /tmp/NsCDE-2.3/README.localization
8 /tmp/NsCDE-2.3/README.md
16 /tmp/NsCDE-2.3/INSTALL.md
20 /tmp/NsCDE-2.3/configure.ac
24 /tmp/NsCDE-2.3/patches
24 /tmp/NsCDE-2.3/ReleaseNotes.txt
28 /tmp/NsCDE-2.3/Makefile.in
32 /tmp/NsCDE-2.3/bin
32 /tmp/NsCDE-2.3/ChangeLog
36 /tmp/NsCDE-2.3/COPYING
52 /tmp/NsCDE-2.3/aclocal.m4
76 /tmp/NsCDE-2.3/pkg
140 /tmp/NsCDE-2.3/ac-aux
176 /tmp/NsCDE-2.3/po
244 /tmp/NsCDE-2.3/configure
328 /tmp/NsCDE-2.3/NsCDE.png
496 /tmp/NsCDE-2.3/src
556 /tmp/NsCDE-2.3/nscde_tools
920 /tmp/NsCDE-2.3/autom4te.cache
952 /tmp/NsCDE-2.3/lib
5860 /tmp/NsCDE-2.3/doc
14016 /tmp/NsCDE-2.3/xdg
48712 /tmp/NsCDE-2.3/data
$ du -s /tmp/NsCDE-2.3/xdg/*|sort -k1 -n
4 /tmp/NsCDE-2.3/xdg/Makefile.am
8 /tmp/NsCDE-2.3/xdg/xsessions
16 /tmp/NsCDE-2.3/xdg/Makefile.in
16 /tmp/NsCDE-2.3/xdg/menus
84 /tmp/NsCDE-2.3/xdg/applications
96 /tmp/NsCDE-2.3/xdg/desktop-directories
13788 /tmp/NsCDE-2.3/xdg/icons
$ du -s /tmp/NsCDE-2.3/data/*|sort -k1 -n
4 /tmp/NsCDE-2.3/data/Makefile.am
16 /tmp/NsCDE-2.3/data/help
20 /tmp/NsCDE-2.3/data/Makefile.in
84 /tmp/NsCDE-2.3/data/fontsets
312 /tmp/NsCDE-2.3/data/palettes
316 /tmp/NsCDE-2.3/data/defaults
408 /tmp/NsCDE-2.3/data/fvwm
1092 /tmp/NsCDE-2.3/data/fallback
1672 /tmp/NsCDE-2.3/data/config_templates
4800 /tmp/NsCDE-2.3/data/integration
4968 /tmp/NsCDE-2.3/data/icons
14968 /tmp/NsCDE-2.3/data/photos
20048 /tmp/NsCDE-2.3/data/backdrops

That is, there’s roughly 1 MiB of code for more than 50 MiB of images.

Is GPLv3 really meant to apply to those images? It might be the intent,
but that would be a dubious choice since it’s a software license.

So I think it would be worth checking with upstream the provenance and
licensing of all the artwork here.

WDYT?

Thanks,
Ludo’.
Andy Tai wrote 2 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 64176@debbugs.gnu.org)
CAJsg1E_A7BNmUSbt0tEUyGmL9RGx-Uhy6rZAzmVp_BNTTALm1g@mail.gmail.com
Ok, sure. I did not check these.

On Mon, Jul 10, 2023, 2:14 PM Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (81 lines)
> Hi,
>
> Andy Tai <atai@atai.org> skribis:
>
> > * gnu/packages/fvwm.scm (nscde): New variable
>
> [...]
>
> > + (method url-fetch)
> > + (uri (string-append
> > + "https://github.com/NsCDE/NsCDE/releases/download/"
> > + version "/NsCDE-" version ".tar.gz"))
>
> Upon closer inspection, I noticed an unexpected size distribution:
>
> --8<---------------cut here---------------start------------->8---
> $ du -s /tmp/NsCDE-2.3/*|sort -k1 -n
> 0 /tmp/NsCDE-2.3/LICENSE
> 4 /tmp/NsCDE-2.3/autogen.sh
> 4 /tmp/NsCDE-2.3/Makefile.am
> 4 /tmp/NsCDE-2.3/TODO
> 8 /tmp/NsCDE-2.3/README.localization
> 8 /tmp/NsCDE-2.3/README.md
> 16 /tmp/NsCDE-2.3/INSTALL.md
> 20 /tmp/NsCDE-2.3/configure.ac
> 24 /tmp/NsCDE-2.3/patches
> 24 /tmp/NsCDE-2.3/ReleaseNotes.txt
> 28 /tmp/NsCDE-2.3/Makefile.in
> 32 /tmp/NsCDE-2.3/bin
> 32 /tmp/NsCDE-2.3/ChangeLog
> 36 /tmp/NsCDE-2.3/COPYING
> 52 /tmp/NsCDE-2.3/aclocal.m4
> 76 /tmp/NsCDE-2.3/pkg
> 140 /tmp/NsCDE-2.3/ac-aux
> 176 /tmp/NsCDE-2.3/po
> 244 /tmp/NsCDE-2.3/configure
> 328 /tmp/NsCDE-2.3/NsCDE.png
> 496 /tmp/NsCDE-2.3/src
> 556 /tmp/NsCDE-2.3/nscde_tools
> 920 /tmp/NsCDE-2.3/autom4te.cache
> 952 /tmp/NsCDE-2.3/lib
> 5860 /tmp/NsCDE-2.3/doc
> 14016 /tmp/NsCDE-2.3/xdg
> 48712 /tmp/NsCDE-2.3/data
> $ du -s /tmp/NsCDE-2.3/xdg/*|sort -k1 -n
> 4 /tmp/NsCDE-2.3/xdg/Makefile.am
> 8 /tmp/NsCDE-2.3/xdg/xsessions
> 16 /tmp/NsCDE-2.3/xdg/Makefile.in
> 16 /tmp/NsCDE-2.3/xdg/menus
> 84 /tmp/NsCDE-2.3/xdg/applications
> 96 /tmp/NsCDE-2.3/xdg/desktop-directories
> 13788 /tmp/NsCDE-2.3/xdg/icons
> $ du -s /tmp/NsCDE-2.3/data/*|sort -k1 -n
> 4 /tmp/NsCDE-2.3/data/Makefile.am
> 16 /tmp/NsCDE-2.3/data/help
> 20 /tmp/NsCDE-2.3/data/Makefile.in
> 84 /tmp/NsCDE-2.3/data/fontsets
> 312 /tmp/NsCDE-2.3/data/palettes
> 316 /tmp/NsCDE-2.3/data/defaults
> 408 /tmp/NsCDE-2.3/data/fvwm
> 1092 /tmp/NsCDE-2.3/data/fallback
> 1672 /tmp/NsCDE-2.3/data/config_templates
> 4800 /tmp/NsCDE-2.3/data/integration
> 4968 /tmp/NsCDE-2.3/data/icons
> 14968 /tmp/NsCDE-2.3/data/photos
> 20048 /tmp/NsCDE-2.3/data/backdrops
> --8<---------------cut here---------------end--------------->8---
>
> That is, there’s roughly 1 MiB of code for more than 50 MiB of images.
>
> Is GPLv3 really meant to apply to those images? It might be the intent,
> but that would be a dubious choice since it’s a software license.
>
> So I think it would be worth checking with upstream the provenance and
> licensing of all the artwork here.
>
> WDYT?
>
> Thanks,
> Ludo’.
>
Attachment: file
Ludovic Courtès wrote 1 years ago
Re: bug#64176: [PATCH] gnu: Add nscde
(name . Andy Tai)(address . atai@atai.org)(address . 64176@debbugs.gnu.org)
87ttrw4foz.fsf_-_@gnu.org
Hi,

Andy Tai <atai@atai.org> skribis:

Toggle quote (2 lines)
> Ok, sure. I did not check these.

That was in reply to:

Toggle quote (10 lines)
>> That is, there’s roughly 1 MiB of code for more than 50 MiB of images.
>>
>> Is GPLv3 really meant to apply to those images? It might be the intent,
>> but that would be a dubious choice since it’s a software license.
>>
>> So I think it would be worth checking with upstream the provenance and
>> licensing of all the artwork here.
>>
>> WDYT?

Did you have a chance to check with upstream? What should we do?

TIA,
Ludo’.
Andy Tai wrote 1 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 64176@debbugs.gnu.org)
CAJsg1E_nxoFMeO=2KEgrB5NC3+2j63eYRaE+5pC9QHGZCN77Ew@mail.gmail.com
OK, I will abandon the patch. Too big a size may mean not worth adding to
Guix.

On Thu, Sep 14, 2023 at 2:18 PM Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (25 lines)
> Hi,
>
> Andy Tai <atai@atai.org> skribis:
>
> > Ok, sure. I did not check these.
>
> That was in reply to:
>
> >> That is, there’s roughly 1 MiB of code for more than 50 MiB of images.
> >>
> >> Is GPLv3 really meant to apply to those images? It might be the intent,
> >> but that would be a dubious choice since it’s a software license.
> >>
> >> So I think it would be worth checking with upstream the provenance and
> >> licensing of all the artwork here.
> >>
> >> WDYT?
>
> Did you have a chance to check with upstream? What should we do?
>
> TIA,
> Ludo’.
>


--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2023 民國112年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Attachment: file
Andy Tai wrote 1 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E91uViFofXorQHuGL3ZNdhwZYOTnaibHjnU-jXHhTPG-Q@mail.gmail.com
close 64176
thanks

images license not clear; project size mostly of images; so not add to Guix
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64176@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64176
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help