[PATCH] gnu: recastnavigation: Update to 1.6.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kaelyn Takata
  • Christopher Baines
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal

Debbugs page

Kaelyn Takata wrote 2 years ago
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
6c6200ac3b6af218893eb6bb125f045ba481537a.1687188150.git.kaelyn.alexi@protonmail.com
* gnu/packages/game-development.scm (recastnavigation): Update to 1.6.0 and
fix indentation after removing the LET expression defining the commit and
revision to use.
---
gnu/packages/game-development.scm | 47 +++++++++++++++----------------
1 file changed, 22 insertions(+), 25 deletions(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 431bd5c5e4..aa99109cca 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2809,29 +2809,26 @@ (define-public tesseract-engine
(license license:zlib))))

(define-public recastnavigation
- ;; We follow master since there hasn't been a release since 1.5.1 in 2016.
- (let ((commit "6d1f9711b3b71f28c2c1c0742d76e0ef8766cf91")
- (revision "2"))
- (package
- (name "recastnavigation")
- (version (git-version "1.5.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/recastnavigation/recastnavigation")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0cqp0sbm0ixqnxqz6gf2gybh5l4az91mdsd8b5bgxs1wpl2jmnga"))))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
- "-DRECASTNAVIGATION_DEMO=OFF"
- "-DRECASTNAVIGATION_TESTS=ON"
- "-DRECASTNAVIGATION_EXAMPLES=OFF")))
- (synopsis "Navigation system for games")
- (description "Recast is state of the art navigation mesh
+ (package
+ (name "recastnavigation")
+ (version "1.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/recastnavigation/recastnavigation")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rdz3qmp4b961zjah2ax82h471j14w2rcf576gcyx7vldrg8dmj8"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
+ "-DRECASTNAVIGATION_DEMO=OFF"
+ "-DRECASTNAVIGATION_TESTS=ON"
+ "-DRECASTNAVIGATION_EXAMPLES=OFF")))
+ (synopsis "Navigation system for games")
+ (description "Recast is state of the art navigation mesh
construction toolset for games.

@itemize
@@ -2854,8 +2851,8 @@ (define-public recastnavigation
in and out pieces of the mesh. The tiled mesh allows you to create
systems where you stream new navigation data in and out as the player
progresses the level, or you may regenerate tiles as the world changes.")
- (home-page "https://github.com/recastnavigation/recastnavigation")
- (license license:zlib))))
+ (home-page "https://github.com/recastnavigation/recastnavigation")
+ (license license:zlib)))

(define-public raylib
(package

base-commit: d884fc9e2efecfba09af4694f5a13ad7fc6f704f
--
2.40.1
Christopher Baines wrote 2 years ago
(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)(address . 64170-done@debbugs.gnu.org)
87legdn7il.fsf@cbaines.net
Kaelyn Takata via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (7 lines)
> * gnu/packages/game-development.scm (recastnavigation): Update to 1.6.0 and
> fix indentation after removing the LET expression defining the commit and
> revision to use.
> ---
> gnu/packages/game-development.scm | 47 +++++++++++++++----------------
> 1 file changed, 22 insertions(+), 25 deletions(-)

Thanks for the patch, I've pushed it to master as
744c979b8fdda5a66490b90327db543be3276380.

I did shorten the commit message a bit, as I don't think it's necessary
to describe the indentation change.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmSSGzJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdsGBAAj66+RaYuFF0RzysgXhqeoAUKFxWx6Cep
2kbRfQq5SHTCYZnQnn/+6ASxsB8Cbvl98Zl7dn2v0z61VvUdHlcL0hx8RLPJA+eD
eE7CQ3CuCBU9crGr8dJHh+lwwJRmI+otClPLLq9ph7Y0uZQHy/NyI8XByCAuxZF/
Vt2ShoZ6hYfZcWmk1MsJNrgj1QtN+nKCBAprW5JFVZLwGTB9wpvj+C3KsMT0JprY
HuzELlOIJjuqfH5g6Zldal3yqZUSp7K3p7n46MvB9aJyI0nPamZyE2SeIPdrcdLB
XROnVd8rUzl1tcso29q3xqzm9xcDh6ox+d9T2c0+bQ2LihHZcY/euxOtNlTs3QGV
Ptm/hxmPt12E+oGl/bGGhG7flJzyHSNGLCqJgG6P8vGX+Mh10kRlvuufH8jtq0V2
IYm1rroMKvBKbd/Q2qZvv/pUHK+MyCZvQHq9aXvaqRcon5eROgaKe7/C6UFPbYfj
rG2as0Gn2TdBGlIHo9qYwophmaHRlILZmJo3KD+hl3jKVEX5zvf0pZYgSW/rS9Q9
w5/QWnijPxqu18pO5dn7/NgH4SUNu+13pSnlKwhr8czogx5wT2CMz//Rzk+cjSdO
ECppPmdFRNKdMhPwq8mE1oobDMWo/fJ8Aai32G333yq4jWNF/wHqCdIHLq7zEi+a
FNwTWBsev5I=
=lARu
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64170@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64170
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help