[PATCH] services: shepherd: Sanitize 'provision' field.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 16 Jun 2023 22:25
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
9770a88a008fd1d087e829a6ad57b556346be9c0.1686947093.git.mirai@makinata.eu

* gnu/services/shepherd.scm (<shepherd-service>)[provision]: Set field
sanitizer.
(sanitize-shepherd-service-provision): New procedure.
---
gnu/services/shepherd.scm | 13 ++++++++++++-
1 file changed, 12 insertions(+), 1 deletion(-)

Toggle diff (47 lines)
diff --git a/gnu/services/shepherd.scm b/gnu/services/shepherd.scm
index de40454f7d..1333067817 100644
--- a/gnu/services/shepherd.scm
+++ b/gnu/services/shepherd.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu services shepherd)
+ #:use-module (guix diagnostics)
#:use-module (guix ui)
#:use-module (guix sets)
#:use-module (guix gexp)
@@ -186,12 +188,21 @@ (define %default-modules
((guix build utils) #:hide (delete))
(guix build syscalls)))
+(define (sanitize-shepherd-service-provision expr)
+ (match expr
+ (((? symbol?) ..1) expr)
+ (_
+ (raise
+ (formatted-message
+ (G_ "'provision' must be a non-empty list of symbols"))))))
+
(define-record-type* <shepherd-service>
shepherd-service make-shepherd-service
shepherd-service?
(documentation shepherd-service-documentation ;string
(default "[No documentation.]"))
- (provision shepherd-service-provision) ;list of symbols
+ (provision shepherd-service-provision ;list of symbols
+ (sanitize sanitize-shepherd-service-provision))
(requirement shepherd-service-requirement ;list of symbols
(default '()))
(one-shot? shepherd-service-one-shot? ;Boolean

base-commit: 31336e9f5d68512a9c1c6826bce9f17c892a2125
--
2.39.2
L
L
Ludovic Courtès wrote on 25 Jun 2023 23:08
(name . Bruno Victal)(address . mirai@makinata.eu)
87cz1jxnaz.fsf@gnu.org
Hi Bruno,

Bruno Victal <mirai@makinata.eu> skribis:

Toggle quote (6 lines)
>
> * gnu/services/shepherd.scm (<shepherd-service>)[provision]: Set field
> sanitizer.
> (sanitize-shepherd-service-provision): New procedure.

Applied, thanks!

Ludo’.
Closed
L
L
Ludovic Courtès wrote on 25 Jun 2023 23:44
(name . Bruno Victal)(address . mirai@makinata.eu)
87o7l3w71m.fsf@gnu.org
Bruno Victal <mirai@makinata.eu> skribis:

Toggle quote (8 lines)
> +(define (sanitize-shepherd-service-provision expr)
> + (match expr
> + (((? symbol?) ..1) expr)
> + (_
> + (raise
> + (formatted-message
> + (G_ "'provision' must be a non-empty list of symbols"))))))

Actually I figured we could do as in other areas of the code in a way
that reports error location, so I came up with a different patch.

Ludo’.
?