[PATCH] gnu: libx11: Replace with 1.8.6 [security and bug fixes]

  • Done
  • quality assurance status badge
Details
2 participants
  • Kaelyn Takata
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Kaelyn Takata
Severity
normal

Debbugs page

Kaelyn Takata wrote 2 years ago
(address . guix-patches@gnu.org)(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)
ab3360296e0d6eb7b903365f9b8bb319c8d46401.1686941245.git.kaelyn.alexi@protonmail.com
Includes fix for: CVE-2023-3138.

* gnu/packages/xorg.scm (libx11-fixed): New variable.
(libx11)[replacement]: Graft.
---
gnu/packages/xorg.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index e1a7cf96f9..49a70b1e07 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5254,6 +5254,7 @@ (define-public libx11
(package
(name "libx11")
(version "1.8.1")
+ (replacement libx11-fixed) ; security fixes
(source
(origin
(method url-fetch)
@@ -5283,6 +5284,19 @@ (define-public libx11
(description "Xorg Core X11 protocol client library.")
(license license:x11)))

+(define-public libx11-fixed
+ (package
+ (inherit libx11)
+ (version "1.8.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://xorg/individual/lib/libX11-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1jawl8zp1h7hdmxx1sc6kmxkki187d9yixr2l03ai6wqqry5nlsr"))))))
+
;; packages of height 5 in the propagated-inputs tree

(define-public libxcursor

base-commit: 31336e9f5d68512a9c1c6826bce9f17c892a2125
--
2.40.1
Maxim Cournoyer wrote 2 years ago
(name . Kaelyn Takata)(address . kaelyn.alexi@protonmail.com)(address . 64116-done@debbugs.gnu.org)
87ledowgtt.fsf@gmail.com
Hi,

Kaelyn Takata <kaelyn.alexi@protonmail.com> writes:

Toggle quote (5 lines)
> Includes fix for: CVE-2023-3138.
>
> * gnu/packages/xorg.scm (libx11-fixed): New variable.
> (libx11)[replacement]: Graft.

Installed, thank you!

--
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64116@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64116
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help