[PATCH 0/2] gnu: zrythm: Enable rtaudio.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sughosha
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Sughosha
Severity
normal

Debbugs page

Sughosha wrote 2 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
KcqZvcfkNVYOukI4xeqb8llOpZncj-vnS4IIz3EkZxNb-Xb231w1ld_F7Y9TKGlbDSvDjKXFUddCqgi5aB0lEzH8q7GsllIGP_xEpzmDICU=@proton.me
Sughosha (2):
[1/2] gnu: rtaudio: Update to 5.2.0.
[2/2] gnu: zrythm: Enable rtaudio.

gnu/packages/audio.scm | 16 ++--------------
gnu/packages/music.scm | 2 ++
2 files changed, 4 insertions(+), 14 deletions(-)


base-commit: 34d973018608cce1532a7832b540333a50fe59f6
Sughosha wrote 2 years ago
[PATCH 1/2] gnu: rtaudio: Update to 5.2.0.
(name . 64103@debbugs.gnu.org)(address . 64103@debbugs.gnu.org)
B4HoM6cnvWrdFpCXZgd2IcWeoQp1TocbhuyI-TL6m5qw3oRTzTPuOGszL80b36AuB4B8StmLBlZ95VRAbmt0QuAIRiDcgpfti3ol0-yaa-4=@proton.me
* gnu/packages/audio.scm (rtaudio): Update to 5.2.0.
[#:phases]: Delete argument.
---
gnu/packages/audio.scm | 16 ++--------------
1 file changed, 2 insertions(+), 14 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 58a981b..46f8a86 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2809,29 +2809,17 @@ (define-public liblo
(define-public rtaudio
(package
(name "rtaudio")
- (version "5.1.0")
+ (version "5.2.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/thestk/rtaudio")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "156c2dgh6jrsyfn1y89nslvaxm4yifmxridsb708yvkaym02w2l8"))))
+ (base32 "189xphhf0winf8b60dx1kk2biz811wk6ps44br7l1lyfhymxcjmi"))))
(build-system cmake-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; The header that pkg-config expects is include/rtaudio/RtAudio.h,
- ;; but this package installs it as include/RtAudio.h by default.
- (add-after 'install 'fix-inc-path
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (inc (string-append out "/include")))
- (mkdir-p (string-append inc "/rtaudio"))
- (rename-file (string-append inc "/RtAudio.h")
- (string-append inc "/rtaudio/RtAudio.h"))))))))
(native-inputs
(list pkg-config))
(inputs
--
libgit2 1.5.1
Sughosha wrote 2 years ago
[PATCH 2/2] gnu: zrythm: Enable rtaudio.
(name . 64103@debbugs.gnu.org)(address . 64103@debbugs.gnu.org)
FI7OQjFSpV24BzcdkwkuYGdMtiUPUwMqx_yBqSfYQf1VNI3X1cSn6Nq5pTTYYmlfDfVe0JIUX1f6SGrSK_jbZlkgko-R5Z1_Yq5pJ_6Yj5c=@proton.me
* gnu/packages/music.scm (zrythm)[#:configure-flags]: Add
"-Drtaudio=enabled".
[inputs]: Add rtaudio.
---
gnu/packages/music.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (20 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2e7edda..cae0a3e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6509,6 +6509,7 @@ (define-public zrythm
"-Dgraphviz=enabled" ;for exporting routing graphs
"-Dguile=enabled" ;for Guile scripting
"-Djack=enabled" ;for JACK audio/MIDI backend
+ "-Drtaudio=enabled" ;for RtAudio backend (ALSA)
"-Drtmidi=enabled" ;for RtMidi backend (ALSA sequencer)
"-Dsdl=enabled") ;for SDL audio backend (which uses ALSA)
#:phases
@@ -6590,6 +6591,7 @@ (define-public zrythm
pipewire
pulseaudio
reproc
+ rtaudio
rtmidi
rubberband
sdl2
--
libgit2 1.5.1
Maxim Cournoyer wrote 2 years ago
Re: bug#64103: [PATCH 0/2] gnu: zrythm: Enable rtaudio.
(name . Sughosha)(address . Sughosha@proton.me)(address . 64103-done@debbugs.gnu.org)
87v8cn9akc.fsf@gmail.com
Hello,

Sughosha <Sughosha@proton.me> writes:

Toggle quote (4 lines)
> Sughosha (2):
> [1/2] gnu: rtaudio: Update to 5.2.0.
> [2/2] gnu: zrythm: Enable rtaudio.

Series installed.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64103@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64103
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help