[PATCH] gnu: emacs-gptel: Add optional propagated-input.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)
aaa6687b9b36351515fbfd32e652f2dc03b9d935.1686713881.git.jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-gptel): Add optional propagated-input.
[propagated-inputs]: Add emacs-markdown-mode
---

hi guix wdyt

what should we do about dependencies like this that are optional
according to upstream but might enable important features in a package
like markdown rendering.

l8terzzz,

jgart

gnu/packages/emacs-xyz.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f46af73aec..32ab18bd81 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -477,7 +477,8 @@ (define-public emacs-gptel
(emacs-substitute-variables "gptel.el"
("gptel-use-curl" 't)))))))
(inputs (list curl))
- (propagated-inputs (list emacs-map))
+ (propagated-inputs
+ (list emacs-map emacs-markdown-mode))
(home-page "https://github.com/karthink/gptel")
(synopsis "GPTel is a simple ChatGPT client for Emacs")
(description

base-commit: b94cbbbce70f59b795526a0ed305facf041e6faa
prerequisite-patch-id: 955d53943a944fc71068775e0535d85c0f0b71ec
prerequisite-patch-id: b40ddb3f1c2f780c18f34b826b1229bb10358ec7
prerequisite-patch-id: 35ea140df746960cf9b020cb8abb74e6889b056c
--
2.40.1
A
A
Andrew Tropin wrote on 14 Jun 2023 07:46
87fs6uioj9.fsf@trop.in
On 2023-06-13 22:41, jgart wrote:

Toggle quote (37 lines)
> * gnu/packages/emacs-xyz.scm (emacs-gptel): Add optional propagated-input.
> [propagated-inputs]: Add emacs-markdown-mode
> ---
>
> hi guix wdyt
>
> what should we do about dependencies like this that are optional
> according to upstream but might enable important features in a package
> like markdown rendering.
>
> l8terzzz,
>
> jgart
>
> gnu/packages/emacs-xyz.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index f46af73aec..32ab18bd81 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -477,7 +477,8 @@ (define-public emacs-gptel
> (emacs-substitute-variables "gptel.el"
> ("gptel-use-curl" 't)))))))
> (inputs (list curl))
> - (propagated-inputs (list emacs-map))
> + (propagated-inputs
> + (list emacs-map emacs-markdown-mode))
> (home-page "https://github.com/karthink/gptel")
> (synopsis "GPTel is a simple ChatGPT client for Emacs")
> (description
>
> base-commit: b94cbbbce70f59b795526a0ed305facf041e6faa
> prerequisite-patch-id: 955d53943a944fc71068775e0535d85c0f0b71ec
> prerequisite-patch-id: b40ddb3f1c2f780c18f34b826b1229bb10358ec7
> prerequisite-patch-id: 35ea140df746960cf9b020cb8abb74e6889b056c

IMHO, optional dependencies in most cases should not be propagated by
the package, to make it possible to manage them on the user side in a
more flexible way.

Closing this ticket without merging, let me know if you have other
thoughts or opinions on the topic.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmSJVEoACgkQIgjSCVjB
3rB16hAAj6+Pa3dGYpXa17MYpiMsr13zKoLur5RA4Im44K2TCKI9UDHPXssI3C/g
QYOqHZahcyNbeWHS9k0mAw0h4/07zpulTcIwHMHEi7KDcJIZv7PVBf4EbHjMD0Nl
VRPOjTh9KQoUz8u4hTbSShNUf3qealwsChPYCBwAT2FDlsMMgoPPMYCjhaNBylRL
Yh06rM+c+pZfhWtD6LYTgKJip7MXKs5ZaopodAkDNCETvKdXpKEFFe1ahRX4uLmM
w1Z5pNeLJlcfsWIHSR99o4ElTN3N+nW4JQxoRD+wV2+vO/ZxoMtxiu1HFsfvjoYO
+5h6iS4ECaOUqmSwBs5vmbFo7bEsyFlU39zZLh+55fyOrpVCk3V/UcHMMDEVcoLJ
Zl/Rea8GGJ/nm+ytMyFzS75BXGX4YKU2aYyamJ121Osbq/GTyc7S6MbaGzxD6Iz5
a/pmgJkpyXJ+dErbRqtS707gXAQLOCTDTD3nrOj1GnqqVJXcmiFh6xNnRAIwH+x2
cLWU4296Yqn30CuS6RXLWTC0ZtGuB9hElnEMyL2PO7YdOmRQobGP0S3vmau1pwyp
e3v78MN9WL+yy4GNtKgbnOS4u8X1zgR73JcUKmEUt683vB4LDiGzVWdzau7xkxft
O6PY7X6LanyIcWJxZbVc9GCnOrbhSpz0M5y+KZnn/ilIWwF+xKo=
=EVLU
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64060@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64060
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch