[PATCH] gnu: Add xiate.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • mekeor
Owner
unassigned
Submitted by
mekeor
Severity
normal
M
M
mekeor wrote on 13 Jun 2023 00:12
(address . guix-patches@gnu.org)
d99dbbede5f33c76d3ff4e81d10dbda1f4e94cb1.1686610408.git.mekeor@posteo.de
* gnu/packages/terminals.scm (xiate): New variable.
---
gnu/packages/terminals.scm | 43 ++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index e3d0937ecc..80d39cc761 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -938,6 +938,49 @@ (define-public sakura
desktop installed to have a decent terminal emulator.")
(license license:gpl2)))
+(define-public xiate
+ (let
+ ((commit "ae3cf30b345c64f097a747ac848e23ef5bae8b57")
+ (revision "0"))
+ (package
+ (name "xiate")
+ (version (git-version "21.12" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (uri
+ (git-reference
+ (url "https://www.uninformativ.de/git/xiate.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0bc205b1gs1jvp1a2cr814l32hmlm0sgv1drfw7ykbavslfpmg2d"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:make-flags
+ #~(list
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "prefix=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'patch-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("/usr/local") #$output)))))))
+ (inputs (list gtk+ glib vte))
+ (native-inputs (list pkg-config))
+ (synopsis "Minimalist terminal emulator based on GTK+")
+ (description "Xiate is a terminal emulator which tries to keep a balance
+between features and simplicity. This is achieved by using VTE as a powerful
+backend, while UI, configuration, and code try to remain much more
+minimalistic.")
+ (home-page "https://www.uninformativ.de/git/xiate/file/README.html")
+ (license license:expat))))
+
(define-public go-github.com-nsf-termbox-go
(let ((commit "288510b9734e30e7966ec2f22b87c5f8e67345e3")
(revision "1"))

base-commit: 44bbfc24e4bcc48d0e3343cd3d83452721af8c36
--
2.39.2
M
M
Mekeor Melire wrote on 14 Jun 2023 20:52
[PATCH v2] gnu: Add xiate.
(address . 64030@debbugs.gnu.org)(name . Mekeor Melire)(address . mekeor@posteo.de)
dab4038a040eab509cde3820e33edf92547f9f7c.1686768759.git.mekeor@posteo.de
* gnu/packages/terminals.scm (xiate): New variable.
---
gnu/packages/terminals.scm | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index e3d0937ecc..6dada660d3 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -938,6 +938,44 @@ (define-public sakura
desktop installed to have a decent terminal emulator.")
(license license:gpl2)))
+(define-public xiate
+ (let
+ ((commit "ae3cf30b345c64f097a747ac848e23ef5bae8b57")
+ (revision "0"))
+ (package
+ (name "xiate")
+ (version (git-version "21.12" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (uri
+ (git-reference
+ (url "https://www.uninformativ.de/git/xiate.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0bc205b1gs1jvp1a2cr814l32hmlm0sgv1drfw7ykbavslfpmg2d"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no tests
+ #:make-flags
+ #~(list
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "prefix=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases (delete 'configure))))
+ (inputs (list gtk+ glib vte))
+ (native-inputs (list pkg-config))
+ (synopsis "Minimalist terminal emulator based on GTK+")
+ (description "Xiate is a terminal emulator which tries to keep a balance
+between features and simplicity. This is achieved by using VTE as a powerful
+backend, while UI, configuration, and code try to remain much more
+minimalistic.")
+ (home-page "https://www.uninformativ.de/git/xiate/file/README.html")
+ (license license:expat))))
+
(define-public go-github.com-nsf-termbox-go
(let ((commit "288510b9734e30e7966ec2f22b87c5f8e67345e3")
(revision "1"))

base-commit: 44bbfc24e4bcc48d0e3343cd3d83452721af8c36
--
2.39.2
L
L
Ludovic Courtès wrote on 20 Jun 2023 23:53
Re: bug#64030: [PATCH] gnu: Add xiate.
(name . Mekeor Melire)(address . mekeor@posteo.de)(address . 64030-done@debbugs.gnu.org)
87wmzxajhm.fsf_-_@gnu.org
Hi,

Mekeor Melire <mekeor@posteo.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/terminals.scm (xiate): New variable.

Applied, but…

Toggle quote (7 lines)
> + (let
> + ((commit "ae3cf30b345c64f097a747ac848e23ef5bae8b57")
> + (revision "0"))
> + (package
> + (name "xiate")
> + (version (git-version "21.12" revision commit))

… the commit apparently corresponds to 22.12, so I changed the versionm
number accordingly.

I also passed it through ‘guix style’.

Thanks,
Ludo’.
Closed
?