[PATCH] gnu: maven-model-builder@3.0: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 12 Jun 2023 20:23
(address . guix-patches@gnu.org)
b4c5f5f100d515f29497ba8ab23665262fd9b17a.1686595282.git.liliana.prikler@gmail.com
* gnu/packages/maven.scm (maven-3.0-model-builder)[#:phases]: Add
‘add-components-shebang’.
---
gnu/packages/maven.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/maven.scm b/gnu/packages/maven.scm
index a805bda8e5..dc25f7640e 100644
--- a/gnu/packages/maven.scm
+++ b/gnu/packages/maven.scm
@@ -2424,6 +2424,10 @@ (define-public maven-3.0-model-builder
(substitute-keyword-arguments (package-arguments maven-model-builder)
((#:phases phases)
`(modify-phases ,phases
+ (add-after 'unpack 'add-components-shebang
+ (lambda _
+ (substitute* "components.sh"
+ (("^## T") "#!/bin/sh\n## T"))))
(add-before 'build 'generate-components.xml
(lambda _
(mkdir-p "build/classes/META-INF/plexus")

base-commit: 3fc26c6dc4b6bbf558a17b5e3ef8092ea0eeeacd
--
2.40.1
L
L
Ludovic Courtès wrote on 20 Jun 2023 23:47
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
871qi5bybu.fsf@gnu.org
Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

Toggle quote (3 lines)
> * gnu/packages/maven.scm (maven-3.0-model-builder)[#:phases]: Add
> ‘add-components-shebang’.

Hi! Go for it!

Ludo’.
L
L
Liliana Marie Prikler wrote on 21 Jun 2023 06:20
(name . Ludovic Courtès)(address . ludo@gnu.org)
e6e88288a77e188d926b9fee58374dd94b5b0e07.camel@gmail.com
Am Dienstag, dem 20.06.2023 um 23:47 +0200 schrieb Ludovic Courtès:
Toggle quote (6 lines)
> Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
>
> > * gnu/packages/maven.scm (maven-3.0-model-builder)[#:phases]: Add
> > ‘add-components-shebang’.
>
> Hi!  Go for it!
Already did, but apparently forgot to mark as done.
Other maven-3.0 packages seem to have the same issue, however.

Cheers
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64026@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64026
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch