[PATCH] gnu: gajim: Update to 1.7.3.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Christopher Baines
  • Parnikkapore
Owner
unassigned
Submitted by
Parnikkapore
Severity
normal
P
P
Parnikkapore wrote on 12 Jun 2023 16:50
(address . guix-patches@gnu.org)
d843f47ac84e5578ba9ed9f441c59ed83a448a4d.1686581089.git.poomklao@yahoo.com
* gnu/packages/messaging.scm (python-nbxmpp): Update to 4.2.2.
[arguments]: Specify "python -m unittest" as test method,
[inputs]: Move python dependencies to propagated-inputs.
[propagated-inputs]: Likewise.
* gnu/packages/messaging.scm (gajim): Update to 1.7.3.
[arguments]: Switch to "python -m build".
To use pyproject-build-system, support for backend-path is needed.
[arguments]: Add metadata build and install phase.
[arguments]: Switch to "python -m unittest" as test method,
following upstream recommendation.
[arguments]: Generate gdk-pixbuf cache and include result in wrapper.
Allows Gajim to run in pure environments.
[native-search-paths]: Update.
* gnu/packages/messaging.scm (gajim-omemo): Update to 2.9.0.
* gnu/packages/messaging.scm (gajim-openpgp): Update to 1.5.0.
---

Here's a resend of https://issues.guix.gnu.org/63494which is rebased
on top of current master. https://issues.guix.gnu.org/63594is already
included.

however, it requires python-protobuf >=4.21.0, which is not yet
packaged to Guix standards.

Again, sorry for consolidating the changes (and for `guix style`-ing python-nbxmpp)!

gnu/packages/messaging.scm | 127 +++++++++++++++++++++----------------
1 file changed, 72 insertions(+), 55 deletions(-)

Toggle diff (237 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 00897ea451..58a3eaaf22 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -148,6 +148,7 @@ (define-module (gnu packages messaging)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system qt)
#:use-module (guix build-system trivial)
#:use-module (guix download)
@@ -1088,27 +1089,34 @@ (define-public znc
(define-public python-nbxmpp
(package
(name "python-nbxmpp")
- (version "3.1.0")
- (source
- (origin
- (method url-fetch)
- (uri
- (pypi-uri "nbxmpp" version))
- (sha256
- (base32 "0c32090gr1fiy7hkn73dcj4ad9gfdpks8hivl1dl8bql01jsfdnj"))))
- (build-system python-build-system)
- (native-inputs
- (list `(,glib "bin")))
- (inputs
- (list glib
- glib-networking
- libsoup-minimal-2
- python-gssapi
- python-idna
- python-precis-i18n
- python-pygobject))
+ (version "4.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "nbxmpp" version))
+ (sha256
+ (base32
+ "095nyy6vjildhrqigxk6vsh49in6mx17bvb3z5zpjmzhv9b8ix46"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ ;; XXX: This probably should be an option for pyproject-build-system
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest" "-v")))))))
+ (native-inputs (list `(,glib "bin")))
+ (inputs (list glib
+ glib-networking
+ libsoup-minimal))
+ (propagated-inputs (list
+ python-gssapi
+ python-idna
+ python-packaging
+ python-precis-i18n
+ python-pygobject))
(synopsis "Non-blocking XMPP Module")
- (description "Python-nbxmpp is a Python library that provides a way for
+ (description
+ "Python-nbxmpp is a Python library that provides a way for
Python applications to use the XMPP network. This library was initially a fork
of xmpppy.")
(home-page "https://dev.gajim.org/gajim/python-nbxmpp")
@@ -1117,7 +1125,7 @@ (define-public python-nbxmpp
(define-public gajim
(package
(name "gajim")
- (version "1.4.7")
+ (version "1.7.3")
(source
(origin
(method url-fetch)
@@ -1126,7 +1134,7 @@ (define-public gajim
(version-major+minor version)
"/gajim-" version ".tar.gz"))
(sha256
- (base32 "1ww46qlxr14nq0ka8wsf8qpn5qfi5dvgyksfh9411crl7azhfj0s"))
+ (base32 "066kvkjw3qcdanr3nczy0wgcwihk9jc9zhzfr5bwlqvcyxcv7k5p"))
(patches (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
(build-system python-build-system)
(arguments
@@ -1139,13 +1147,27 @@ (define-public gajim
#:prefix glib-or-gtk:)
(guix build utils))
#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
+ ,#~(modify-phases %standard-phases
+ (add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'generate-gdk-pixbuf-loaders-cache-file))
+ (add-before 'build 'build-metadata
+ (lambda _
+ (invoke "./pep517build/build_metadata.py" "-o" "dist/metadata")))
+ ;; TODO: Change to pyproject-build-system once it supports
+ ;; in-tree build backends.
+ (replace 'build
(lambda _
- ;; XXX Gajim builds fine on some (my) machines but fails elsewhere:
- ;; ModuleNotFoundError: No module named 'gajim.gui.emoji_data'
- ;; https://dev.gajim.org/gajim/gajim/-/issues/11041
- (delete-file "test/no_gui/test_styling.py")))
+ (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+ (replace 'install
+ (lambda _
+ (apply invoke "pip" "--no-cache-dir" "--no-input"
+ "install" "--no-deps" "--prefix" #$output
+ (find-files "dist" "\\.whl$"))))
+ (add-after 'install 'install-metadata
+ (lambda _
+ (invoke "./pep517build/install_metadata.py" "dist/metadata"
+ (string-append "--prefix=" #$output))))
(replace 'check
(lambda _
;; Tests require a running X server.
@@ -1153,35 +1175,30 @@ (define-public gajim
(setenv "DISPLAY" ":1")
;; For missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
- (invoke "dbus-launch" "python" "./setup.py" "test")))
- ;; Loading gajim_remote require running session bus,
- ;; which in-turn requires running elogind for XDG_RUNTIME_DIR;
- ;; neither of which are possible inside build environment.
- (delete 'sanity-check)
+ (invoke "dbus-launch" "python" "-m" "unittest" "discover" "-s" "test")))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
(add-after 'install 'wrap-env
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (for-each
- (lambda (name)
- (let ((file (string-append out "/bin/" name))
- (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
- (wrap-program file
- `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))))
- '("gajim" "gajim-remote"))))))))
+ (lambda _
+ (for-each
+ (lambda (name)
+ (let ((file (string-append #$output "/bin/" name))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
+ (pixbuf-module-file (getenv "GDK_PIXBUF_MODULE_FILE")))
+ (wrap-program file
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
+ `("GDK_PIXBUF_MODULE_FILE" = (,pixbuf-module-file)))))
+ '("gajim" "gajim-remote")))))))
(native-search-paths
(list
(search-path-specification
(variable "GAJIM_PLUGIN_PATH")
- (separator #f) ;single entry
- (files
- (list
- "share/gajim/plugins")))
+ (separator #f) ; single entry
+ (files (list "share/gajim/plugins")))
;; Gajim needs to use the propagated inputs of its plugins.
(search-path-specification
(variable "GUIX_PYTHONPATH")
@@ -1192,7 +1209,7 @@ (define-public gajim
;; FIXME: Cannot use this expression as it would
;; introduce a circular dependency at the top level.
;; (version-major+minor (package-version python))
- "3.9"
+ "3.10"
"/site-packages"))))))
(native-inputs
(list gettext-minimal
@@ -1200,6 +1217,7 @@ (define-public gajim
gobject-introspection
`(,gtk+ "bin")
python-distutils-extra
+ python-pypa-build
python-setuptools
xorg-server-for-tests))
(inputs
@@ -1235,8 +1253,7 @@ (define-public gajim
python-pycairo
python-pygobject
python-pyopenssl))
- (propagated-inputs
- (list dconf))
+ (propagated-inputs (list dconf))
(synopsis "Fully-featured XMPP client")
(description "Gajim aims to be an easy to use and fully-featured XMPP chat
client. It is extensible via plugins, supports end-to-end encryption (OMEMO
@@ -1247,7 +1264,7 @@ (define-public gajim
(define-public gajim-omemo
(package
(name "gajim-omemo")
- (version "2.8.15")
+ (version "2.9.0")
(source
(origin
(method url-fetch/zipbomb)
@@ -1256,7 +1273,7 @@ (define-public gajim-omemo
"https://ftp.gajim.org/plugins/master/omemo/omemo_"
version ".zip"))
(sha256
- (base32 "1hf148ywr8knk5y3y5xvvwgw74ld1pcfjkp78g514ikcnzfycfcn"))))
+ (base32 "0yy9r9fsrlgdywiln8bskhi8faj9hnz7b19jcap5nkhv8jn9cqq7"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
@@ -1283,7 +1300,7 @@ (define-public gajim-omemo
(define-public gajim-openpgp
(package
(name "gajim-openpgp")
- (version "1.4.9")
+ (version "1.5.0")
(source
(origin
(method url-fetch/zipbomb)
@@ -1292,7 +1309,7 @@ (define-public gajim-openpgp
"https://ftp.gajim.org/plugins/master/openpgp/openpgp_"
version ".zip"))
(sha256
- (base32 "1xwmf6ai1z7z9x6p1ysglxji73r7d27c0gzc8ykab29cjhjyv0dq"))))
+ (base32 "193pbh9iri7bkamvjwp236i8g5zxxiqgsv64kll5sy76vx4q73c4"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))

base-commit: dffaf42e5eac3822bd6b44e9749fc8e5f48fb99c
--
2.34.1
L
L
Ludovic Courtès wrote on 20 Jun 2023 23:46
(name . Parnikkapore)(address . poomklao@yahoo.com)(address . 64021@debbugs.gnu.org)
875y7hbydi.fsf_-_@gnu.org
Hi Parnikkapore,

Parnikkapore <poomklao@yahoo.com> skribis:

Toggle quote (27 lines)
> * gnu/packages/messaging.scm (python-nbxmpp): Update to 4.2.2.
> [arguments]: Specify "python -m unittest" as test method,
> [inputs]: Move python dependencies to propagated-inputs.
> [propagated-inputs]: Likewise.
> * gnu/packages/messaging.scm (gajim): Update to 1.7.3.
> [arguments]: Switch to "python -m build".
> To use pyproject-build-system, support for backend-path is needed.
> [arguments]: Add metadata build and install phase.
> [arguments]: Switch to "python -m unittest" as test method,
> following upstream recommendation.
> [arguments]: Generate gdk-pixbuf cache and include result in wrapper.
> Allows Gajim to run in pure environments.
> [native-search-paths]: Update.
> * gnu/packages/messaging.scm (gajim-omemo): Update to 2.9.0.
> * gnu/packages/messaging.scm (gajim-openpgp): Update to 1.5.0.
> ---
>
> Here's a resend of https://issues.guix.gnu.org/63494 which is rebased
> on top of current master. https://issues.guix.gnu.org/63594 is already
> included.
>
> I have gotten Gajim 1.8 working in Guix (see https://codeberg.org/Parnikkapore/guix-ngapsh-unsigned/src/commit/cc3069a118995e98ff971d51d36689ea6ceef366/pnkp/guix/packages/messaging.scm);
> however, it requires python-protobuf >=4.21.0, which is not yet
> packaged to Guix standards.
>
> Again, sorry for consolidating the changes (and for `guix style`-ing python-nbxmpp)!

This is great and it passes according to
https://qa.guix.gnu.org/issue/64021. However, for clarity, could you
please resubmit it with one change by patch—that is, one patch for
python-nbxmpp, one for gajim, one for the gajim-omemo, etc.?

Sorry for asking for extra work but that’s an important part of
simplifying review as well as bisecting!

Thanks,
Ludo’.
C
C
Christopher Baines wrote on 26 Jun 2023 10:51
tag 64021 moreinfo
(address . control@debbugs.gnu.org)
87h6qu7gjf.fsf@cbaines.net
tags 64021 + moreinfo
quit
P
P
Parnikkapore wrote on 4 Jul 2023 18:31
[PATCH v2 1/6] gnu: python-nbxmpp: Update to 4.2.2.
(address . 64021@debbugs.gnu.org)
61a27ed52288bab9945aa256a1193e6956b60616.1688488273.git.poomklao@yahoo.com
* gnu/packages/messaging.scm (python-nbxmpp): Update to 4.2.2.
[arguments]: Specify "python -m unittest" as test method.
Gajim will not build at this commit.
---
gnu/packages/messaging.scm | 16 ++++++++++++----
1 file changed, 12 insertions(+), 4 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3629d9a6d5..1b721e8f8e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -148,6 +148,7 @@ (define-module (gnu packages messaging)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system qt)
#:use-module (guix build-system trivial)
#:use-module (guix download)
@@ -1089,21 +1090,28 @@ (define-public znc
(define-public python-nbxmpp
(package
(name "python-nbxmpp")
- (version "3.1.0")
+ (version "4.2.2")
(source
(origin
(method url-fetch)
(uri
(pypi-uri "nbxmpp" version))
(sha256
- (base32 "0c32090gr1fiy7hkn73dcj4ad9gfdpks8hivl1dl8bql01jsfdnj"))))
- (build-system python-build-system)
+ (base32 "095nyy6vjildhrqigxk6vsh49in6mx17bvb3z5zpjmzhv9b8ix46"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; XXX: This probably should be an option for pyproject-build-system
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "python" "-m" "unittest" "-v")))))))
(native-inputs
(list `(,glib "bin")))
(inputs
(list glib
glib-networking
- libsoup-minimal-2
+ libsoup-minimal
python-gssapi
python-idna
python-precis-i18n

base-commit: 1011100868ec6d712145c75c016b18ba5913c7c7
--
2.40.1
P
P
Parnikkapore wrote on 4 Jul 2023 18:31
[PATCH v2 4/6] gnu: gajim-openpgp: Update to 1.5.0.
(address . 64021@debbugs.gnu.org)
7a97b8edc856858924b9139134cef557194aeeae.1688488273.git.poomklao@yahoo.com
* gnu/packages/messaging.scm (gajim-openpgp): Update to 1.5.0.
---
gnu/packages/messaging.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index e780f04cad..5aae60ac62 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1304,7 +1304,7 @@ (define-public gajim-omemo
(define-public gajim-openpgp
(package
(name "gajim-openpgp")
- (version "1.4.9")
+ (version "1.5.0")
(source
(origin
(method url-fetch/zipbomb)
@@ -1313,7 +1313,7 @@ (define-public gajim-openpgp
"https://ftp.gajim.org/plugins/master/openpgp/openpgp_"
version ".zip"))
(sha256
- (base32 "1xwmf6ai1z7z9x6p1ysglxji73r7d27c0gzc8ykab29cjhjyv0dq"))))
+ (base32 "193pbh9iri7bkamvjwp236i8g5zxxiqgsv64kll5sy76vx4q73c4"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
--
2.40.1
P
P
Parnikkapore wrote on 4 Jul 2023 18:31
[PATCH v2 2/6] gnu: gajim: Update to 1.7.3.
(address . 64021@debbugs.gnu.org)
fd84fffcd04a4dcbe2f8556c19fd3ec51d969698.1688488273.git.poomklao@yahoo.com
* gnu/packages/messaging.scm (gajim): Update to 1.7.3.
[arguments]: Switch to "python -m build".
To use pyproject-build-system, support for backend-path is needed.
[arguments]: Add metadata build and install phase.
[arguments]: Switch to "python -m unittest" as test method,
following upstream recommendation.
[arguments]: Generate gdk-pixbuf cache and include result in wrapper.
Allows Gajim to run in pure environments.
[native-search-paths]: Update.
---
gnu/packages/messaging.scm | 62 +++++++++++++++++++++++---------------
1 file changed, 37 insertions(+), 25 deletions(-)

Toggle diff (116 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 1b721e8f8e..8fc4c48e47 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1126,7 +1126,7 @@ (define-public python-nbxmpp
(define-public gajim
(package
(name "gajim")
- (version "1.4.7")
+ (version "1.7.3")
(source
(origin
(method url-fetch)
@@ -1135,7 +1135,7 @@ (define-public gajim
(version-major+minor version)
"/gajim-" version ".tar.gz"))
(sha256
- (base32 "1ww46qlxr14nq0ka8wsf8qpn5qfi5dvgyksfh9411crl7azhfj0s"))
+ (base32 "066kvkjw3qcdanr3nczy0wgcwihk9jc9zhzfr5bwlqvcyxcv7k5p"))
(patches (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
(build-system python-build-system)
(arguments
@@ -1148,13 +1148,27 @@ (define-public gajim
#:prefix glib-or-gtk:)
(guix build utils))
#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
+ ,#~(modify-phases %standard-phases
+ (add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'generate-gdk-pixbuf-loaders-cache-file))
+ (add-before 'build 'build-metadata
(lambda _
- ;; XXX Gajim builds fine on some (my) machines but fails elsewhere:
- ;; ModuleNotFoundError: No module named 'gajim.gui.emoji_data'
- ;; https://dev.gajim.org/gajim/gajim/-/issues/11041
- (delete-file "test/no_gui/test_styling.py")))
+ (invoke "./pep517build/build_metadata.py" "-o" "dist/metadata")))
+ ;; TODO: Change to pyproject-build-system once it supports
+ ;; in-tree build backends.
+ (replace 'build
+ (lambda _
+ (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+ (replace 'install
+ (lambda _
+ (apply invoke "pip" "--no-cache-dir" "--no-input"
+ "install" "--no-deps" "--prefix" #$output
+ (find-files "dist" "\\.whl$"))))
+ (add-after 'install 'install-metadata
+ (lambda _
+ (invoke "./pep517build/install_metadata.py" "dist/metadata"
+ (string-append "--prefix=" #$output))))
(replace 'check
(lambda _
;; Tests require a running X server.
@@ -1162,27 +1176,24 @@ (define-public gajim
(setenv "DISPLAY" ":1")
;; For missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
- (invoke "dbus-launch" "python" "./setup.py" "test")))
- ;; Loading gajim_remote require running session bus,
- ;; which in-turn requires running elogind for XDG_RUNTIME_DIR;
- ;; neither of which are possible inside build environment.
- (delete 'sanity-check)
+ (invoke "dbus-launch" "python" "-m" "unittest" "discover" "-s" "test")))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
(add-after 'install 'wrap-env
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (for-each
- (lambda (name)
- (let ((file (string-append out "/bin/" name))
- (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
- (wrap-program file
- `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path)))))
- '("gajim" "gajim-remote"))))))))
+ (lambda _
+ (for-each
+ (lambda (name)
+ (let ((file (string-append #$output "/bin/" name))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
+ (pixbuf-module-file (getenv "GDK_PIXBUF_MODULE_FILE")))
+ (wrap-program file
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
+ `("GDK_PIXBUF_MODULE_FILE" = (,pixbuf-module-file)))))
+ '("gajim" "gajim-remote")))))))
(native-search-paths
(list
(search-path-specification
@@ -1201,7 +1212,7 @@ (define-public gajim
;; FIXME: Cannot use this expression as it would
;; introduce a circular dependency at the top level.
;; (version-major+minor (package-version python))
- "3.9"
+ "3.10"
"/site-packages"))))))
(native-inputs
(list gettext-minimal
@@ -1209,6 +1220,7 @@ (define-public gajim
gobject-introspection
`(,gtk+ "bin")
python-distutils-extra
+ python-pypa-build
python-setuptools
xorg-server-for-tests))
(inputs
--
2.40.1
P
P
Parnikkapore wrote on 4 Jul 2023 18:31
[PATCH v2 5/6] gnu: python-nbxmpp: Clean up formatting.
(address . 64021@debbugs.gnu.org)
a7daa049a209bf4381fadbb6f851a74e4c95c131.1688488273.git.poomklao@yahoo.com
* gnu/packages/messaging.scm (python-nbxmpp): Clean up formatting.
---
gnu/packages/messaging.scm | 8 +++-----
1 file changed, 3 insertions(+), 5 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 5aae60ac62..bee9750055 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1094,10 +1094,9 @@ (define-public python-nbxmpp
(source
(origin
(method url-fetch)
- (uri
- (pypi-uri "nbxmpp" version))
+ (uri (pypi-uri "nbxmpp" version))
(sha256
- (base32 "095nyy6vjildhrqigxk6vsh49in6mx17bvb3z5zpjmzhv9b8ix46"))))
+ (base32 "095nyy6vjildhrqigxk6vsh49in6mx17bvb3z5zpjmzhv9b8ix46"))))
(build-system pyproject-build-system)
(arguments
'(#:phases
@@ -1106,8 +1105,7 @@ (define-public python-nbxmpp
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests? (invoke "python" "-m" "unittest" "-v")))))))
- (native-inputs
- (list `(,glib "bin")))
+ (native-inputs (list `(,glib "bin")))
(inputs
(list glib
glib-networking
--
2.40.1
P
P
Parnikkapore wrote on 4 Jul 2023 18:31
[PATCH v2 6/6] gnu: gajim: Clean up formatting.
(address . 64021@debbugs.gnu.org)
fcfc095318526625c5dce27cadc6b09204bab0d0.1688488273.git.poomklao@yahoo.com
* gnu/packages/messaging.scm (gajim): Clean up formatting.
---
gnu/packages/messaging.scm | 36 +++++++++++++++++++-----------------
1 file changed, 19 insertions(+), 17 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index bee9750055..2d377d0bcb 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1128,13 +1128,13 @@ (define-public gajim
(source
(origin
(method url-fetch)
- (uri
- (string-append "https://gajim.org/downloads/"
- (version-major+minor version)
- "/gajim-" version ".tar.gz"))
+ (uri (string-append "https://gajim.org/downloads/"
+ (version-major+minor version)
+ "/gajim-" version ".tar.gz"))
(sha256
- (base32 "066kvkjw3qcdanr3nczy0wgcwihk9jc9zhzfr5bwlqvcyxcv7k5p"))
- (patches (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
+ (base32 "066kvkjw3qcdanr3nczy0wgcwihk9jc9zhzfr5bwlqvcyxcv7k5p"))
+ (patches
+ (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
(build-system python-build-system)
(arguments
`(#:imported-modules
@@ -1142,8 +1142,7 @@ (define-public gajim
(guix build glib-or-gtk-build-system))
#:modules
((guix build python-build-system)
- ((guix build glib-or-gtk-build-system)
- #:prefix glib-or-gtk:)
+ ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
(guix build utils))
#:phases
,#~(modify-phases %standard-phases
@@ -1152,12 +1151,14 @@ (define-public gajim
'generate-gdk-pixbuf-loaders-cache-file))
(add-before 'build 'build-metadata
(lambda _
- (invoke "./pep517build/build_metadata.py" "-o" "dist/metadata")))
+ (invoke "./pep517build/build_metadata.py"
+ "-o" "dist/metadata")))
;; TODO: Change to pyproject-build-system once it supports
;; in-tree build backends.
(replace 'build
(lambda _
- (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+ (invoke "python" "-m" "build" "--wheel" "--no-isolation"
+ ".")))
(replace 'install
(lambda _
(apply invoke "pip" "--no-cache-dir" "--no-input"
@@ -1174,11 +1175,14 @@ (define-public gajim
(setenv "DISPLAY" ":1")
;; For missing '/etc/machine-id'.
(setenv "DBUS_FATAL_WARNINGS" "0")
- (invoke "dbus-launch" "python" "-m" "unittest" "discover" "-s" "test")))
+ (invoke "dbus-launch" "python" "-m" "unittest"
+ "discover" "-s" "test")))
(add-after 'install 'glib-or-gtk-compile-schemas
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'glib-or-gtk-compile-schemas))
(add-after 'install 'glib-or-gtk-wrap
- (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
+ (assoc-ref glib-or-gtk:%standard-phases
+ 'glib-or-gtk-wrap))
(add-after 'install 'wrap-env
(lambda _
(for-each
@@ -1196,10 +1200,8 @@ (define-public gajim
(list
(search-path-specification
(variable "GAJIM_PLUGIN_PATH")
- (separator #f) ;single entry
- (files
- (list
- "share/gajim/plugins")))
+ (separator #f) ; single entry
+ (files (list "share/gajim/plugins")))
;; Gajim needs to use the propagated inputs of its plugins.
(search-path-specification
(variable "GUIX_PYTHONPATH")
--
2.40.1
P
P
Parnikkapore wrote on 4 Jul 2023 18:31
[PATCH v2 3/6] gnu: gajim-omemo: Update to 2.9.0.
(address . 64021@debbugs.gnu.org)
1f2f92d9c17e7c17ccce3027dfa3bd6f2e33b681.1688488273.git.poomklao@yahoo.com
* gnu/packages/messaging.scm (gajim-omemo): Update to 2.9.0.
---
gnu/packages/messaging.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 8fc4c48e47..e780f04cad 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1268,7 +1268,7 @@ (define-public gajim
(define-public gajim-omemo
(package
(name "gajim-omemo")
- (version "2.8.15")
+ (version "2.9.0")
(source
(origin
(method url-fetch/zipbomb)
@@ -1277,7 +1277,7 @@ (define-public gajim-omemo
"https://ftp.gajim.org/plugins/master/omemo/omemo_"
version ".zip"))
(sha256
- (base32 "1hf148ywr8knk5y3y5xvvwgw74ld1pcfjkp78g514ikcnzfycfcn"))))
+ (base32 "0yy9r9fsrlgdywiln8bskhi8faj9hnz7b19jcap5nkhv8jn9cqq7"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
--
2.40.1
C
C
Christopher Baines wrote on 27 Sep 2023 12:16
tag 64021 moreinfo
(address . control@debbugs.gnu.org)
87v8bvzzt3.fsf@cbaines.net
tags 64021 - moreinfo
quit
C
C
Christopher Baines wrote on 27 Sep 2023 13:14
Re: [bug#64021] [PATCH v2 6/6] gnu: gajim: Clean up formatting.
(name . Parnikkapore)(address . poomklao@yahoo.com)
87jzsbdfez.fsf@cbaines.net
Hi,

Thanks for sending a v2, unfortunately this got a bit lost.

I've tweaked the formatting of some commit messages, made arguments a
(list rather than a `( quasiquoted list in a few cases and I've pushed
these patches to master as 8bc78fc86b928f603a589e413e9f20815a194f17.

Thanks,

Chris
?
Your comment

This issue is archived.

To comment on this conversation send an email to 64021@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 64021
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch