Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/bioinformatics.scm (python-mizani): New variable.
---
gnu/packages/bioinformatics.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (43 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9e356cba5d..0863c8a897 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3312,6 +3312,34 @@ (define-public python-bx-python
multiple sequence alignments.")
(license license:expat)))
+(define-public python-mizani
+ (let ((commit "8677800599eae212b145132beef1d43f08ffc8b2")
+ (revision "1"))
+ (package
+ (name "python-mizani")
+ (version "0.9.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/has2k1/mizani")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13aisfc98nvypb4mglpdphp2r627cjzpdriw4dhlx55f3b2m0dza"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-matplotlib python-numpy python-pandas
+ python-scipy tzdata))
+ (native-inputs (list python-setuptools python-pytest python-pytest-cov))
+ (home-page "https://github.com/has2k1/mizani")
+ (synopsis "This is a package for creating data visualizations in Python")
+ (description
+ "Mizani is a Python package for creating data visualizations.
+ It provides functions and tools to help with the creation of
+ visually appealing and informative visualizations, including
+ scales, transformations and color palettes.")
+ (license license:bsd-3))))
+
(define-public python-mofax
;; This is a recent commit from the "dev" branch, which is much more recent
;; than the latest commit from the "master" branch.
base-commit: dffaf42e5eac3822bd6b44e9749fc8e5f48fb99c
--
2.34.1