[PATCH] gnu: python-typeguard: Add dependency on python-setuptools-scm.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Christopher Baines
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 9 Jun 2023 17:52
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20230609155229.2656864-1-monego@posteo.net
* gnu/packages/python-xyz.scm (python-typeguard)[native-inputs]: Add
python-setuptools-scm.
---
This is required to report the correct version.

gnu/packages/python-xyz.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7d5128911f..351e199e57 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23453,8 +23453,10 @@ (define-public python-typeguard
;; XXX: These fail when installed as a library:
;; https://github.com/agronholm/typeguard/issues/176
"not usefixtures and not test_cached_module")))))))
- (native-inputs
- (list python-mypy python-pytest python-typing-extensions))
+ (native-inputs (list python-mypy
+ python-pytest
+ python-setuptools-scm
+ python-typing-extensions))
(home-page "https://github.com/agronholm/typeguard")
(synopsis "Run-time type checker for Python")
(description
--
2.34.1
L
L
Ludovic Courtès wrote on 1 Jul 2023 23:25
(name . Vinicius Monego)(address . monego@posteo.net)
875y73wchu.fsf@gnu.org
Hi,

Vinicius Monego <monego@posteo.net> skribis:

Toggle quote (3 lines)
> * gnu/packages/python-xyz.scm (python-typeguard)[native-inputs]: Add
> python-setuptools-scm.

LGTM!

https://qa.guix.gnu.org/issue/63980 says it’s OK; the “Blocked”
numbers are higher, but I’m not sure what that means since there are no
new packages here. Chris, WDYT?

Thanks,
Ludo’.
C
C
Christopher Baines wrote on 2 Jul 2023 11:45
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 63980@debbugs.gnu.org)
87a5weprqk.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (13 lines)
> Hi,
>
> Vinicius Monego <monego@posteo.net> skribis:
>
>> * gnu/packages/python-xyz.scm (python-typeguard)[native-inputs]: Add
>> python-setuptools-scm.
>
> LGTM!
>
> <https://qa.guix.gnu.org/issue/63980> says it’s OK; the “Blocked”
> numbers are higher, but I’m not sure what that means since there are no
> new packages here. Chris, WDYT?

This is an issue with the data service incorrectly seeing some builds as
not blocked, when they should be. Some of the builds in the base
revision that are being counted in the "Unknown" column should actually
be in blocked, which is why the blocked count appears to increase.

I'm not quite sure what the issue is, but I'll have another look at
fixing this.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmShSFNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xeqtw//VDSqhcOJYrvDf4ed29FPbTnAbS3tJmwb
zJOYEPi4OmfV2/Vp6E917gjgmri4Y+QfTPfqmjYGeqiLgLvidk91HRk3rBttrZye
zOLBIvXfNeIx/BTJltFXTuoKsj45YzqRawVhvj41kf7+5oqkLhPrcUTIqcVqWj6E
yxgL0FPUVtFi+KzxWNB/ql+KRBCtX8NJ0U+2/vGdBarPrptKsh9w9Qu1V1Mc1FFb
a/WFM5Qtkzp5aHdCxar+cmfEnvgL6SGRkxrfwOhCQjnaEuOR1SC8rYm6YwQ8kg1L
7ln83YfPo/glwEGd22r5KxxqY0t7x1IwKmoKEWHphWe9jEShJ55dH7massnkZbdV
EmrKYs4YrpMJxpdydOuXJ1Rpj75EDX1YX3E1tQWoaxZt/ZmnrVGNLWR0DxMg+JTe
OmRBKZTr3B+uwVH/eM19z8ihXuSwNMBhTTbkfn5k5+t2DvTpeDXnkJsWKWIlJed/
kutwNm0h9Sibfquo78PBOF1gC9rDcnfL7FlxvRlaLPpYNYtoWm9YeMpYmCH2uRRe
nMI/yabK3pySsA4gQCzqMtwmT3JXKPmdH3KEDp1MWR8CCnYaKRwPDKscvlTrRw3S
MV8J6ZDI0cAI7bvVxuH9McXBH6DDD6H7hwROhIa+x9F7eiCqjXckm6qJjLDoeF7l
pS2KRA1HTAc=
=5kBh
-----END PGP SIGNATURE-----

V
V
Vinicius Monego wrote on 29 Jul 2023 20:53
Re: [bug#63980] [PATCH] gnu: python-typeguard: Add dependency on python-setuptools-scm.
(address . 63980@debbugs.gnu.org)
6fbc4f23de9f88480c3caffd2233276caf0189d9.camel@posteo.net
Hi,

Em dom, 2023-07-02 às 10:45 +0100, Christopher Baines escreveu:
Toggle quote (28 lines)
>
> Ludovic Courtès <ludo@gnu.org> writes:
>
> > Hi,
> >
> > Vinicius Monego <monego@posteo.net> skribis:
> >
> > > * gnu/packages/python-xyz.scm (python-typeguard)[native-inputs]:
> > > Add
> > > python-setuptools-scm.
> >
> > LGTM!
> >
> > <https://qa.guix.gnu.org/issue/63980> says it’s OK; the “Blocked”
> > numbers are higher, but I’m not sure what that means since there
> > are no
> > new packages here.  Chris, WDYT?
>
> This is an issue with the data service incorrectly seeing some builds
> as
> not blocked, when they should be. Some of the builds in the base
> revision that are being counted in the "Unknown" column should
> actually
> be in blocked, which is why the blocked count appears to increase.
>
> I'm not quite sure what the issue is, but I'll have another look at
> fixing this.

If it's a problem in the data service only, can I push this to master?
There are 257 rebuilds with this change (including pytorch) and I want
to add another one in https://issues.guix.gnu.org/63621before it hits
300.

Vinicius
L
L
Ludovic Courtès wrote on 8 Sep 2023 23:51
Re: bug#63980: [PATCH] gnu: python-typeguard: Add dependency on python-setuptools-scm.
(name . Vinicius Monego)(address . monego@posteo.net)
87sf7o1gh2.fsf_-_@gnu.org
Hi Vinicius,

Vinicius Monego <monego@posteo.net> skribis:

Toggle quote (5 lines)
> If it's a problem in the data service only, can I push this to master?
> There are 257 rebuilds with this change (including pytorch) and I want
> to add another one in https://issues.guix.gnu.org/63621 before it hits
> 300.

I think you can go ahead and push both series (assuming that at least
‘python-pytorch’ is fine after these changes).

Thanks,
Ludo’.
V
V
Vinicius Monego wrote on 17 Sep 2023 13:29
(address . 63980-done@debbugs.gnu.org)
066555a5f1b999b9f472d88372976251b98cc667.camel@posteo.net
Em sex, 2023-09-08 às 23:51 +0200, Ludovic Courtès escreveu:
Toggle quote (18 lines)
> Hi Vinicius,
>
> Vinicius Monego <monego@posteo.net> skribis:
>
> > If it's a problem in the data service only, can I push this to
> > master?
> > There are 257 rebuilds with this change (including pytorch) and I
> > want
> > to add another one in https://issues.guix.gnu.org/63621 before it
> > hits
> > 300.
>
> I think you can go ahead and push both series (assuming that at least
> ‘python-pytorch’ is fine after these changes).
>
> Thanks,
> Ludo’.

Hi Ludo,

Closing this one because I applied it. I pushed only part of the other
because the latest version of BoTorch is having issues with reporting
its version, I will look further into it.

Vinicius
Closed
?