[PATCH] gnu: Add python-mudata.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
b6ce59ff756491be94ba63edc8c7bade4d615ef8.1686322594.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-mudata): New variable.
---
gnu/packages/bioinformatics.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1caea80f86..13ae47d858 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3352,6 +3352,32 @@ (define-public python-mofax
models trained with MOFA+ in Python.")
(license license:expat))))
+(define-public python-mudata
+ (let ((commit "392f5464135d687fe64bc571d35cbf557b796ff0")
+ (revision "0"))
+ (package
+ (name "python-mudata")
+ (version (git-version "0.2.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/scverse/mudata")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02h0k1q57589r0hdv8nwg1vk7g2ljvn5g66c47fy5gdilbm3gjws"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-anndata python-h5py python-pandas python-flit-core))
+ (native-inputs (list python-numpy python-pytest python-zarr))
+ (home-page "https://github.com/scverse/mudata")
+ (synopsis "Python package for multi-omics data analysis")
+ (description
+ "Mudata is a Python package for multi-omics data analysis.
+It is designed to provide functionality to load, process, and store
+multimodal omics data.")
+ (license license:bsd-3))))
+
(define-public python-pyega3
(package
(name "python-pyega3")

base-commit: dd587a4fefbd8841f609910af36e13aa890781b7
prerequisite-patch-id: c5352e197d46cff8e37f0ff85044983c550a9663
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 63976-done@debbugs.gnu.org)
87cz24oen0.fsf@elephly.net
I simplified this a little and pushed this with commit
74443c30f3e20655a046c0d3ea236822ef130968.

Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63976@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63976
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help