[PATCH] gnu: Add python-mofax.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
7399348a0fb8ebcda6b7d99b91e20fadae73a5c1.1686319557.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-mofax): New variable.
---
gnu/packages/bioinformatics.scm | 40 +++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9ce28596c2..1caea80f86 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3312,6 +3312,46 @@ (define-public python-bx-python
multiple sequence alignments.")
(license license:expat)))
+(define-public python-mofax
+ (let ((commit "4d96f8f0a5d5251847353656f523684d66c3c47a")
+ (revision "0"))
+ (package
+ (name "python-mofax")
+ (version (git-version "0.4.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bioFAM/mofax")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lwrw0qyvvnyiqz1l20dhcf7dxidb80cqgvk78czvdgba87yxzqx"))
+ (modules '((guix build utils)))
+ (snippet '(substitute* "pyproject.toml"
+ (("^#.*")
+ "")))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; This test is failing due to a bug. The bug has been reported to the developers. See https://github.com/bioFAM/mofax/issues/12 for more info.
+ #:test-flags '(list "-k" "not test_get_methods")))
+ (propagated-inputs (list python-h5py
+ python-matplotlib
+ python-pandas
+ python-poetry-core
+ python-scipy
+ python-seaborn))
+ (native-inputs (list python-numpy python-pytest))
+ (home-page "https://github.com/bioFAM/mofax")
+ (synopsis
+ "Motif activity finder for transcription factor motif analysis")
+ (description
+ "MoFax is a Python package for transcription factor motif analysis.
+It provides convenience functions to load and visualize factor
+models trained with MOFA+ in Python.")
+ (license license:expat))))
+
(define-public python-pyega3
(package
(name "python-pyega3")

base-commit: e8f9fb3e03ea8fee0e13f13706a6b16414f74a7b
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 63974-done@debbugs.gnu.org)
878rcsoem5.fsf@elephly.net
Pushed with minor changes. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63974@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63974
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help