Christopher Howard wrote 2 years ago
(address . guix-patches@gnu.org)
Patch attached to add kineto, an HTTP proxy for the Gemini protocol.
--
馃摏 Christopher Howard
馃殌 gemini://gem.librehacker.com
讘专讗砖讬转 讘专讗 讗诇讛讬诐 讗转 讛砖诪讬诐 讜讗转 讛讗专抓
From 6107b5e5c555aa4781f922ee1b9b91428b6240af Mon Sep 17 00:00:00 2001
From: Christopher Howard <christopher@librehacker.com>
Date: Thu, 8 Jun 2023 13:10:15 -0800
Subject: [PATCH] gnu: Add kineto.
* gnu/packages/web.scm (kineto): New variable.
---
gnu/packages/web.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (51 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3af4aa0b8d..21e9579ac6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -62,6 +62,7 @@
;;; Copyright � 2023 Paul A. Patience <paul@apatience.com>
;;; Copyright � 2022 Bruno Victal <mirai@makinata.eu>
;;; Copyright � 2023 David Thompson <dthompson2@worcester.edu>
+;;; Copyright � 2023 Christopher Howard <christopher@librehacker.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8502,6 +8503,36 @@ (define-public vger
@command{stunnel} on @command{inetd}.")
(license license:bsd-2)))
+(define-public kineto
+ (package
+ (name "kineto")
+ (version "0.0.0-20211105093215-857f8c97ebc5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/kineto")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r17c904i76yy5ilvhjczmhnq5g7r4nkjwmsjcfxcqzly0ia7m2k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "git.sr.ht/~sircmpwn/kineto/"))
+ (propagated-inputs `(("go-git-sr-ht-sircmpwn-getopt"
+ ,go-git-sr-ht-sircmpwn-getopt)
+ ("go-git-sr-ht-adnano-go-gemini"
+ ,go-git-sr-ht-adnano-go-gemini)))
+ (home-page "https://git.sr.ht/~sircmpwn/kineto/")
+ (synopsis "HTTP proxy for Gemini")
+ (description
+ "This is an @@url{https://en.wikipedia.org/wiki/Hypertext_Transfer_Protocol,HTTP}
+to @@url{https://gemini.circumlunar.space/,Gemini} proxy designed to provide
+service for a single domain, i.e. to make your Gemini site available over HTTP.
+It can proxy to any domain in order to facilitate linking to the rest of
+Geminispace, but it defaults to a specific domain.")
+ (license license:gpl3)))
+
(define-public libzim
(package
(name "libzim")
--
2.40.1