[PATCH] gnu: Add kineto.

  • Done
  • quality assurance status badge
Details
3 participants
  • Christopher Howard
  • Ludovic Courtès
  • Bruno Victal
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Christopher Howard wrote 2 years ago
(address . guix-patches@gnu.org)
ZIJFps2QzuMP196f@theoden
Patch attached to add kineto, an HTTP proxy for the Gemini protocol.

--
馃摏 Christopher Howard
馃殌 gemini://gem.librehacker.com

讘专讗砖讬转 讘专讗 讗诇讛讬诐 讗转 讛砖诪讬诐 讜讗转 讛讗专抓
From 6107b5e5c555aa4781f922ee1b9b91428b6240af Mon Sep 17 00:00:00 2001
From: Christopher Howard <christopher@librehacker.com>
Date: Thu, 8 Jun 2023 13:10:15 -0800
Subject: [PATCH] gnu: Add kineto.

* gnu/packages/web.scm (kineto): New variable.
---
gnu/packages/web.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3af4aa0b8d..21e9579ac6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -62,6 +62,7 @@
;;; Copyright � 2023 Paul A. Patience <paul@apatience.com>
;;; Copyright � 2022 Bruno Victal <mirai@makinata.eu>
;;; Copyright � 2023 David Thompson <dthompson2@worcester.edu>
+;;; Copyright � 2023 Christopher Howard <christopher@librehacker.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8502,6 +8503,36 @@ (define-public vger
@command{stunnel} on @command{inetd}.")
(license license:bsd-2)))
+(define-public kineto
+ (package
+ (name "kineto")
+ (version "0.0.0-20211105093215-857f8c97ebc5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/kineto")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r17c904i76yy5ilvhjczmhnq5g7r4nkjwmsjcfxcqzly0ia7m2k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "git.sr.ht/~sircmpwn/kineto/"))
+ (propagated-inputs `(("go-git-sr-ht-sircmpwn-getopt"
+ ,go-git-sr-ht-sircmpwn-getopt)
+ ("go-git-sr-ht-adnano-go-gemini"
+ ,go-git-sr-ht-adnano-go-gemini)))
+ (home-page "https://git.sr.ht/~sircmpwn/kineto/")
+ (synopsis "HTTP proxy for Gemini")
+ (description
+ "This is an @@url{https://en.wikipedia.org/wiki/Hypertext_Transfer_Protocol,HTTP}
+to @@url{https://gemini.circumlunar.space/,Gemini} proxy designed to provide
+service for a single domain, i.e. to make your Gemini site available over HTTP.
+It can proxy to any domain in order to facilitate linking to the rest of
+Geminispace, but it defaults to a specific domain.")
+ (license license:gpl3)))
+
(define-public libzim
(package
(name "libzim")
--
2.40.1
Christopher Howard wrote 2 years ago
Re: bug#63964: Acknowledgement ([PATCH] gnu: Add kineto.)
(address . 63964@debbugs.gnu.org)
ZIStCiCQgnGDmhft@theoden
Someone on IRC asked me to makes some changes to the description. Here is a new patch.

--
Christopher Howard
From e7a59ebe9dd0eaec32da26c2de77199959e52f6f Mon Sep 17 00:00:00 2001
From: Christopher Howard <christopher@librehacker.com>
Date: Sat, 10 Jun 2023 09:00:14 -0800
Subject: [PATCH] gnu: Add kineto

* gnu/packages/web.scm (kineto): New variable.
---
gnu/packages/web.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3af4aa0b8d..3969ff4605 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -62,6 +62,7 @@
;;; Copyright � 2023 Paul A. Patience <paul@apatience.com>
;;; Copyright � 2022 Bruno Victal <mirai@makinata.eu>
;;; Copyright � 2023 David Thompson <dthompson2@worcester.edu>
+;;; Copyright � 2023 Christopher Howard <christopher@librehacker.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8502,6 +8503,36 @@ (define-public vger
@command{stunnel} on @command{inetd}.")
(license license:bsd-2)))
+(define-public kineto
+ (package
+ (name "kineto")
+ (version "0.0.0-20211105093215-857f8c97ebc5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/kineto")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r17c904i76yy5ilvhjczmhnq5g7r4nkjwmsjcfxcqzly0ia7m2k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "git.sr.ht/~sircmpwn/kineto/"))
+ (propagated-inputs `(("go-git-sr-ht-sircmpwn-getopt"
+ ,go-git-sr-ht-sircmpwn-getopt)
+ ("go-git-sr-ht-adnano-go-gemini"
+ ,go-git-sr-ht-adnano-go-gemini)))
+ (home-page "https://git.sr.ht/~sircmpwn/kineto/")
+ (synopsis "HTTP proxy for Gemini")
+ (description
+ "This is an @acronym{HTTP} to
+@url{https://gemini.circumlunar.space/,Gemini} proxy designed to provide
+service for a single domain, i.e. to make your Gemini site available over
+HTTP. It can proxy to any domain in order to facilitate linking to the rest
+of Geminispace, but it defaults to a specific domain.")
+ (license license:gpl3)))
+
(define-public libzim
(package
(name "libzim")
--
2.40.1
Christopher Howard wrote 2 years ago
(address . 63964@debbugs.gnu.org)
ZJXqKT0qNlapa99D@theoden
I just want to mention that the package builds easily without any issues.

--
Christopher Howard
christopher wrote 2 years ago
[PATCH] gnu: Add kineto
(address . 63964@debbugs.gnu.org)(name . Christopher Howard)(address . christopher@librehacker.com)
e7a59ebe9dd0eaec32da26c2de77199959e52f6f.1688674515.git.christopher@librehacker.com
From: Christopher Howard <christopher@librehacker.com>

* gnu/packages/web.scm (kineto): New variable.
---
gnu/packages/web.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3af4aa0b8d..3969ff4605 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
+;;; Copyright © 2023 Christopher Howard <christopher@librehacker.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8502,6 +8503,36 @@ (define-public vger
@command{stunnel} on @command{inetd}.")
(license license:bsd-2)))
+(define-public kineto
+ (package
+ (name "kineto")
+ (version "0.0.0-20211105093215-857f8c97ebc5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/kineto")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r17c904i76yy5ilvhjczmhnq5g7r4nkjwmsjcfxcqzly0ia7m2k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "git.sr.ht/~sircmpwn/kineto/"))
+ (propagated-inputs `(("go-git-sr-ht-sircmpwn-getopt"
+ ,go-git-sr-ht-sircmpwn-getopt)
+ ("go-git-sr-ht-adnano-go-gemini"
+ ,go-git-sr-ht-adnano-go-gemini)))
+ (home-page "https://git.sr.ht/~sircmpwn/kineto/")
+ (synopsis "HTTP proxy for Gemini")
+ (description
+ "This is an @acronym{HTTP} to
+@url{https://gemini.circumlunar.space/,Gemini} proxy designed to provide
+service for a single domain, i.e. to make your Gemini site available over
+HTTP. It can proxy to any domain in order to facilitate linking to the rest
+of Geminispace, but it defaults to a specific domain.")
+ (license license:gpl3)))
+
(define-public libzim
(package
(name "libzim")

base-commit: 872b2487451c39020a78ed3227992fb02a7ed5e5
--
2.40.1
Christopher Howard wrote 2 years ago
(address . 63964@debbugs.gnu.org)
ZKclg4dfdim_S1LO@theoden
The last patch had encoding issues. I sent the patch again using git-send-email.

--
Christopher Howard
Bruno Victal wrote 2 years ago
Re: [bug#63964] [PATCH] gnu: Add kineto
(address . christopher@librehacker.com)(address . 63964@debbugs.gnu.org)
f3d107a7-d553-9e62-924e-3a4055356a7d@makinata.eu
Hi Christopher,

On 2023-07-06 21:31, christopher@librehacker.com wrote:
Toggle quote (5 lines)
> + (propagated-inputs `(("go-git-sr-ht-sircmpwn-getopt"
> + ,go-git-sr-ht-sircmpwn-getopt)
> + ("go-git-sr-ht-adnano-go-gemini"
> + ,go-git-sr-ht-adnano-go-gemini)))

You can write this part as:
(propagated-inputs
(list go-git-sr-ht-sircmpwn-getopt go-git-sr-ht-adnano-go-gemini))


--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
Christopher Howard wrote 2 years ago
[PATCH] gnu: Add kineto
(address . 63964@debbugs.gnu.org)(address . christopher@librehacker.com)
20230719213539.18271-1-christopher@librehacker.com
* gnu/packages/web.scm (kineto): New variable.
---
gnu/packages/web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ad5ec0a..f8fd856 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2023 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
+;;; Copyright © 2023 Christopher Howard <christopher@librehacker.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8558,6 +8559,34 @@ (define-public vger
@command{stunnel} on @command{inetd}.")
(license license:bsd-2)))
+(define-public kineto
+ (package
+ (name "kineto")
+ (version "0.0.0-20211105093215-857f8c97ebc5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/kineto")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r17c904i76yy5ilvhjczmhnq5g7r4nkjwmsjcfxcqzly0ia7m2k"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "git.sr.ht/~sircmpwn/kineto/"))
+ (propagated-inputs
+ (list go-git-sr-ht-sircmpwn-getopt go-git-sr-ht-adnano-go-gemini))
+ (home-page "https://git.sr.ht/~sircmpwn/kineto/")
+ (synopsis "HTTP proxy for Gemini")
+ (description
+ "This is an @acronym{HTTP} to
+@url{https://gemini.circumlunar.space/,Gemini} proxy designed to provide
+service for a single domain, i.e. to make your Gemini site available over
+HTTP. It can proxy to any domain in order to facilitate linking to the rest
+of Geminispace, but it defaults to a specific domain.")
+ (license license:gpl3)))
+
(define-public libzim
(package
(name "libzim")
--
2.40.1
Ludovic Courtès wrote 2 years ago
Re: bug#63964: [PATCH] gnu: Add kineto.
(name . Christopher Howard)(address . christopher@librehacker.com)(address . 63964-done@debbugs.gnu.org)
87350vt0el.fsf_-_@gnu.org
Christopher Howard <christopher@librehacker.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/web.scm (kineto): New variable.

[...]

Toggle quote (2 lines)
> + (license license:gpl3)))

Hi! Change to ‘gpl3+’ and applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63964@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63964
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help