(address . bug-guix@gnu.org)
The closure of ‘qtbase’ is unreasonable large, and this is in part
because it retains a reference to GCC:
Toggle snippet (17 lines)
$ guix graph -t references --path qtbase /gnu/store/gqld7hz5vm4g904g7nc77z7wzvdrrwyb-zlib-1.2.13
/gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2
/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0
/gnu/store/gqld7hz5vm4g904g7nc77z7wzvdrrwyb-zlib-1.2.13
$ guix build -e '(@@ (gnu packages commencement) gcc-final)'
/gnu/store/930nwsiysdvy2x5zv1sf6v7ym75z8ayk-gcc-11.3.0-lib
/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0
$ guix size qtbase | tail -1
total: 1204.7 MiB
$ guix describe
Generation 265 Jun 04 2023 23:48:31 (current)
guix eed55a6
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: eed55a6544d5bda2245ec853e5fa4b28e1865bea
This comes from a CMake file:
Toggle snippet (5 lines)
$ grep -r 5lqhcv91ijy82p92ac6g5xw48l0lwwz4 /gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2
/gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2/lib/cmake/Qt6/qt.toolchain.cmake: set(__qt_initial_c_compiler "/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/gcc")
/gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2/lib/cmake/Qt6/qt.toolchain.cmake: set(__qt_initial_cxx_compiler "/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/c++")
We should remove this reference.
Ludo’.