qtbase@6 retains reference to ‘gcc-final’

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Ludovic Courtès
Severity
normal
L
L
Ludovic Courtès wrote on 7 Jun 2023 21:55
(address . bug-guix@gnu.org)
87a5xb59ob.fsf@inria.fr
The closure of ‘qtbase’ is unreasonable large, and this is in part
because it retains a reference to GCC:

Toggle snippet (17 lines)
$ guix graph -t references --path qtbase /gnu/store/gqld7hz5vm4g904g7nc77z7wzvdrrwyb-zlib-1.2.13
/gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2
/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0
/gnu/store/gqld7hz5vm4g904g7nc77z7wzvdrrwyb-zlib-1.2.13
$ guix build -e '(@@ (gnu packages commencement) gcc-final)'
/gnu/store/930nwsiysdvy2x5zv1sf6v7ym75z8ayk-gcc-11.3.0-lib
/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0
$ guix size qtbase | tail -1
total: 1204.7 MiB
$ guix describe
Generation 265 Jun 04 2023 23:48:31 (current)
guix eed55a6
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: eed55a6544d5bda2245ec853e5fa4b28e1865bea

This comes from a CMake file:

Toggle snippet (5 lines)
$ grep -r 5lqhcv91ijy82p92ac6g5xw48l0lwwz4 /gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2
/gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2/lib/cmake/Qt6/qt.toolchain.cmake: set(__qt_initial_c_compiler "/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/gcc")
/gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2/lib/cmake/Qt6/qt.toolchain.cmake: set(__qt_initial_cxx_compiler "/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/c++")

We should remove this reference.

Ludo’.
M
M
Maxim Cournoyer wrote on 8 Aug 2023 05:38
Re: bug#63948: qtbase@6 retains reference to ‘gcc -final’
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 63948-done@debbugs.gnu.org)
87350udwza.fsf@gmail.com
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (28 lines)
> The closure of ‘qtbase’ is unreasonable large, and this is in part
> because it retains a reference to GCC:
>
> $ guix graph -t references --path qtbase /gnu/store/gqld7hz5vm4g904g7nc77z7wzvdrrwyb-zlib-1.2.13
> /gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2
> /gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0
> /gnu/store/gqld7hz5vm4g904g7nc77z7wzvdrrwyb-zlib-1.2.13
> $ guix build -e '(@@ (gnu packages commencement) gcc-final)'
> /gnu/store/930nwsiysdvy2x5zv1sf6v7ym75z8ayk-gcc-11.3.0-lib
> /gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0
> $ guix size qtbase | tail -1
> total: 1204.7 MiB
> $ guix describe
> Generation 265 Jun 04 2023 23:48:31 (current)
> guix eed55a6
> repository URL: https://git.savannah.gnu.org/git/guix.git
> branch: master
> commit: eed55a6544d5bda2245ec853e5fa4b28e1865bea
>
>
> This comes from a CMake file:
>
> $ grep -r 5lqhcv91ijy82p92ac6g5xw48l0lwwz4 /gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2
> /gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2/lib/cmake/Qt6/qt.toolchain.cmake: set(__qt_initial_c_compiler "/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/gcc")
> /gnu/store/0zqk6bmgvwxh1kx963hhknwnqh3h0iik-qtbase-6.3.2/lib/cmake/Qt6/qt.toolchain.cmake: set(__qt_initial_cxx_compiler "/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/c++")
>
> We should remove this reference.

Fixed with commit 98c17c14829349d4838186400541a7cd650b64d0; there's was
convenient QT_EMBED_TOOLCHAIN_COMPILER build switch we can use to
disable embedding the compilers in the CMake files.

Thanks for the report!

--
Maxim
Closed
L
L
Ludovic Courtès wrote on 9 Aug 2023 22:24
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 63948-done@debbugs.gnu.org)
87350sotfw.fsf@gnu.org
Heya,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (4 lines)
> Fixed with commit 98c17c14829349d4838186400541a7cd650b64d0; there's was
> convenient QT_EMBED_TOOLCHAIN_COMPILER build switch we can use to
> disable embedding the compilers in the CMake files.

Well done, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63948@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63948
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch