sonnet uses hardcoded paths for hunspell dictionaries

  • Open
  • quality assurance status badge
Details
One participant
  • Efraim Flashner
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 6 Jun 2023 22:39
(address . bug-guix@gnu.org)
ZH-Zc9GzL2YUYJ7B@3900XT
In sonnet's source code, in src/plugins/hunspell/hunspellclient.cpp, we
have the following code snippet:

#ifdef Q_OS_WIN
maybeAddPath(QStringLiteral(SONNET_INSTALL_PREFIX "/bin/data/hunspell/"));
#else
maybeAddPath(QStringLiteral("/System/Library/Spelling"));
maybeAddPath(QStringLiteral("/usr/share/hunspell/"));
maybeAddPath(QStringLiteral("/usr/share/myspell/"));
#endif

This is probably why sonnet can't find any hunspell dictionaries.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR/mXMACgkQQarn3Mo9
g1Fh4g/+OSEMEO4HTCYW5Om2aJ6ezQOFdZQMe9MACxbJZIEngy2RIEo5uSv9vzqq
/p8KK5hbq12l8Pzb08NUBrBspjqkMHKd8P4dZkkar2QWaxdptgZLgAIz9GVBg9le
7HeRdIF+qB3yUoWGcLWzI765xdTKJIQfJsVoSFJeDnlfASWQWGE2OHnTTnIUaGrw
s52xT4Prk/PJ0BEJU84ojQIG1rM1jxg+6/q6ijzVDKuhkwzN6mADtnFiSuhmt8nH
Ic8Gev2WUgMrIupJtlAJTTC8tpeq+SY+t2k3c2k57INOclzD8xo9RifuF51FXyRW
N8yRszJkorPLBw3CYgHzlkwLw2v1PwUvefJkVWyt5Kfkp2i69Vy27mVOXWKFRPly
u+uGWpeKOGIRa2CN2x7X8z1cmGDYtqxbyU9aSr7xdW2Kbnj0VoK9nApWem06ZWsn
PU0pk4zpZWSnY1OuUBjF4VsV9Mb2eD0vaDr8igjnn9cLq/b/7gJvbviY1V1HmJnK
h1svBzJ7abSFhpBOlrhW+d/+um9qmzsd3CPNpYo8a6jRTTgNu6HTnJm91anyPEbR
83ImFR1Uj07oOTtYV9H3eYTXWVpON3eE7MEVEF+j1MUqRz3nOKr0GHiv55SPWU6a
h19ZuwlpwRHaatQHAdaiuVFZG2LCz6oUU5bVuhCEUM501DlPgZ8=
=HJyW
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 63934@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63934
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch