[PATCH 1/2] gnu: Add r-caretensemble.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
01a6270712ebcd53017074ea47427333825cfdb6.1686044007.git.navid.afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-caretensemble): New variable.
---
gnu/packages/cran.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d8221fd0fc..b2eb3efc15 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27921,6 +27921,37 @@ (define-public r-caret
classification and regression models.")
(license license:gpl2+)))
+(define-public r-caretensemble
+ (package
+ (name "r-caretensemble")
+ (version "2.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "caretEnsemble" version))
+ (sha256
+ (base32
+ "0kagw1ilfz1yy1q0ysmkp3f13k08hiq84xk7d0xp5p7d5dsg7z6q"))))
+ (properties `((upstream-name . "caretEnsemble")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-caret
+ r-data-table
+ r-digest
+ r-ggplot2
+ r-gridextra
+ r-lattice
+ r-pbapply
+ r-plyr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/zachmayer/caretEnsemble")
+ (synopsis "Ensembles of caret models")
+ (description
+ "Framework for fitting multiple caret models.
+This Framework use the same re-sampling strategy as well as creating
+ensembles of such models. Use caretList to fit multiple models and
+then use caretEnsemble to combine them greedily or caretStack to
+combine them using a caret model.")
+ (license license:expat)))
+
(define-public r-adabag
(package
(name "r-adabag")

base-commit: e3cd3f03202c48cd8d777f4769b4e31fea8dcd60
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 63923-done@debbugs.gnu.org)
87mt1cq0mq.fsf@elephly.net
Applied with minor changes to the description.
Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63923@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63923
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help