(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
* gnu/packages/maths.scm (ruy): New variable
---
gnu/packages/maths.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4e34124469..264797d0c6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8501,3 +8501,31 @@ (define-public scilab
optimization, and modeling, simulation of explicit and implicit dynamical
systems and symbolic manipulations.")
(license license:cecill))) ;CeCILL v2.1
+
+
+(define-public ruy
+ (let ((commit "caa244343de289f913c505100e6a463d46c174de")
+ (version "0")
+ (revision "1"))
+ (package
+ (name "ruy")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/ruy")
+ (commit commit)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z9q2czk9im88zp8d9spiyx3y9l86rgqj0q0xxqq7vfg9ncypay2"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/google/ruy")
+ (synopsis "Matrix multiplication library")
+ (description
+ "Ruy is a matrix multiplication library. Its focus is to cover the matrix
+multiplication needs of neural network inference engines. Its initial user has
+been TensorFlow Lite, where it is used by default on the ARM CPU architecture.")
+ (license license:asl2.0))))
+
base-commit: b3492964c2573993b65c20f6e7d16c29cfd6f4f5
--
2.40.1