[PATCH] gnu: add ruy

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
d0a1b1cd1bb624ce4feb24793dbeb5fd379f9da5.1685868317.git.atai@atai.org
* gnu/packages/maths.scm (ruy): New variable
---
gnu/packages/maths.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4e34124469..264797d0c6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8501,3 +8501,31 @@ (define-public scilab
optimization, and modeling, simulation of explicit and implicit dynamical
systems and symbolic manipulations.")
(license license:cecill))) ;CeCILL v2.1
+
+
+(define-public ruy
+ (let ((commit "caa244343de289f913c505100e6a463d46c174de")
+ (version "0")
+ (revision "1"))
+ (package
+ (name "ruy")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/ruy")
+ (commit commit)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z9q2czk9im88zp8d9spiyx3y9l86rgqj0q0xxqq7vfg9ncypay2"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/google/ruy")
+ (synopsis "Matrix multiplication library")
+ (description
+ "Ruy is a matrix multiplication library. Its focus is to cover the matrix
+multiplication needs of neural network inference engines. Its initial user has
+been TensorFlow Lite, where it is used by default on the ARM CPU architecture.")
+ (license license:asl2.0))))
+

base-commit: b3492964c2573993b65c20f6e7d16c29cfd6f4f5
--
2.40.1
Andy Tai wrote 2 years ago
[PATCH v2] gnu: add ruy
(address . 63889@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
f7c69f3b148d6a39f8e4a9035201210528b7eff3.1685873662.git.atai@atai.org
* gnu/packages/maths.scm (ruy): New variable
---
gnu/packages/maths.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4e34124469..c6fabf1973 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8501,3 +8501,36 @@ (define-public scilab
optimization, and modeling, simulation of explicit and implicit dynamical
systems and symbolic manipulations.")
(license license:cecill))) ;CeCILL v2.1
+
+
+(define-public ruy
+ (let ((commit "caa244343de289f913c505100e6a463d46c174de")
+ (version "0")
+ (revision "1"))
+ (package
+ (name "ruy")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/ruy")
+ (commit commit)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z9q2czk9im88zp8d9spiyx3y9l86rgqj0q0xxqq7vfg9ncypay2"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list
+ ;; needs to make sure code is relocatable for
+ ;; use in tensorflow
+ "-DCMAKE_CXX_FLAGS=-fPIC ")))
+ (home-page "https://github.com/google/ruy")
+ (synopsis "Matrix multiplication library")
+ (description
+ "Ruy is a matrix multiplication library. Its focus is to cover the matrix
+multiplication needs of neural network inference engines. Its initial user has
+been TensorFlow Lite, where it is used by default on the ARM CPU architecture.")
+ (license license:asl2.0))))
+

base-commit: b3492964c2573993b65c20f6e7d16c29cfd6f4f5
--
2.40.1
Andy Tai wrote 2 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E9TDEVoW74d55yt85r2AH4C+F0iJi2a2cH9U70=NTF0bw@mail.gmail.com
block 63897 by 63888, 63889
Andy Tai wrote 2 years ago
(address . 63889@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
cfb7a0b4356514ece5bc122aa59df4ae3de85564.1686032266.git.atai@atai.org
* gnu/packages/maths.scm (ruy): New variable
---
gnu/packages/maths.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4e34124469..c6fabf1973 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8501,3 +8501,36 @@ (define-public scilab
optimization, and modeling, simulation of explicit and implicit dynamical
systems and symbolic manipulations.")
(license license:cecill))) ;CeCILL v2.1
+
+
+(define-public ruy
+ (let ((commit "caa244343de289f913c505100e6a463d46c174de")
+ (version "0")
+ (revision "1"))
+ (package
+ (name "ruy")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/ruy")
+ (commit commit)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z9q2czk9im88zp8d9spiyx3y9l86rgqj0q0xxqq7vfg9ncypay2"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list
+ ;; needs to make sure code is relocatable for
+ ;; use in tensorflow
+ "-DCMAKE_CXX_FLAGS=-fPIC ")))
+ (home-page "https://github.com/google/ruy")
+ (synopsis "Matrix multiplication library")
+ (description
+ "Ruy is a matrix multiplication library. Its focus is to cover the matrix
+multiplication needs of neural network inference engines. Its initial user has
+been TensorFlow Lite, where it is used by default on the ARM CPU architecture.")
+ (license license:asl2.0))))
+

base-commit: 8937898af9433c0b7a8d95a78c95e21576ae22e8
--
2.40.1
Andy Tai wrote 2 years ago
[PATCH v4] gnu: add ruy
(address . 63889@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
82ddb05cd10ccf35e2b4338ebfc0ac2d1d5417ac.1686033863.git.atai@atai.org
* gnu/packages/maths.scm (ruy): New variable
---
gnu/packages/maths.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4e34124469..7904d9e8e3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8501,3 +8501,37 @@ (define-public scilab
optimization, and modeling, simulation of explicit and implicit dynamical
systems and symbolic manipulations.")
(license license:cecill))) ;CeCILL v2.1
+
+
+(define-public ruy
+ (let ((commit "caa244343de289f913c505100e6a463d46c174de")
+ (version "0")
+ (revision "1"))
+ (package
+ (name "ruy")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/ruy")
+ (commit commit)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z9q2czk9im88zp8d9spiyx3y9l86rgqj0q0xxqq7vfg9ncypay2"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DRUY_FIND_CPUINFO=ON"
+ ;; needs to make sure code is relocatable for
+ ;; use in tensorflow
+ "-DCMAKE_CXX_FLAGS=-fPIC ")))
+ (inputs (list cpuinfo googletest))
+ (home-page "https://github.com/google/ruy")
+ (synopsis "Matrix multiplication library")
+ (description
+ "Ruy is a matrix multiplication library. Its focus is to cover the matrix
+multiplication needs of neural network inference engines. Its initial user has
+been TensorFlow Lite, where it is used by default on the ARM CPU architecture.")
+ (license license:asl2.0))))
+

base-commit: 8937898af9433c0b7a8d95a78c95e21576ae22e8
--
2.40.1
Ricardo Wurmus wrote 2 years ago
[PATCH] gnu: add ruy
(address . 63889-done@debbugs.gnu.org)
87il8l6og1.fsf@elephly.net
Applied with minor changes:

- removed recursive git fetch
- changed formatting of arguments
- reflowed paragraph in description
- moved googletest to native-inputs
- corrected commit message
- fixed typos in comments

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63889@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63889
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help