[PATCH] gnu: Add neon2sse

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 2 years ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
0eb48801a9fb91b04e7bce653d13ed31d36cc011.1685867147.git.atai@atai.org
* gnu/packages/assembly.scm (neon2sse): New variable
---
gnu/packages/assembly.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 03a868690c..30b0b27482 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -553,3 +553,33 @@ (define-public intel-xed
tools is named like @code{xed*}. Documentation for the cli tools is sparse, so
this is a case where ``the code is the documentation.''")
(license license:asl2.0)))
+
+(define-public neon2sse
+ (let ((commit "097a5ecacd527d5b5c3006e360fb9cb1c1c48a1f")
+ (version "0")
+ (revision "1"))
+ (package
+ (name "neon2sse")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/intel/ARM_NEON_2_x86_SSE")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17mf788b8asrvjl6dnyzrm5xrz20wx9j5f8n6drgc6qgwqxpx4hv"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;no tests
+ (home-page "https://github.com/intel/ARM_NEON_2_x86_SSE")
+ (synopsis "Header file to simplify ARM->IA32 porting")
+ (description
+ "The NEON_2_SSE.h file is intended to simplify ARM->IA32 porting. It makes
+the correspondence (or a real porting) of ARM NEON intrinsics as defined in
+arm_neon.h header and x86 SSE (up to SSE4.2) intrinsic functions as defined
+in corresponding x86 compilers headers files.")
+ (license license:expat))))
+
+

base-commit: b3492964c2573993b65c20f6e7d16c29cfd6f4f5
prerequisite-patch-id: 1cf5efaef61230f116426626d00146d96f649a21
prerequisite-patch-id: 91e910056bab9b38abdc1a3174ff74018fa5110c
prerequisite-patch-id: b81bf6c33129c089f53609ee5b4e4beaa223d3de
prerequisite-patch-id: b98b4e15f99547cb07147b04bab4129a2248c84d
prerequisite-patch-id: a61599c42d411fe96c04c00d15d943fdb05ca8fa
prerequisite-patch-id: bd30256c0ad82f2f439d31df957962f14342906c
--
2.40.1
Andy Tai wrote 2 years ago
[PATCH v2] gnu: Add neon2sse
(address . 63888@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
2f8bd93b222ad34c8a8a27f0f2624e0292164fe9.1685917952.git.atai@atai.org
* gnu/packages/assembly.scm (neon2sse): New variable
---
gnu/packages/assembly.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 03a868690c..30b0b27482 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -553,3 +553,33 @@ (define-public intel-xed
tools is named like @code{xed*}. Documentation for the cli tools is sparse, so
this is a case where ``the code is the documentation.''")
(license license:asl2.0)))
+
+(define-public neon2sse
+ (let ((commit "097a5ecacd527d5b5c3006e360fb9cb1c1c48a1f")
+ (version "0")
+ (revision "1"))
+ (package
+ (name "neon2sse")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/intel/ARM_NEON_2_x86_SSE")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17mf788b8asrvjl6dnyzrm5xrz20wx9j5f8n6drgc6qgwqxpx4hv"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f)) ;no tests
+ (home-page "https://github.com/intel/ARM_NEON_2_x86_SSE")
+ (synopsis "Header file to simplify ARM->IA32 porting")
+ (description
+ "The NEON_2_SSE.h file is intended to simplify ARM->IA32 porting. It makes
+the correspondence (or a real porting) of ARM NEON intrinsics as defined in
+arm_neon.h header and x86 SSE (up to SSE4.2) intrinsic functions as defined
+in corresponding x86 compilers headers files.")
+ (license license:expat))))
+
+

base-commit: eed55a6544d5bda2245ec853e5fa4b28e1865bea
--
2.40.1
Andy Tai wrote 2 years ago
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
CAJsg1E9TDEVoW74d55yt85r2AH4C+F0iJi2a2cH9U70=NTF0bw@mail.gmail.com
block 63897 by 63888, 63889
Ludovic Courtès wrote 2 years ago
(name . Andy Tai)(address . atai@atai.org)(address . 63888-done@debbugs.gnu.org)
87pm5by5uk.fsf_-_@gnu.org
Andy Tai <atai@atai.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/assembly.scm (neon2sse): New variable

Hi! Applied with the edits below.

Thanks,
Ludo’.
Toggle diff (19 lines)
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 30b0b27482..104e61f63f 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -576,10 +576,11 @@ (define-public neon2sse
(home-page "https://github.com/intel/ARM_NEON_2_x86_SSE")
(synopsis "Header file to simplify ARM->IA32 porting")
(description
- "The NEON_2_SSE.h file is intended to simplify ARM->IA32 porting. It makes
-the correspondence (or a real porting) of ARM NEON intrinsics as defined in
-arm_neon.h header and x86 SSE (up to SSE4.2) intrinsic functions as defined
-in corresponding x86 compilers headers files.")
- (license license:expat))))
+ "The @file{NEON_2_SSE.h} file is intended to simplify ARM-to-IA32
+porting. It makes the correspondence (or a real porting) of ARM NEON
+intrinsics as defined in the @file{arm_neon.h} header and x86 SSE (up to
+SSE4.2) intrinsic functions as defined in corresponding x86 compilers headers
+files.")
+ (license license:bsd-2))))
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63888@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63888
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help