importer fails to find “main” branch on github

  • Open
  • quality assurance status badge
Details
One participant
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 2 Jun 2023 20:30
(address . bug-guix@gnu.org)
87ttvpra00.fsf@elephly.net
This fails:

./pre-inst-env guix import cran -a git -r https://github.com/zdebruine/singlet

With this error:

Toggle snippet (41 lines)
Backtrace:
In guix/ui.scm:
1374:6 19 (guix-import-cran . _)
In ice-9/boot-9.scm:
1752:10 18 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/scripts/import/cran.scm:
121:31 17 (_)
In guix/import/utils.scm:
647:27 16 (recursive-import _ #:repo->guix-package _ #:guix-name _ #:version _ . _)
639:33 15 (lookup-node "https://github.com/zdebruine/singlet" #f)
In guix/memoization.scm:
98:0 14 (mproc "https://github.com/zdebruine/singlet" #:version #f #:repo git #:repo->guix-package #<procedure mproc args> #:guix-name …)
In unknown file:
13 (_ #<procedure 7f75548c7760 at guix/memoization.scm:179:32 ()> #<procedure list _> (this is nothing))
In guix/import/cran.scm:
748:24 12 (_ "https://github.com/zdebruine/singlet" #:repo _ #:version _ #:license-prefix _ #:fetch-description _ #:download-source _)
320:25 11 (fetch-description _ "https://github.com/zdebruine/singlet" _)
In guix/memoization.scm:
98:0 10 (mproc "https://github.com/zdebruine/singlet" #:method git)
In unknown file:
9 (_ #<procedure 7f75548c76c0 at guix/memoization.scm:179:32 ()> #<procedure list _> (this is nothing))
In ice-9/boot-9.scm:
1752:10 8 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/store.scm:
659:37 7 (thunk)
In guix/git.scm:
562:8 6 (latest-repository-commit #<store-connection 256.99 7f75534a4820> "https://github.com/zdebruine/singlet" #:recursive? _ # _ # _ …)
291:4 5 (update-cached-checkout _ #:ref _ #:recursive? _ #:check-out? _ #:starting-commit _ #:log-port _ #:cache-directory _)
241:18 4 (resolve _)
In git/reference.scm:
60:8 3 (_ _ _)
In git/bindings.scm:
77:2 2 (raise-git-error _)
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Git error: reference 'refs/remotes/origin/HEAD' not found

The default branch of this repository is called “main”.

--
Ricardo
?