[PATCH] gnu: po4a: Fix SGML tests.

  • Done
  • quality assurance status badge
Details
3 participants
  • gemmaro
  • Maxim Cournoyer
  • Bruno Victal
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote on 2 Jun 19:52 +0200
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
787df376b4ca9aaf15b8eda7c04ee7ae984d78e9.1685728331.git.gemmaro.dev@gmail.com
* gnu/packages/gettext.scm (po4a): Fix SGML tests.
---
gnu/packages/gettext.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 9387f4fb8a5..0d66d492d40 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2019 Miguel <rosen644835@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
-;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2022, 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Maxim Cournoyer maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -280,10 +280,11 @@ (define-public po4a
(wrap-program file
`("PERL5LIB" ":" prefix (,path))))
(find-files bin "\\.*$")))))
- (add-before 'check 'disable-failing-tests
- (lambda _
- ;; FIXME: fails despite of importing SGMLS
- (delete-file "t/fmt-sgml.t"))))))
+ (add-before 'check 'set-SGML-catalog-file
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "SGML_CATALOG_FILES"
+ (string-append (assoc-ref inputs "docbook-sgml")
+ "/sgml/dtd/docbook/docbook.cat")))))))
(native-inputs
(list gettext-minimal
perl-module-build
@@ -291,11 +292,13 @@ (define-public po4a
libxml2
libxslt
;; For tests.
+ docbook-sgml-4.1
docbook-xml-4.1.2
perl-test-pod
texlive-tiny))
(inputs
(list bash-minimal
+ opensp
perl-gettext
perl-pod-parser
perl-sgmls

base-commit: a7d9cd742c3149bb014db95f88d1158d590bc124
--
2.40.1
B
B
Bruno Victal wrote on 4 Jun 00:12 +0200
(name . gemmaro)(address . gemmaro.dev@gmail.com)(address . 63854@debbugs.gnu.org)
4dc41553-83cb-f126-42ca-96b62ea981f7@makinata.eu
Hi gemmaro,

I think this is the wrong place to set the SGML_CATALOG_FILES,
based on the information in the manpage for xmllint (libxml2),
it seems that the libxml2 package should be setting this variable
through the native-search-paths instead.


--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
G
G
gemmaro wrote on 4 Jun 14:28 +0200
[PATCH core-updates v2 0/2] gnu: po4a: Fix SGML tests.
(address . 63854@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
cover.1685879572.git.gemmaro.dev@gmail.com
Hello Bruno,

Toggle quote (5 lines)
> I think this is the wrong place to set the SGML_CATALOG_FILES,
> based on the information in the manpage for xmllint (libxml2),
> it seems that the libxml2 package should be setting this variable
> through the native-search-paths instead.

Thank you for the review. I moved SGML_CATALOG_FILES from opensp to libxml2
and checked that libxml2, opensp and po4a build pass.

As with the patch series for DocBook [1], this should be core-updates since it
also triggers mass rebuilds.


Thank you again,
gemmaro.

gemmaro (2):
gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.
gnu: po4a: Fix SGML tests.

gnu/packages/gettext.scm | 12 +++++-------
gnu/packages/xml.scm | 37 ++++++++++++++++++++-----------------
2 files changed, 25 insertions(+), 24 deletions(-)


base-commit: b3492964c2573993b65c20f6e7d16c29cfd6f4f5
--
2.40.1
G
G
gemmaro wrote on 4 Jun 14:28 +0200
[PATCH core-updates v2 1/2] gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.
(address . 63854@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
72b82f75a3f87474a3eb40486fd01db09ee97ebd.1685879572.git.gemmaro.dev@gmail.com
* gnu/packages/xml.scm
(libxml2)[native-search-paths]: Add SGML_CATALOG_FILES.
(opensp)[native-search-paths]: Remove SGML_CATALOG_FILES.
---
gnu/packages/xml.scm | 37 ++++++++++++++++++++-----------------
1 file changed, 20 insertions(+), 17 deletions(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 8d9974b825c..c19e7125647 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -222,14 +223,24 @@ (define-public libxml2
(inputs (list xz))
(propagated-inputs (list zlib)) ; libxml2.la says '-lz'.
(native-inputs (list perl))
- ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
- ;; sub-directory of any given package.
- (native-search-paths (list (search-path-specification
- (variable "XML_CATALOG_FILES")
- (separator " ")
- (files '("xml"))
- (file-pattern "^catalog\\.xml$")
- (file-type 'regular))))
+ (native-search-paths
+ (list
+ ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
+ ;; sub-directory of any given package.
+ (search-path-specification
+ (variable "XML_CATALOG_FILES")
+ (separator " ")
+ (files '("xml"))
+ (file-pattern "^catalog\\.xml$")
+ (file-type 'regular))
+ ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
+ ;; under the 'sgml' sub-directory of any given package.
+ (search-path-specification
+ (variable "SGML_CATALOG_FILES")
+ (separator ":")
+ (files '("sgml"))
+ (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
+ (file-type 'regular))))
(search-paths native-search-paths)
(description
"Libxml2 is the XML C parser and toolkit developed for the Gnome
@@ -1743,7 +1754,7 @@ (define-public opensp
(native-inputs
(list docbook-xml-4.1.2
docbook-xsl
- libxml2 ;for XML_CATALOG_DIR
+ libxml2 ;for XML_CATALOG_FILES and SGML_CATALOG_FILES
xmlto
;; Dependencies to regenerate the 'configure' script.
autoconf
@@ -1781,14 +1792,6 @@ (define-public opensp
(("^\tOSGMLNORM=`echo osgmlnorm\\|sed '\\$\\(transform\\)'`\\\\")
"\tOSGMLNORM=`echo osgmlnorm|sed '$(transform)'`")
(("^\t\\$\\(SHELL\\)\n") "")))))))
- ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
- ;; under the 'sgml' sub-directory of any given package.
- (native-search-paths (list (search-path-specification
- (variable "SGML_CATALOG_FILES")
- (separator ":")
- (files '("sgml"))
- (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
- (file-type 'regular))))
(home-page "https://openjade.sourceforge.net/")
(synopsis "Suite of SGML/XML processing tools")
(description "OpenSP is an object-oriented toolkit for SGML parsing and
--
2.40.1
G
G
gemmaro wrote on 4 Jun 14:28 +0200
[PATCH core-updates v2 2/2] gnu: po4a: Fix SGML tests.
(address . 63854@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
99dd54ed52c714945eff265946160f2c682f2899.1685879572.git.gemmaro.dev@gmail.com
* gnu/packages/gettext.scm (po4a)
[arguments]: Fix SGML tests.
[native-inputs]: Add docbook-sgml-4.1.
[inputs]: Add opensp.
---
gnu/packages/gettext.scm | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 9387f4fb8a5..382c1d8e93e 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2019 Miguel <rosen644835@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
-;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2022, 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Maxim Cournoyer maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -279,23 +279,21 @@ (define-public po4a
(for-each (lambda (file)
(wrap-program file
`("PERL5LIB" ":" prefix (,path))))
- (find-files bin "\\.*$")))))
- (add-before 'check 'disable-failing-tests
- (lambda _
- ;; FIXME: fails despite of importing SGMLS
- (delete-file "t/fmt-sgml.t"))))))
+ (find-files bin "\\.*$"))))))))
(native-inputs
(list gettext-minimal
perl-module-build
docbook-xsl
- libxml2
+ libxml2 ;for SGML_CATALOG_FILES
libxslt
;; For tests.
+ docbook-sgml-4.1
docbook-xml-4.1.2
perl-test-pod
texlive-tiny))
(inputs
(list bash-minimal
+ opensp
perl-gettext
perl-pod-parser
perl-sgmls
--
2.40.1
B
B
Bruno Victal wrote on 8 Jun 20:46 +0200
Re: [bug#63854] [PATCH core-updates v2 1/2] gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.
(name . gemmaro)(address . gemmaro.dev@gmail.com)(address . 63854@debbugs.gnu.org)
e4e0b35c-00f9-5532-2a1d-84ad032a3e09@makinata.eu
Hi gemmaro,

On 2023-06-04 13:28, gemmaro wrote:
Toggle quote (4 lines)
> * gnu/packages/xml.scm
> (libxml2)[native-search-paths]: Add SGML_CATALOG_FILES.
> (opensp)[native-search-paths]: Remove SGML_CATALOG_FILES.

[…]

Toggle quote (13 lines)
> @@ -1781,14 +1792,6 @@ (define-public opensp
> (("^\tOSGMLNORM=`echo osgmlnorm\\|sed '\\$\\(transform\\)'`\\\\")
> "\tOSGMLNORM=`echo osgmlnorm|sed '$(transform)'`")
> (("^\t\\$\\(SHELL\\)\n") "")))))))
> - ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
> - ;; under the 'sgml' sub-directory of any given package.
> - (native-search-paths (list (search-path-specification
> - (variable "SGML_CATALOG_FILES")
> - (separator ":")
> - (files '("sgml"))
> - (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
> - (file-type 'regular))))

Interesting, looking at opensp it seems that it also makes use of the
SGML_CATALOG_FILES environment variable so I don't think it shouldn't
be removed though I don't know if it's valid for more than one package
to share the same native-search-path.

Maybe someone else can weigh in?


--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
G
G
gemmaro wrote on 20 Jun 01:47 +0200
[PATCH core-updates v3 0/2] gnu: po4a: Fix SGML tests.
(address . 63854@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
cover.1687217685.git.gemmaro.dev@gmail.com
Hello Bruno,

Bruno Victal <mirai@makinata.eu> writes:
Toggle quote (18 lines)
>> @@ -1781,14 +1792,6 @@ (define-public opensp
>> (("^\tOSGMLNORM=`echo osgmlnorm\\|sed '\\$\\(transform\\)'`\\\\")
>> "\tOSGMLNORM=`echo osgmlnorm|sed '$(transform)'`")
>> (("^\t\\$\\(SHELL\\)\n") "")))))))
>> - ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
>> - ;; under the 'sgml' sub-directory of any given package.
>> - (native-search-paths (list (search-path-specification
>> - (variable "SGML_CATALOG_FILES")
>> - (separator ":")
>> - (files '("sgml"))
>> - (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
>> - (file-type 'regular))))
>
> Interesting, looking at opensp it seems that it also makes use of the
> SGML_CATALOG_FILES environment variable so I don't think it shouldn't
> be removed though I don't know if it's valid for more than one package
> to share the same native-search-path.

You are right. Looking at other packages, there are some
native-search-paths defined with the same name, such as
C_INCLUDE_PATH. One solution to avoid duplication is to define it
globally, like $SSL_CERT_DIR in guix/search-paths.scm, but maybe not
go that far this time. I stopped changing opensp.

Best,
gemmaro.

gemmaro (2):
gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.
gnu: po4a: Fix SGML tests.

gnu/packages/gettext.scm | 12 +++++-------
gnu/packages/xml.scm | 27 +++++++++++++++++++--------
2 files changed, 24 insertions(+), 15 deletions(-)


base-commit: d884fc9e2efecfba09af4694f5a13ad7fc6f704f
--
2.40.1
G
G
gemmaro wrote on 20 Jun 01:47 +0200
[PATCH core-updates v3 1/2] gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.
(address . 63854@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
a1c2e8847ce91e0462ba908ba65a2cd97b7b2e79.1687217685.git.gemmaro.dev@gmail.com
* gnu/packages/xml.scm (libxml2)[native-search-paths]: Add SGML_CATALOG_FILES.
---
gnu/packages/xml.scm | 27 +++++++++++++++++++--------
1 file changed, 19 insertions(+), 8 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 8d9974b825c..e376f0f09b2 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -222,14 +223,24 @@ (define-public libxml2
(inputs (list xz))
(propagated-inputs (list zlib)) ; libxml2.la says '-lz'.
(native-inputs (list perl))
- ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
- ;; sub-directory of any given package.
- (native-search-paths (list (search-path-specification
- (variable "XML_CATALOG_FILES")
- (separator " ")
- (files '("xml"))
- (file-pattern "^catalog\\.xml$")
- (file-type 'regular))))
+ (native-search-paths
+ (list
+ ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
+ ;; sub-directory of any given package.
+ (search-path-specification
+ (variable "XML_CATALOG_FILES")
+ (separator " ")
+ (files '("xml"))
+ (file-pattern "^catalog\\.xml$")
+ (file-type 'regular))
+ ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
+ ;; under the 'sgml' sub-directory of any given package.
+ (search-path-specification
+ (variable "SGML_CATALOG_FILES")
+ (separator ":")
+ (files '("sgml"))
+ (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
+ (file-type 'regular))))
(search-paths native-search-paths)
(description
"Libxml2 is the XML C parser and toolkit developed for the Gnome
--
2.40.1
G
G
gemmaro wrote on 20 Jun 01:47 +0200
[PATCH core-updates v3 2/2] gnu: po4a: Fix SGML tests.
(address . 63854@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
7080ff0ecfe6817501ab3eb64d200158d17c595a.1687217685.git.gemmaro.dev@gmail.com
* gnu/packages/gettext.scm (po4a): Fix SGML tests.
---
gnu/packages/gettext.scm | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 114d8cf7afd..92bc506dd04 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2019 Miguel <rosen644835@gmail.com>
;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
-;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2022, 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Maxim Cournoyer maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -278,23 +278,21 @@ (define-public po4a
(for-each (lambda (file)
(wrap-program file
`("PERL5LIB" ":" prefix (,path))))
- (find-files bin "\\.*$")))))
- (add-before 'check 'disable-failing-tests
- (lambda _
- ;; FIXME: fails despite of importing SGMLS
- (delete-file "t/fmt-sgml.t"))))))
+ (find-files bin "\\.*$"))))))))
(native-inputs
(list gettext-minimal
perl-module-build
docbook-xsl
- libxml2
+ libxml2 ;for SGML_CATALOG_FILES
libxslt
;; For tests.
+ docbook-sgml-4.1
docbook-xml-4.1.2
perl-test-pod
texlive-tiny))
(inputs
(list bash-minimal
+ opensp
perl-gettext
perl-pod-parser
perl-sgmls
--
2.40.1
G
G
gemmaro wrote on 22 Jul 16:56 +0200
[PATCH core-updates v4 0/2] gnu: po4a: Enable SGML format.
(address . 63854@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
cover.1690037161.git.gemmaro.dev@gmail.com
I rebased on top of current master.

gemmaro (2):
gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.
gnu: po4a: Fix SGML tests.

gnu/packages/gettext.scm | 10 ++++------
gnu/packages/xml.scm | 27 +++++++++++++++++++--------
2 files changed, 23 insertions(+), 14 deletions(-)


base-commit: eb12f3fd8bee99920118ec802ffbac8f1ab676b9
--
2.41.0
G
G
gemmaro wrote on 22 Jul 16:56 +0200
[PATCH core-updates v4 1/2] gnu: libxml2: Add SGML_CATALOG_FILES to native-search-path.
(address . 63854@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
faf9d3f80af4f1141a785907203a2c155750b5a7.1690037161.git.gemmaro.dev@gmail.com
* gnu/packages/xml.scm (libxml2)[native-search-paths]: Add SGML_CATALOG_FILES.
---
gnu/packages/xml.scm | 27 +++++++++++++++++++--------
1 file changed, 19 insertions(+), 8 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 555f0ab624..712af965d8 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -222,14 +223,24 @@ (define-public libxml2
(inputs (list xz))
(propagated-inputs (list zlib)) ; libxml2.la says '-lz'.
(native-inputs (list perl))
- ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
- ;; sub-directory of any given package.
- (native-search-paths (list (search-path-specification
- (variable "XML_CATALOG_FILES")
- (separator " ")
- (files '("xml"))
- (file-pattern "^catalog\\.xml$")
- (file-type 'regular))))
+ (native-search-paths
+ (list
+ ;; $XML_CATALOG_FILES lists 'catalog.xml' files found in under the 'xml'
+ ;; sub-directory of any given package.
+ (search-path-specification
+ (variable "XML_CATALOG_FILES")
+ (separator " ")
+ (files '("xml"))
+ (file-pattern "^catalog\\.xml$")
+ (file-type 'regular))
+ ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
+ ;; under the 'sgml' sub-directory of any given package.
+ (search-path-specification
+ (variable "SGML_CATALOG_FILES")
+ (separator ":")
+ (files '("sgml"))
+ (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
+ (file-type 'regular))))
(search-paths native-search-paths)
(description
"Libxml2 is the XML C parser and toolkit developed for the Gnome
--
2.41.0
G
G
gemmaro wrote on 22 Jul 16:56 +0200
[PATCH core-updates v4 2/2] gnu: po4a: Enable SGML format.
(address . 63854@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
a3f711c9a42a5fa7253f656feca2d653aabd00fa.1690037161.git.gemmaro.dev@gmail.com
* gnu/packages/gettext.scm (po4a): Enable SGML format.
[arguments]<phases>: Remove disable-failing-tests phase.
[native-inputs]: Add docbook-sgml-4.1.
[inputs]: Add opensp.
---
gnu/packages/gettext.scm | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index b3dd844147..ca52f912e7 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2019 Miguel <rosen644835@gmail.com>
;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
-;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2022, 2023 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Maxim Cournoyer maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -276,10 +276,6 @@ (define-public po4a
(wrap-program file
`("PERL5LIB" ":" prefix (,path))))
(find-files bin "\\.*$")))))
- (add-before 'check 'disable-failing-tests
- (lambda _
- ;; FIXME: fails despite of importing SGMLS
- (delete-file "t/fmt-sgml.t")))
#$@(if (system-hurd?)
#~((add-after 'unpack 'skip-tests/hurd
(lambda _
@@ -291,14 +287,16 @@ (define-public po4a
(list gettext-minimal
perl-module-build
docbook-xsl
- libxml2
+ libxml2 ;for SGML_CATALOG_FILES
libxslt
;; For tests.
+ docbook-sgml-4.1
docbook-xml-4.1.2
perl-test-pod
(texlive-updmap.cfg)))
(inputs
(list bash-minimal
+ opensp
perl-gettext
perl-pod-parser
perl-sgmls
--
2.41.0
M
M
Maxim Cournoyer wrote on 6 Sep 16:05 +0200
Re: bug#63854: [PATCH] gnu: po4a: Fix SGML tests.
(name . Bruno Victal)(address . mirai@makinata.eu)
878r9j75yh.fsf_-_@gmail.com
Hi,

Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (27 lines)
> Hi gemmaro,
>
> On 2023-06-04 13:28, gemmaro wrote:
>> * gnu/packages/xml.scm
>> (libxml2)[native-search-paths]: Add SGML_CATALOG_FILES.
>> (opensp)[native-search-paths]: Remove SGML_CATALOG_FILES.
>
> […]
>
>> @@ -1781,14 +1792,6 @@ (define-public opensp
>> (("^\tOSGMLNORM=`echo osgmlnorm\\|sed '\\$\\(transform\\)'`\\\\")
>> "\tOSGMLNORM=`echo osgmlnorm|sed '$(transform)'`")
>> (("^\t\\$\\(SHELL\\)\n") "")))))))
>> - ;; $SGML_CATALOG_FILES lists 'catalog' or 'CATALOG' or '*.cat' files found
>> - ;; under the 'sgml' sub-directory of any given package.
>> - (native-search-paths (list (search-path-specification
>> - (variable "SGML_CATALOG_FILES")
>> - (separator ":")
>> - (files '("sgml"))
>> - (file-pattern "^catalog$|^CATALOG$|^.*\\.cat$")
>> - (file-type 'regular))))
>
> Interesting, looking at opensp it seems that it also makes use of the
> SGML_CATALOG_FILES environment variable so I don't think it shouldn't
> be removed though I don't know if it's valid for more than one package
> to share the same native-search-path.

The search paths are not currently 'merged', but if they are exactly
defined the same way (could by via a $SGML_CATALOG_FILES export
defininition (guix search-paths)) then it should work normally.

--
Thanks,
Maxim
B
B
Bruno Victal wrote on 6 Sep 16:28 +0200
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
06f48d52-edb1-4961-97e1-a8baf72ea10c@makinata.eu
Hi Maxim,

On 2023-09-06 15:05, Maxim Cournoyer wrote:
Toggle quote (9 lines)
>> Interesting, looking at opensp it seems that it also makes use of the
>> SGML_CATALOG_FILES environment variable so I don't think it shouldn't
>> be removed though I don't know if it's valid for more than one package
>> to share the same native-search-path.
>
> The search paths are not currently 'merged', but if they are exactly
> defined the same way (could by via a $SGML_CATALOG_FILES export
> defininition (guix search-paths)) then it should work normally.

Indeed, this is what I'm doing in 12/61 from the #65479-v1 [1] patch
series. (hence the partial integration mentioned in the cover letter)



--
Furthermore, I consider that nonfree software must be eradicated.

Cheers,
Bruno.
M
M
Maxim Cournoyer wrote on 6 Sep 20:44 +0200
(name . Bruno Victal)(address . mirai@makinata.eu)
87edjbqgz7.fsf@gmail.com
Hi,

Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (18 lines)
> Hi Maxim,
>
> On 2023-09-06 15:05, Maxim Cournoyer wrote:
>>> Interesting, looking at opensp it seems that it also makes use of the
>>> SGML_CATALOG_FILES environment variable so I don't think it shouldn't
>>> be removed though I don't know if it's valid for more than one package
>>> to share the same native-search-path.
>>
>> The search paths are not currently 'merged', but if they are exactly
>> defined the same way (could by via a $SGML_CATALOG_FILES export
>> defininition (guix search-paths)) then it should work normally.
>
> Indeed, this is what I'm doing in 12/61 from the #65479-v1 [1] patch
> series. (hence the partial integration mentioned in the cover letter)
>
>
> [1]: <https://issues.guix.gnu.org/65479>

OK, excellent.

--
Thanks,
Maxim
B
B
Bruno Victal wrote on 10 Oct 00:20 +0200
[PATCH v5] gnu: po4a: Enable SGML format.
(address . guix-patches@gnu.org)
8bb6da4603509b481cea0795b85b36122d790da3.1696890055.git.mirai@makinata.eu
From: gemmaro <gemmaro.dev@gmail.com>

* gnu/packages/gettext.scm (po4a): Enable SGML format.
[arguments]<phases>: Remove disable-failing-tests phase.
[native-inputs]: Add docbook-sgml-4.1. Remove libxml2.
[inputs]: Add opensp.

Modified-by: Bruno Victal <mirai@makinata.eu>
---

Note: Depends on v3 of https://issues.guix.gnu.org/65479.

gnu/packages/gettext.scm | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 1408cc4cb4..6e22b5a2d3 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -278,10 +278,6 @@ (define-public po4a
(wrap-program file
`("PERL5LIB" ":" prefix (,path))))
(find-files bin "\\.*$")))))
- (add-before 'check 'disable-failing-tests
- (lambda _
- ;; FIXME: fails despite of importing SGMLS
- (delete-file "t/fmt-sgml.t")))
#$@(if (system-hurd?)
#~((add-after 'unpack 'skip-tests/hurd
(lambda _
@@ -293,14 +289,15 @@ (define-public po4a
(list gettext-minimal
perl-module-build
docbook-xsl
- libxml2
libxslt
;; For tests.
+ docbook-sgml-4.1
docbook-xml-4.1.2
perl-test-pod
(texlive-updmap.cfg)))
(inputs
(list bash-minimal
+ opensp
perl-gettext
perl-pod-parser
perl-sgmls

base-commit: 24988295b7b65b4de4e9a8cc378ad13cb247ac91
--
2.41.0
M
M
Maxim Cournoyer wrote on 11 Oct 03:52 +0200
(name . Bruno Victal)(address . mirai@makinata.eu)
87v8bediyk.fsf@gmail.com
Hi,

Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (7 lines)
> From: gemmaro <gemmaro.dev@gmail.com>
>
> * gnu/packages/gettext.scm (po4a): Enable SGML format.
> [arguments]<phases>: Remove disable-failing-tests phase.
> [native-inputs]: Add docbook-sgml-4.1. Remove libxml2.
> [inputs]: Add opensp.

Installed to core-updates; thanks!

--
Thanks,
Maxim
Closed
?