[PATCH] gnu: Add python-cell2cell.

  • Done
  • quality assurance status badge
Details
2 participants
  • Navid Afkhami
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Navid Afkhami
Severity
normal

Debbugs page

Navid Afkhami wrote 2 years ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
13266f60b98b4632c6b7fa2c4e5cacdc3a0840f7.1685719423.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-cell2cell): New variable.
---
gnu/packages/bioinformatics.scm | 64 +++++++++++++++++++++++++++++++++
1 file changed, 64 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 89f8041d56..6dbbc26eac 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1298,6 +1298,70 @@ (define-public python-biofluff
experiments.")
(license license:expat)))
+(define-public python-cell2cell
+ (package
+ (name "python-cell2cell")
+ (version "0.6.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/earmingol/cell2cell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hwww0rcv8sc4k312n4d0jhbyix1jjqgv5djg25bw8127q5iym3s"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ (substitute* "cell2cell/plotting/factor_plot.py"
+ (("from statannotations.Annotator import Annotator")
+ "")
+ (("if statistical_test is not None")
+ "if False"))
+ (substitute* "setup.py"
+ (("'statannotations',")
+ ""))
+ (substitute* "setup.py"
+ (("matplotlib >= 3.2.0,<=3.5.1")
+ ""))
+ (substitute* "setup.py"
+ (("'gseapy == 1.0.3'")
+ "'gseapy'"))))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f ;There are no tests
+ #:phases '(modify-phases %standard-phases
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'build 'set-numba-cache-dir
+ (lambda _
+ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (propagated-inputs (list python-gseapy
+ python-kneed
+ python-matplotlib
+ python-networkx
+ python-numpy
+ python-openpyxl
+ python-pandas
+ python-scikit-learn
+ python-scipy
+ python-seaborn
+ python-statsmodels
+ python-scanpy
+ python-seaborn
+ python-tensorly
+ python-tqdm
+ python-umap-learn
+ python-xlrd))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/earmingol/cell2cell")
+ (synopsis "Python library for cell communication analysis")
+ (description
+ "Cell2cell is a Python library for cell communication analysis.
+This is a method to calculate, visualize and analyze communication
+between cell types. Cell2cell is suitable for single-cell RNA sequencing
+(scRNA-seq) data.")
+ (license license:bsd-3)))
+
(define-public python-cellbender
(package
(name "python-cellbender")

base-commit: a7d9cd742c3149bb014db95f88d1158d590bc124
--
2.34.1
Ricardo Wurmus wrote 2 years ago
(address . 63849-done@debbugs.gnu.org)
87y1l1rble.fsf@elephly.net
Pushed with a few changes with commit
f09944461f97537364231ff213a84faadbfb5fe6.

Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63849@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63849
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help