unbound evaluate-populate-directive variable error with guix shell -C --symlink

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 2 Jun 2023 16:44
(name . bug-guix)(address . bug-guix@gnu.org)
87wn0lexev.fsf@gmail.com
Hi,

This appears to be a recent regression:

Toggle snippet (40 lines)
$ LANG=C guix shell --container --symlink=/usr/bin/env=bin/env coreutils
;;; Failed to autoload evaluate-populate-directive in (gnu build install):
;;; no code for module (gnu build install)
Backtrace:
18 (primitive-load "/home/maxim/.config/guix/current/bin/g?")
In guix/ui.scm:
2300:7 17 (run-guix . _)
2263:10 16 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 15 (with-exception-handler _ _ #:unwind? _ # _)
1752:10 14 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
659:37 13 (thunk)
1298:8 12 (call-with-build-handler _ _)
1298:8 11 (call-with-build-handler #<procedure 7f2709325510 at g?> ?)
In guix/status.scm:
839:4 10 (call-with-status-report _ _)
In guix/scripts/environment.scm:
1152:11 9 (_)
In guix/store.scm:
2168:25 8 (run-with-store #<store-connection 256.99 7f270924b4b0> ?)
In guix/scripts/environment.scm:
864:8 7 (_ _)
In gnu/build/linux-container.scm:
397:16 6 (call-with-container (#<<file-system> device: "none?> ?) ?)
265:16 5 (run-container _ _ (cgroup mnt pid ipc uts user net) _ # ?)
In guix/scripts/environment.scm:
894:14 4 (_)
In srfi/srfi-1.scm:
634:9 3 (for-each #<procedure 7f271a45bc90 at guix/scripts/env?> ?)
In guix/scripts/environment.scm:
894:29 2 (_ (directory "/usr/bin"))
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
error: evaluate-populate-directive: unbound variable

Tested with commit 99fc7e5dd3c9c92f9b6c2e51db9dc5b0481a56b2.

--
Thanks,
Maxim
L
L
Ludovic Courtès wrote on 2 Jun 2023 17:25
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 63845-done@debbugs.gnu.org)
87ilc551kh.fsf@gnu.org
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (41 lines)
> This appears to be a recent regression:
>
> $ LANG=C guix shell --container --symlink=/usr/bin/env=bin/env coreutils
> ;;; Failed to autoload evaluate-populate-directive in (gnu build install):
> ;;; no code for module (gnu build install)
> Backtrace:
> 18 (primitive-load "/home/maxim/.config/guix/current/bin/g?")
> In guix/ui.scm:
> 2300:7 17 (run-guix . _)
> 2263:10 16 (run-guix-command _ . _)
> In ice-9/boot-9.scm:
> 1752:10 15 (with-exception-handler _ _ #:unwind? _ # _)
> 1752:10 14 (with-exception-handler _ _ #:unwind? _ # _)
> In guix/store.scm:
> 659:37 13 (thunk)
> 1298:8 12 (call-with-build-handler _ _)
> 1298:8 11 (call-with-build-handler #<procedure 7f2709325510 at g?> ?)
> In guix/status.scm:
> 839:4 10 (call-with-status-report _ _)
> In guix/scripts/environment.scm:
> 1152:11 9 (_)
> In guix/store.scm:
> 2168:25 8 (run-with-store #<store-connection 256.99 7f270924b4b0> ?)
> In guix/scripts/environment.scm:
> 864:8 7 (_ _)
> In gnu/build/linux-container.scm:
> 397:16 6 (call-with-container (#<<file-system> device: "none?> ?) ?)
> 265:16 5 (run-container _ _ (cgroup mnt pid ipc uts user net) _ # ?)
> In guix/scripts/environment.scm:
> 894:14 4 (_)
> In srfi/srfi-1.scm:
> 634:9 3 (for-each #<procedure 7f271a45bc90 at guix/scripts/env?> ?)
> In guix/scripts/environment.scm:
> 894:29 2 (_ (directory "/usr/bin"))
> In ice-9/boot-9.scm:
> 1685:16 1 (raise-exception _ #:continuable? _)
> 1685:16 0 (raise-exception _ #:continuable? _)
>
> ice-9/boot-9.scm:1685:16: In procedure raise-exception:
> error: evaluate-populate-directive: unbound variable

Fixed in 69dfdb7bd190a1562eb11555da6f556b222245d3.

The regression was introduced in
abdf812acc70d5424e51e2d6fb280bf08b087b68.

Thanks,
Ludo’.
Closed
M
M
Maxim Cournoyer wrote on 3 Jun 2023 03:26
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 63845-done@debbugs.gnu.org)
87jzwle3pa.fsf@gmail.com
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (11 lines)
> Hi,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> This appears to be a recent regression:
>>
>> $ LANG=C guix shell --container --symlink=/usr/bin/env=bin/env coreutils
>> ;;; Failed to autoload evaluate-populate-directive in (gnu build install):
>> ;;; no code for module (gnu build install)
>> Backtrace:

[...]

Toggle quote (8 lines)
>> ice-9/boot-9.scm:1685:16: In procedure raise-exception:
>> error: evaluate-populate-directive: unbound variable
>
> Fixed in 69dfdb7bd190a1562eb11555da6f556b222245d3.
>
> The regression was introduced in
> abdf812acc70d5424e51e2d6fb280bf08b087b68.

Yay! Thanks for the quick fix.

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63845@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63845
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch