(name . bug-guix)(address . bug-guix@gnu.org)
Hi,
This appears to be a recent regression:
Toggle snippet (40 lines)
$ LANG=C guix shell --container --symlink=/usr/bin/env=bin/env coreutils
;;; Failed to autoload evaluate-populate-directive in (gnu build install):
;;; no code for module (gnu build install)
Backtrace:
18 (primitive-load "/home/maxim/.config/guix/current/bin/g?")
In guix/ui.scm:
2300:7 17 (run-guix . _)
2263:10 16 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 15 (with-exception-handler _ _ #:unwind? _ # _)
1752:10 14 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
659:37 13 (thunk)
1298:8 12 (call-with-build-handler _ _)
1298:8 11 (call-with-build-handler #<procedure 7f2709325510 at g?> ?)
In guix/status.scm:
839:4 10 (call-with-status-report _ _)
In guix/scripts/environment.scm:
1152:11 9 (_)
In guix/store.scm:
2168:25 8 (run-with-store #<store-connection 256.99 7f270924b4b0> ?)
In guix/scripts/environment.scm:
864:8 7 (_ _)
In gnu/build/linux-container.scm:
397:16 6 (call-with-container (#<<file-system> device: "none?> ?) ?)
265:16 5 (run-container _ _ (cgroup mnt pid ipc uts user net) _ # ?)
In guix/scripts/environment.scm:
894:14 4 (_)
In srfi/srfi-1.scm:
634:9 3 (for-each #<procedure 7f271a45bc90 at guix/scripts/env?> ?)
In guix/scripts/environment.scm:
894:29 2 (_ (directory "/usr/bin"))
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
error: evaluate-populate-directive: unbound variable
Tested with commit 99fc7e5dd3c9c92f9b6c2e51db9dc5b0481a56b2.
--
Thanks,
Maxim