[PATCH guix-artwork] website: data: Discard translations in help blurbs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Florian Pelz
Owner
unassigned
Submitted by
Florian Pelz
Severity
normal

Debbugs page

Florian Pelz wrote 2 years ago
(address . guix-patches@gnu.org)(name . Florian Pelz)(address . pelzflorian@pelzflorian.de)
20230602102043.13597-1-pelzflorian@pelzflorian.de
We no longer need the blurbs, now that the website has
gettext translations that are reasonably complete, except
Hungarian, which we lose.

* website/apps/base/data.scm (contact-media)["Help Mailing List"]:
Drop legacy blurbs.
---
website/apps/base/data.scm | 68 ++------------------------------------
1 file changed, 3 insertions(+), 65 deletions(-)

Toggle diff (85 lines)
diff --git a/website/apps/base/data.scm b/website/apps/base/data.scm
index ad44a10..bd2c7ab 100644
--- a/website/apps/base/data.scm
+++ b/website/apps/base/data.scm
@@ -44,73 +44,11 @@ English)."))
(contact
#:name (G_ "Help Mailing List")
#:description
- ;; Compute an association list from language code to blurb.
- ;; If possible, look up translated blurbs from the PO file.
- ;; Fall back to old hard-coded translations.
- (let ((original '(G_
- "Subscribe to the Help mailing list to get support
+ (G_
+ `(p
+ "Subscribe to the Help mailing list to get support
from the GNU Guix community via email. You can post messages in English
though we also accept other languages."))
- (lang-code '(C_ "unique lingua code like en or zh-cn" "en")))
- (sort
- (delete-duplicates
- (append
- (delete ;delete untranslated blurbs other than "en"
- (cons original lang-code)
- (map-in-order
- (lambda (lingua)
- (begin
- (setlocale LC_ALL (string-append lingua ".utf8"))
- (let ((out (list (gettext (string-append
- (cadr lang-code) ;msgctxt
- (string #\eot) ;separates msgctxt
- (caddr lang-code))) ;msgid
- (gettext (cadr original)))))
- (setlocale LC_ALL "")
- (if (string-index (car out) #\eot) ;if untranslated
- (list (caddr lang-code) (cadr original)) ;use original
- out)))) ;else use what has been looked up via gettext
- %linguas)
- (lambda (to-delete b) (and ;delete where text is equal to original
- (string=? (cadar to-delete) (cadr b))
- ;; but language code is different
- (not (string=? (cadddr to-delete) (car b))))))
- `(("eo"
- "Subskribu al la retmesaĝolisto \"Help\" por demandi helpon pri
-GNU Guix al la grupo. Vi povas skribi esperantlingve.")
- ("fr"
- "Abonnez-vous à la liste de diffusion « Help » pour obtenir l'aide
-de la communauté sur GNU Guix par courrier électronique. Vous
-pouvez envoyer des messages en français.")
- ("hu"
- "Iratkozzon fel a „Help“ levelezőlistára, hogy segítséget kaphasson
-e-mailben a Guix System és a GNU Guix közösségtől. Magyarul is küldhet
-üzeneteket.")
- ("it"
- "Iscrivetevi alla mailing list 'Help' per essere aiutati da altri
-utenti di Guix e Guix System. Potete scrivere sulla mailing list anche in
-italiano.")
- ("ja"
- "メールでGNU GuixとGuix Systemのコミュニティからサポートを受けるには、
-「Help」のメーリングリストに登録してください。
-メッセージ内容は日本語でも問題ございませんが、多言語でも受け付けております。")
- ("nb"
- "Meld deg på diskusjonslisten «Help» for å få råd og tips fra
-andre Guix System- og GNU Guix-brukere via e-post. Du kan legge inn
-meldinger på norsk.")
- ("nl"
- "Abonneer je op de discussielijst \"Help\" om hulp te vragen
-van de Guix System- en GNU Guix-gemeenschap. Je kunt berichten sturen in
-het Nederlands.")
- ("ru"
- "Подпишитесь на список рассылки «Help», чтобы получить помощь от
-сообщества Guix System и GNU Guix по электронной почте. Вы можете писать на русском
-языке.")
- ("zh-Hant"
- "訂閱「Help」郵件群組以電郵從Guix System及GNU Guix社群取得支援。你可以使用
-正體、繁體中文發送訊息。")))
- (lambda (a b) (string=? (car a) (car b))))
- (lambda (a b) (string<? (car a) (car b)))))
#:url "https://lists.gnu.org/mailman/listinfo/help-guix"
#:log "https://lists.gnu.org/archive/html/help-guix")

base-commit: dbc448b94a25564a7bb5d139243a5ea7845529dd
--
2.40.1
Ludovic Courtès wrote 2 years ago
(name . Florian Pelz)(address . pelzflorian@pelzflorian.de)(address . 63836@debbugs.gnu.org)
87y1kyi01a.fsf@gnu.org
Hallo,

Florian Pelz <pelzflorian@pelzflorian.de> skribis:

Toggle quote (7 lines)
> We no longer need the blurbs, now that the website has
> gettext translations that are reasonably complete, except
> Hungarian, which we lose.
>
> * website/apps/base/data.scm (contact-media)["Help Mailing List"]:
> Drop legacy blurbs.

LGTM, thank you!

Ludo’.
pelzflorian (Florian Pelz) wrote 2 years ago
(address . 63836-done@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
873535w174.fsf@pelzflorian.de
Pushed as 42bfae16b7f09c4ec3765c3177d5d976f618ff21, thank you!

Regards,
Florian
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63836@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63836
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help