[PATCH] gnu: Add r-mbecs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 2 years ago
(address . guix-patches@gnu.org)
dd772332501fc0ef4f4853c691eb1665466bd397.1685453860.git.madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-mbecs): New variable.
---
gnu/packages/bioconductor.scm | 51 +++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 265a70cdd4..b75b9f1886 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10118,6 +10118,57 @@ (define-public r-ripseeker
processing to visualization and annotation.")
(license license:gpl2)))
+(define-public r-mbecs
+ (package
+ (name "r-mbecs")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "MBECS" version))
+ (sha256
+ (base32 "0gfr3c5k7xjd342zfdksgh22mrk3ryr4cp89nar0mlpgzxg4l4vz"))))
+ (properties `((upstream-name . "MBECS")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-HOME
+ ;; Fontconfig needs an writable cache
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list r-cluster
+ r-dplyr
+ r-ggplot2
+ r-gridextra
+ r-limma
+ r-lme4
+ r-lmertest
+ r-magrittr
+ r-markdown
+ r-matrix
+ r-pheatmap
+ r-phyloseq
+ r-rmarkdown
+ r-ruv
+ r-sva
+ r-tibble
+ r-tidyr
+ r-vegan))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/rmolbrich/MBECS")
+ (synopsis
+ "Evaluation and correction of batch effects in microbiome data-sets")
+ (description
+ "The @acronym{MBECS, Microbiome Batch Effect Correction Suite} provides a
+set of functions to evaluate and mitigate unwated noise due to processing in
+batches. To that end it incorporates a host of batch correcting algorithms
+(BECA) from various packages. In addition it offers a correction and reporting
+pipeline that provides a preliminary look at the characteristics of a data-set
+before and after correcting for batch effects.")
+ (license license:artistic2.0)))
+
(define-public r-mbkmeans
(package
(name "r-mbkmeans")

base-commit: 3807876af4b53babdbc2f1d730e4763ff651f316
--
2.40.1
Ricardo Wurmus wrote 2 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 63803-done@debbugs.gnu.org)
87a5xjtzp3.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-mbecs): New variable.

Applied, thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63803@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63803
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help