[PATCH] gnu: blesh: Update to 0.4.0-devel3.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
ba0eb3f6f133ec9807913ef47fbbcb3f54f04edf.1685404012.git.kiasoc5@disroot.org
I couldn't figure out how to get the commit hash of the git repo, as git-fetch doesn't make .git available in the build directory. For now I use #$version instead.

* gnu/packages/bash.scm (blesh): Update to 0.4.0-devel3.
[source]: Use recursive checkout.
[phases]: Remove 'make-readlink-work. Rename 'pretend-contrib-.git-exists
to 'pretend-.git-exists. Substitute commit_hash for package version.
[native-inputs]: Add git.
---
gnu/packages/bash.scm | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 43f38303f7..bb3359d5d1 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -445,28 +445,27 @@ (define-public bash-ctypes
(define-public blesh
(package
(name "blesh")
- (version "0.4.0-devel2")
+ (version "0.4.0-devel3")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/akinomyoga/ble.sh")
- (commit (string-append "v" version))))
+ (commit (string-append "v" version))
+ (recursive? #t)))
(file-name (git-file-name name version))
(sha256
(base32
- "02fdjyh4x6wr5hg3i86nsxhz8ysgjrvvxdmk6pqr0lm8ngw9p3sh"))))
+ "19y9rmj9srl7akx33gl34l5qgz2ww0vlmi4j2r11029p8sn4s418"))))
(arguments
(list #:make-flags #~(list (string-append "PREFIX="
#$output))
#:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'pretend-contrib-.git-exists
- (lambda _
- (mkdir-p "contrib/.git")))
- (add-after 'unpack 'make-readlink-work
+ (add-after 'unpack 'pretend-.git-exists
(lambda _
(substitute* "ble.pp"
- (("PATH=/bin:/usr/bin readlink")
- "readlink"))))
+ (("#%\\[commit_hash =.*")
+ (string-append "#%[commit_hash = " #$version "]\n")))
+ (mkdir-p ".git")))
(delete 'configure) ;no configure
(add-before 'check 'use-LANG-for-tests
(lambda _
@@ -474,7 +473,7 @@ (define-public blesh
(getenv "LC_ALL"))
(unsetenv "LC_ALL"))))))
(build-system gnu-build-system)
- (native-inputs (list less))
+ (native-inputs (list git less))
(home-page "https://github.com/akinomyoga/ble.sh")
(synopsis "Bash Line Editor")
(description

base-commit: b96b82bcd4bc24529941ff74a91432481f1a71b5
--
2.40.1
Ludovic Courtès wrote 2 years ago
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 63795-done@debbugs.gnu.org)
87r0q0zynb.fsf@gnu.org
Hi,

kiasoc5 <kiasoc5@disroot.org> skribis:

Toggle quote (2 lines)
> I couldn't figure out how to get the commit hash of the git repo, as git-fetch doesn't make .git available in the build directory. For now I use #$version instead.

Good idea.

Toggle quote (6 lines)
> * gnu/packages/bash.scm (blesh): Update to 0.4.0-devel3.
> [source]: Use recursive checkout.
> [phases]: Remove 'make-readlink-work. Rename 'pretend-contrib-.git-exists
> to 'pretend-.git-exists. Substitute commit_hash for package version.
> [native-inputs]: Add git.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63795@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63795
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help