[PATCH] home: services: ssh: Allow unset boolean options in ssh-config.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andrew Tropin
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal

Debbugs page

Efraim Flashner wrote 2 years ago
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
6f1959b0041895af538fec1b72a02d7767451767.1685371966.git.efraim@flashner.co.il
From man 5 ssh_config:
Unless noted otherwise, for each parameter, the first obtained value
will be used.

We want to allow falling through to the first actual user defined value.

* gnu/home/services.ssh.scm (define-maybe boolean): New configuration.
(openssh-host)[forward-x11?, forward-x11-trusted?, forward-agent?,
compression?]: Replace default value with maybe-boolean.
* doc/guix.texi (Secure Shell): Update documentation to match the
changes in the code.
---
doc/guix.texi | 10 +++++-----
gnu/home/services/ssh.scm | 11 +++++++----
2 files changed, 12 insertions(+), 9 deletions(-)

Toggle diff (88 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 31dc33fb97..d22924e522 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -33,7 +33,7 @@
Copyright @copyright{} 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022, 2023 Ricardo Wurmus@*
Copyright @copyright{} 2016 Ben Woodcroft@*
Copyright @copyright{} 2016, 2017, 2018, 2021 Chris Marusich@*
-Copyright @copyright{} 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner@*
+Copyright @copyright{} 2016, 2017, 2018, 2019, 2020, 2021, 2022, 2023 Efraim Flashner@*
Copyright @copyright{} 2016 John Darrington@*
Copyright @copyright{} 2016, 2017 Nikita Gillmann@*
Copyright @copyright{} 2016, 2017, 2018, 2019, 2020, 2021, 2022, 2023 Jan Nieuwenhuizen@*
@@ -43017,19 +43017,19 @@ Secure Shell
@item @code{user} (type: maybe-string)
User name on the remote host.
-@item @code{forward-x11?} (default: @code{#f}) (type: boolean)
+@item @code{forward-x11?} (type: maybe-boolean)
Whether to forward remote client connections to the local X11 graphical
display.
-@item @code{forward-x11-trusted?} (default: @code{#f}) (type: boolean)
+@item @code{forward-x11-trusted?} (type: maybe-boolean)
Whether remote X11 clients have full access to the original X11
graphical display.
-@item @code{forward-agent?} (default: @code{#f}) (type: boolean)
+@item @code{forward-agent?} (type: maybe-boolean)
Whether the authentication agent (if any) is forwarded to the remote
machine.
-@item @code{compression?} (default: @code{#f}) (type: boolean)
+@item @code{compression?} (type: maybe-boolean)
Whether to compress data in transit.
@item @code{proxy} (type: maybe-proxy-command-or-jump-list)
diff --git a/gnu/home/services/ssh.scm b/gnu/home/services/ssh.scm
index 628dc743ae..0a4b37d84e 100644
--- a/gnu/home/services/ssh.scm
+++ b/gnu/home/services/ssh.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -104,6 +105,8 @@ (define (serialize-natural-number field value)
(string-append " " (serialize-field-name field) " "
(number->string value) "\n"))
+(define-maybe boolean)
+
(define (serialize-boolean field value)
(string-append " " (serialize-field-name field) " "
(if value "yes" "no") "\n"))
@@ -194,19 +197,19 @@ (define-configuration openssh-host
maybe-string
"User name on the remote host.")
(forward-x11?
- (boolean #f)
+ maybe-boolean
"Whether to forward remote client connections to the local X11 graphical
display.")
(forward-x11-trusted?
- (boolean #f)
+ maybe-boolean
"Whether remote X11 clients have full access to the original X11 graphical
display.")
(forward-agent?
- (boolean #f)
+ maybe-boolean
"Whether the authentication agent (if any) is forwarded to the remote
machine.")
(compression?
- (boolean #f)
+ maybe-boolean
"Whether to compress data in transit.")
(proxy-command
maybe-string

base-commit: 7b400e7f8751e6b0cc6e66d3f7ecfb7f5bd51309
--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Ludovic Courtès wrote 2 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 63786@debbugs.gnu.org)
87ilbx1xku.fsf@gnu.org
Hello!

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (6 lines)
>>From man 5 ssh_config:
> Unless noted otherwise, for each parameter, the first obtained value
> will be used.
>
> We want to allow falling through to the first actual user defined value.

What do you mean by “first actual user-defined value”? This service is
what generates all the “user-defined values”, no?

Overall my take is that default values should be specified in our code
(as default values of configuration record fields) rather than left
unspecified. I think this is clearer and more predictable than relying
on upstream’s default values.

Thanks,
Ludo’.
Efraim Flashner wrote 2 years ago
Re: bug#63786: [PATCH] home: services: ssh: Allow unset boolean
(address . 63786@debbugs.gnu.org)
ZIV8pvv8U5ras1X2@3900XT
options in ssh-config.
Reply-To:
X-PGP-Key-ID: 0x41AAE7DCCA3D8351
X-PGP-Fingerprint: A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351

For some reason this didn't get sent to the bug.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Date: Fri, 9 Jun 2023 16:24:26 +0300
From: Efraim Flashner <efraim@flashner.co.il>
To: Ludovic =?utf-8?Q?Court=C3=A8s?= <ludo@gnu.org>
Subject: Re: bug#63786: [PATCH] home: services: ssh: Allow unset boolean
options in ssh-config.
Message-ID: <ZIMoCIMm22unHsc4@3900XT>
References: <6f1959b0041895af538fec1b72a02d7767451767.1685371966.git.efraim@flashner.co.il>
<87ilbx1xku.fsf@gnu.org>
MIME-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha256;
protocol="application/pgp-signature"; boundary="/+KKtAVMmHMtW/th"
Content-Disposition: inline
In-Reply-To: <87ilbx1xku.fsf@gnu.org>
X-PGP-Key-ID: 0x41AAE7DCCA3D8351
X-PGP-Fingerprint: A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351


--/+KKtAVMmHMtW/th
Content-Type: text/plain; charset=utf-8
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Thu, Jun 08, 2023 at 10:57:37PM +0200, Ludovic Court=C3=A8s wrote:
Toggle quote (11 lines)
> Hello!
>=20
> Efraim Flashner <efraim@flashner.co.il> skribis:
>=20
> >>From man 5 ssh_config:
> > Unless noted otherwise, for each parameter, the first obtained value
> > will be used.
> >
> > We want to allow falling through to the first actual user defined value.
>=20
> What do you mean by =E2=80=9Cfirst actual user-defined value=E2=80=9D? T=
his service is
Toggle quote (2 lines)
> what generates all the =E2=80=9Cuser-defined values=E2=80=9D, no?

Right now my ~/.ssh/config has

Host do1-tor
Hostname <insert tor address>
IdentityFile ~/.ssh/id_ed25519
Host *.onion *-tor
#ProxyCommand /gnu/store/dgvybjrj154f4cyfbkrbqyirv5gd8ic2-netcat-openbs=
d-1.218-2/bin/nc -X 5 -x localhost:9050 %h %p
ProxyCommand /home/efraim/bin/openbsd-netcat -X 5 -x localhost:9050 %h =
%p
ControlPath ${XDG_RUNTIME_DIR}/%r@%k-%p
Compression yes

The way the ssh config is read is that `ssh do1-tor` first matches
do1-tor and then also matches *-tor, so I can factor our ProxyCommand,
ControlPath and Compression for use with the other *-tor Hosts I have
listed.

This configuration could be
(openssh-host (name "do1-tor")
(host-name <insert tor address>)
(identity-file "~/.ssh/id_ed25519"))
(openssh-host (name "*-onion *-tor)
(compression? #t)
(proxy
(proxy-command ...))
(extra-content " ControlPath ...\n"))

If this is all I enter, then my .ssh/config is generated like this:

Host do1-tor
Hostname <insert tor address>
IdentityFile ~/.ssh/id_ed25519
ForwardX11 no
ForwardX11Trusted no
ForwardAgent no
Compression no
Host *.onion *-tor
ForwardX11 no
ForwardX11Trusted no
ForwardAgent no
Compression yes
ProxyCommand /home/efraim/bin/openbsd-netcat -X 5 -x localhost:9050 %h %p
ControlPath ${XDG_RUNTIME_DIR}/%r@%k-%p

Compression might default to no, but in my hand crafted .ssh/config I've
set it to yes for *-tor Hosts. Forward* might all default to no, and
it's not set anywhere, but being explicit about the default here could
cause problems if I want X11 forwarding across an entire range of hosts,
not just individual ones.

Toggle quote (5 lines)
> Overall my take is that default values should be specified in our code
> (as default values of configuration record fields) rather than left
> unspecified. I think this is clearer and more predictable than relying
> on upstream=E2=80=99s default values.

In general this is a good plan, but here it actually interferes with the
expected configuration output. 'Fall through' is the default, not the
actual default for each of the individual configuration options. They
only get set if that field isn't set by any of the possibly multiple
configuration matches set it first.


--=20
Efraim Flashner <efraim@flashner.co.il> =D7=A8=D7=A0=D7=A9=D7=9C=D7=A4 =
=D7=9D=D7=99=D7=A8=D7=A4=D7=90
GPG key =3D A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted

--/+KKtAVMmHMtW/th
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmSDKAQACgkQQarn3Mo9
g1GEVBAAshjlsAjh/+PR650tR4unLPpp7yCTbMmsiNjizrxNIFIRaMc1y7S/8Mcj
5iu0+b8p8Z+4sVWNdEemZLgZAUf6rafv2Ujlk9Ky1HCbWgTXVqe0KNCjDP9Q8t3D
Lu3y+jreMjuJ/PLvFXR0ZOLoqh8kzn5RdrHc25nc92ev1KDzUKH9jlCbanSDRx4x
vISV8euOFA+P2JZvhvs6hn/aF2gcZzuivTiAoGY5PgVOU52dbLebUAAe79fe1fJb
sRjH+tglhEvxqV8D8BWABbASp0VmV3LjV4yJg3dHWRcsqwRmmKxIqtbKjkYIAd5f
MTP6w858BCXLTx0Am5MpfadzSS4FIFOgq885Ze5PCGcEP0Ut9LnDd9jYHicW19MO
td7zvpQUUmiu70viWD/P2m0c+yWmg+S0AhmjArwnTG1yP4ua+mjmOmca8HqYjTiU
DsunVxyiXlffJOi/wstk//idsVPH8IV7CpJsxwUfDdwFZ5cnS3Tbb3Z9ILNhWc/d
olnndyctzU3avX2r7zWaC/ISbap9o90eXBS4tEfSGy/sL6pHwChBKr6i7jVX5xL/
p8YX8YmwvNiDXUHq9pYc+0KHTlNz6lsKY1jDNpH+5gxI1fjkXDw377YT8vXR8Vzl
R2ERChBH+gh5eF2OtvycAzO5vqRw7zy6yOshh1D+MeNGqddBx2g=
=luXe
-----END PGP SIGNATURE-----

--/+KKtAVMmHMtW/th--


-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmSFfKIACgkQQarn3Mo9
g1ExXA/6AmsOp4Wdu/ViKVikV+E/iMR07+MDOSrKdcWQtsrtvCwCV0MqNSP90/s0
KkrQdtQwNmi9q2pgwOrjywSMLb+dWf9sqbFXJ7hAGmdsJPhQas52toy2nDPNLSk6
0xT27zAHEeM3IBM9pRweT0mYqBnvNYQ0n0y2CXTilK27F1NBjZm1eTqjmv6AezH3
lnAMq18x08NGp2FW8vmrrpbPuVhUGfl7rZdZaLE8jCvwW0grmAIZia3JQRBK2uWl
me8f0Y/WDVZqnlddKNxMQYXvkmPqn4XN9AssgfVWu9usUTo16XGK/gO6Z3XOijMM
as9mPDjp9cI+1tFTm+gut96lGDwA+652R8WEM9ZxtMmyYk8/cznz/duaBArVj4UT
0vB/IUmp8DQn8jxeEOKtTD/g5hTbSE7Gpi90Tv4+gKvUSjDbRvD8jGLDrb6XcJfd
yNFGi1I9XYZ7iuwoZwuI96I9ibPD0vAFdwc4gk0O0dmghTuR8NSmR4ENebAEq/AX
XxG1DsRbT+W9uJ2J178E3/PgfQIy4TfZYDtbYgPNbMAqBL1QhZGf/Rx18DYSQqaL
QNRC/uIZIGWKl+jta4RCq9ld39/nXCN5doTSIFldf0EvNx3WuNEO6CvuOIJahx22
8eVF1Y49kku+lGumrAzKEbNYA6PLHeCgzct5UZlPiXa85sSI5+s=
=R2m0
-----END PGP SIGNATURE-----


Andrew Tropin wrote 2 years ago
Re: [bug#63786] [PATCH] home: services: ssh: Allow unset boolean
87r0qhmg45.fsf@trop.in
On 2023-06-11 10:49, Efraim Flashner wrote:

Toggle quote (91 lines)
> options in ssh-config.
> Reply-To:
> X-PGP-Key-ID: 0x41AAE7DCCA3D8351
> X-PGP-Key: https://flashner.co.il/~efraim/efraim_flashner.asc
> X-PGP-Fingerprint: A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
>
> For some reason this didn't get sent to the bug.
>
> --
> Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
> GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received unencrypted
> From: Efraim Flashner <efraim@flashner.co.il>
> Subject: Re: bug#63786: [PATCH] home: services: ssh: Allow unset boolean options in ssh-config.
> To: Ludovic Courtès <ludo@gnu.org>
> Date: Fri, 09 Jun 2023 16:24:26 +0300
>
> On Thu, Jun 08, 2023 at 10:57:37PM +0200, Ludovic Courtès wrote:
>> Hello!
>>
>> Efraim Flashner <efraim@flashner.co.il> skribis:
>>
>> >>From man 5 ssh_config:
>> > Unless noted otherwise, for each parameter, the first obtained value
>> > will be used.
>> >
>> > We want to allow falling through to the first actual user defined value.
>>
>> What do you mean by “first actual user-defined value”? This service is
>> what generates all the “user-defined values”, no?
>
> Right now my ~/.ssh/config has
>
> Host do1-tor
> Hostname <insert tor address>
> IdentityFile ~/.ssh/id_ed25519
> Host *.onion *-tor
> #ProxyCommand /gnu/store/dgvybjrj154f4cyfbkrbqyirv5gd8ic2-netcat-openbsd-1.218-2/bin/nc -X 5 -x localhost:9050 %h %p
> ProxyCommand /home/efraim/bin/openbsd-netcat -X 5 -x localhost:9050 %h %p
> ControlPath ${XDG_RUNTIME_DIR}/%r@%k-%p
> Compression yes
>
> The way the ssh config is read is that `ssh do1-tor` first matches
> do1-tor and then also matches *-tor, so I can factor our ProxyCommand,
> ControlPath and Compression for use with the other *-tor Hosts I have
> listed.
>
> This configuration could be
> (openssh-host (name "do1-tor")
> (host-name <insert tor address>)
> (identity-file "~/.ssh/id_ed25519"))
> (openssh-host (name "*-onion *-tor)
> (compression? #t)
> (proxy
> (proxy-command ...))
> (extra-content " ControlPath ...\n"))
>
> If this is all I enter, then my .ssh/config is generated like this:
>
> Host do1-tor
> Hostname <insert tor address>
> IdentityFile ~/.ssh/id_ed25519
> ForwardX11 no
> ForwardX11Trusted no
> ForwardAgent no
> Compression no
> Host *.onion *-tor
> ForwardX11 no
> ForwardX11Trusted no
> ForwardAgent no
> Compression yes
> ProxyCommand /home/efraim/bin/openbsd-netcat -X 5 -x localhost:9050 %h %p
> ControlPath ${XDG_RUNTIME_DIR}/%r@%k-%p
>
> Compression might default to no, but in my hand crafted .ssh/config I've
> set it to yes for *-tor Hosts. Forward* might all default to no, and
> it's not set anywhere, but being explicit about the default here could
> cause problems if I want X11 forwarding across an entire range of hosts,
> not just individual ones.
>
>> Overall my take is that default values should be specified in our code
>> (as default values of configuration record fields) rather than left
>> unspecified. I think this is clearer and more predictable than relying
>> on upstream’s default values.
>
> In general this is a good plan, but here it actually interferes with the
> expected configuration output. 'Fall through' is the default, not the
> actual default for each of the individual configuration options. They
> only get set if that field isn't set by any of the possibly multiple
> configuration matches set it first.

A few years ago, when we were implementing the first version of ssh home
service in rde we went a slightly different way and didn't hardcode any
record fields and let user set an alist of key/value pairs:

It's not a perfect solution either, but quite flexible. Also, it's
relatively easy to implement default values: we can provide
%default-host-options and ask people to do something like this on user
side configuration:

(merge %default-host-options '((compression . #f)))

Of course "asking people" won't work, so it's possible to set a default
value of options field to %default-host-options
and let people override it with '((compression . #f)) or enrich with
(merge %default-host-options '((compression . #f))).

It's not a proposal or something, just sharing how it's implemented in
rde.


P.S. Note that (gnu home-services *) modules are subject to deprecation
and when (rde home services ssh) appear, it will have a slightly
different interface.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmSGpeoACgkQIgjSCVjB
3rBLcg/+IeVr8QYWi6VvEuih68CzTxghn4JiIUC3xKnkCqQ9emdq6TA+ZobHrUMD
3G7CZzB+WNl0JfU6msbr02/FxvLIb4DLjQuKhAnYmMGFzVR/ei3xN3H0EYwAM2cg
HubwTRYZlcYnTaFavaV1o558OKmhxPCRkMn7ge8JDXUA5ccJZ8ZH9u9i9TsPl5dJ
HSGTGUZeyLFNGC7B12p9xYiiAGQGNiOSODW9qonJ3xWxjtBEpsekUU9C1xH8YD37
LRhVK9bw7cry0VEgKFMKYUKojmPGrgXNAPd5bjr0YN3wR/ZwEjYch5iNj8QDQ4um
EvAIQVe7Vw7BYFyybCP3LOElidIzn4DyuwPFQIRwEylV2v3u8AFLsobmghrlZE0s
s061eNrjeSH8FBa0zO/SEF57M6VErXfIrJVCYZjoSWetxzkNj/ZUunm1/NR83rVF
W5zkZxQASfHpZ2dAMhkervngtgYAi1mVz1GQnmTZiEy38mOEBUahADquZPGUcmNo
qStWD3WdykrAHDtxbrl5s5JDjDJ2ojhsM77JqjrmZmUXdHUfHBGnbGi6Q+y/kqwm
5C0/fZTjNiPZhILoAVmXEwyJ3We8CVTr8BZQBUVwbV5U+1bXMn9JHlL9YpVF1YSq
6MSUFiJJ5fqaZHi3NIktf/yjwYtPlmhJ9Sydne6k3u+/lpKt/rc=
=bz5h
-----END PGP SIGNATURE-----

Efraim Flashner wrote 2 years ago
(name . Andrew Tropin)(address . andrew@trop.in)(address . 63786-done@debbugs.gnu.org)
ZIoSH795GQcn9Llb@3900XT
On Mon, Jun 12, 2023 at 08:58:18AM +0400, Andrew Tropin wrote:
Toggle quote (22 lines)
>
> A few years ago, when we were implementing the first version of ssh home
> service in rde we went a slightly different way and didn't hardcode any
> record fields and let user set an alist of key/value pairs:
> https://git.sr.ht/~abcdw/rde/tree/19c2d2f0996624eea8b7a87b14bbc31e4a9b943b/src/gnu/home-services/ssh.scm#L204
>
> It's not a perfect solution either, but quite flexible. Also, it's
> relatively easy to implement default values: we can provide
> %default-host-options and ask people to do something like this on user
> side configuration:
>
> (merge %default-host-options '((compression . #f)))
>
> Of course "asking people" won't work, so it's possible to set a default
> value of options field to %default-host-options
> https://git.sr.ht/~abcdw/rde/tree/19c2d2f0996624eea8b7a87b14bbc31e4a9b943b/src/gnu/home-services/ssh.scm#L100
> and let people override it with '((compression . #f)) or enrich with
> (merge %default-host-options '((compression . #f))).
>
> It's not a proposal or something, just sharing how it's implemented in
> rde.

I'm still undecided about the alist as a comparison. It would make it
easier to add arbitrary fields, but then I feel like maybe we should be
adding something to validate the configurations.

Toggle quote (5 lines)
> P.S. Note that (gnu home-services *) modules are subject to deprecation
> and when (rde home services ssh) appear, it will have a slightly
> different interface.


I went ahead and pushed the patch. I believe that, after having added to
a .ssh/config file over a period of time, line by line or entry by
entry, people will be surprised to see a bunch of fields filled in
automatically, and with different results from what they had before.


--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmSKEh8ACgkQQarn3Mo9
g1Ff4w//UZ9gZTeQxswem6oCK7bch5wu+14xAqxEZF4FJAEW4Je1GNKzArejtoxF
794Muah3ml58tEoixuV9IiF490VIYAdHqaCtLfCHUgv24DnjIVYk0oGbQ4A9+kBj
ukMIVJH0R+5dEq7e/shx/po54vsa2rx/7a51MZ8O91+gFZ8DqNlM8uGiU39iLPtj
HfJkxkx8A1z+yTJFyDYEX7AoTqa47ugTNzfQromq63CFR8iqLqU5WDiD3QmXKLyO
HgG/CEbTMbrVF/bnS7fP+QF/mDaTwYjQfXabFbEHhMTGOidS2NdWuYo6fHQWIEI+
FJItfPiMlajjOwo4miuK4wOpHcoCQEgpv8hw1rbvtQfzxf/wTu6qbnNHnfMXmqEA
/NTnDUYivD+l7iSe4BoDwzOl5WJfN3HWt5ULcFl0iYFfCnAoZS9L7S4rjf8NsDRg
On5ncn6BF+EJ/X9xyB8THmHqxNBc5TEhsyotn/VnL3tsk3QM5qUaYbprpfnRdjy3
Fa5I4bB7NTDsxgsJIcFTC0QqbkFWRZEF7R1WRJmyt+drFJpZUZCNWGR1DABNcVaS
CpNpLaFxM1j9TwGCkmBvK1dybUluvaF+WfE4O5v5xMWJoinS+BkXNca70uUzVR9j
5d10lhpAvn7DTZumSJXdXVZfp2ht061Sd7IlRbrqZpzM3oNmY/Q=
=Rsg/
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63786@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63786
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help