[PATCH 0/3] zita-alsa-pcmi: remove -march=native, fix cross-build, and use new style.

  • Done
  • quality assurance status badge
Details
2 participants
  • Z572
  • Ludovic Courtès
Owner
unassigned
Submitted by
Z572
Severity
normal

Debbugs page

Z572 wrote 2 years ago
(address . guix-patches@gnu.org)
tencent_A82BB376FE347528CA834AB26A91374F5209@qq.com
Zheng Junjie (3):
gnu: zita-alsa-pcmi: Do not build with "-march=native".
gnu: zita-alsa-pcmi: fix cross-build.
gnu: zita-alsa-pcmi: Use new style for arguments.

gnu/packages/audio.scm | 57 ++++++++++++++++++++++--------------------
1 file changed, 30 insertions(+), 27 deletions(-)


base-commit: 3299b40b3599371890816b52d65a6a5ada1b1131
--
2.40.1
Z572 wrote 2 years ago
[PATCH 2/3] gnu: zita-alsa-pcmi: fix cross-build.
(address . 63751@debbugs.gnu.org)
tencent_4E6BF95C0975ADD7265DAA7856D45F828E06@qq.com
* gnu/packages/audio.scm (zita-alsa-pcmi): fix cross-build.
[arguments]: use CXX-FOR-TARGET.
---
gnu/packages/audio.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6a24c5b9c6..a3873e7631 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4460,7 +4460,8 @@ (define-public zita-alsa-pcmi
`(#:tests? #f ; no "check" target
#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "SUFFIX="))
+ (string-append "SUFFIX=")
+ (string-append "CXX=" ,(cxx-for-target)))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-makefile-and-enter-directory
--
2.40.1
Z572 wrote 2 years ago
[PATCH 1/3] gnu: zita-alsa-pcmi: Do not build with "-march=native".
(address . 63751@debbugs.gnu.org)
tencent_194AFEF274EACAE14B786A4337595221B309@qq.com
* gnu/packages/audio.scm (zita-alsa-pcmi): Do not build with "-march=native".
[arguments]<#:phases>: remove '-march=native' form source/Makefile.
[properties]: New field.
---
gnu/packages/audio.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 58a981b2fe..6a24c5b9c6 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4466,7 +4467,8 @@ (define-public zita-alsa-pcmi
(lambda _
(substitute* "source/Makefile"
(("ldconfig") "true")
- (("^LIBDIR =.*") "LIBDIR = lib\n"))
+ (("^LIBDIR =.*") "LIBDIR = lib\n")
+ (("CXXFLAGS \\+= -march=native") ""))
(chdir "source")
#t))
(add-after 'install 'install-symlink
@@ -4479,6 +4481,7 @@ (define-public zita-alsa-pcmi
(delete 'configure))))
(inputs
(list alsa-lib fftw))
+ (properties `((tunable? . #t)))
(home-page "https://kokkinizita.linuxaudio.org")
(synopsis "C++ wrapper around the ALSA API")
(description
--
2.40.1
Z572 wrote 2 years ago
[PATCH 3/3] gnu: zita-alsa-pcmi: Use new style for arguments.
(address . 63751@debbugs.gnu.org)
tencent_96A69265A5FD25EB80940B943CD45A6F7A0A@qq.com
* gnu/packages/audio.scm(zita-alsa-pcmi)[arguments]: Use
G-Expressions. Delete trailing #ts.
---
gnu/packages/audio.scm | 57 +++++++++++++++++++++---------------------
1 file changed, 28 insertions(+), 29 deletions(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a3873e7631..97a4061324 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4448,40 +4448,39 @@ (define-public zita-alsa-pcmi
(version "0.3.2")
(source (origin
(method url-fetch)
- (uri (string-append
- "http://kokkinizita.linuxaudio.org"
- "/linuxaudio/downloads/zita-alsa-pcmi-"
- version ".tar.bz2"))
+ (uri (string-append "http://kokkinizita.linuxaudio.org"
+ "/linuxaudio/downloads/zita-alsa-pcmi-"
+ version ".tar.bz2"))
(sha256
(base32
"12d7vdg74yh21w69qi0wg57iz4876j94qbiq09bvscih6xz9y78s"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no "check" target
- #:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "SUFFIX=")
- (string-append "CXX=" ,(cxx-for-target)))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-makefile-and-enter-directory
- (lambda _
- (substitute* "source/Makefile"
- (("ldconfig") "true")
- (("^LIBDIR =.*") "LIBDIR = lib\n")
- (("CXXFLAGS \\+= -march=native") ""))
- (chdir "source")
- #t))
- (add-after 'install 'install-symlink
- (lambda _
- (symlink "libzita-alsa-pcmi.so"
- (string-append (assoc-ref %outputs "out")
- "/lib/libzita-alsa-pcmi.so.0"))
- #t))
- ;; no configure script
- (delete 'configure))))
- (inputs
- (list alsa-lib fftw))
+ (list #:tests? #f ;no "check" target
+ #:make-flags #~(list (string-append "PREFIX="
+ (assoc-ref %outputs "out"))
+ (string-append "SUFFIX=")
+ (string-append "CXX="
+ #$(cxx-for-target)))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-makefile-and-enter-directory
+ (lambda _
+ (substitute* "source/Makefile"
+ (("ldconfig")
+ "true")
+ (("^LIBDIR =.*")
+ "LIBDIR = lib\n")
+ (("CXXFLAGS \\+= -march=native")
+ ""))
+ (chdir "source")))
+ (add-after 'install 'install-symlink
+ (lambda _
+ (symlink "libzita-alsa-pcmi.so"
+ (string-append (assoc-ref %outputs "out")
+ "/lib/libzita-alsa-pcmi.so.0"))))
+ ;; no configure script
+ (delete 'configure))))
+ (inputs (list alsa-lib fftw))
(properties `((tunable? . #t)))
(home-page "https://kokkinizita.linuxaudio.org")
(synopsis "C++ wrapper around the ALSA API")
--
2.40.1
Ludovic Courtès wrote 2 years ago
Re: bug#63751: [PATCH 0/3] zita-alsa-pcmi: remove -march=native, fix cross-build, and use new style.
(name . Z572)(address . 873216071@qq.com)(address . 63751-done@debbugs.gnu.org)
87o7kvzoo9.fsf@gnu.org
Hi,

Z572 <873216071@qq.com> skribis:

Toggle quote (4 lines)
> gnu: zita-alsa-pcmi: Do not build with "-march=native".
> gnu: zita-alsa-pcmi: fix cross-build.
> gnu: zita-alsa-pcmi: Use new style for arguments.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63751@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63751
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help