[PATCH] gnu: Update mgba to 0.10.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • altadil
  • Nicolas Goaziou
Owner
unassigned
Submitted by
altadil
Severity
normal
A
A
altadil wrote on 26 May 2023 19:17
(address . guix-patches@gnu.org)(name . altadil)(address . altadil@protonmail.com)
4f598b6692d3801ef8dd5f41da525d3ea05873ea.1685121406.git.altadil@protonmail.com
* gnu/packages/emulators.scm (mgba): Update to 0.10.2.
---
gnu/packages/emulators.scm | 75 ++++++++++++++++++--------------------
1 file changed, 36 insertions(+), 39 deletions(-)

Toggle diff (92 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 13b6022308..44c8626f2b 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -725,47 +725,44 @@ (define-public mednafen
(define-public mgba
(package
(name "mgba")
- (version "0.10.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mgba-emu/mgba")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0pqfjsr9q61a3mgmvqxxkalxb838k46q9ilz31frpcvvndif0sm1"))
- (modules '((guix build utils)))
- (snippet
- ;; Make sure we don't use the bundled software.
- '(begin
- (for-each
- (lambda (subdir)
- (let ((lib-subdir (string-append "src/third-party/" subdir)))
- (delete-file-recursively lib-subdir)))
- '("libpng" "lzma" "sqlite3" "zlib"))))))
+ (version "0.10.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mgba-emu/mgba")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wwpjcblp2c1svab4z1if5xb7707wsy6zw590lwdz9za35i0h37q"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Make sure we don't use the bundled software.
+ '(begin
+ (for-each (lambda (subdir)
+ (let ((lib-subdir (string-append
+ "src/third-party/" subdir)))
+ (delete-file-recursively lib-subdir)))
+ '("libpng" "lzma" "sqlite3" "zlib"))))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ;no "test" target
- #:configure-flags
- (list "-DUSE_LZMA=OFF" ;do not use bundled LZMA
- "-DUSE_LIBZIP=OFF"))) ;use "zlib" instead
- (native-inputs
- (list pkg-config qttools-5))
- (inputs
- (list ffmpeg
- libedit
- libelf
- libepoxy
- libpng
- mesa
- minizip
- ncurses
- qtbase-5
- qtmultimedia-5
- sdl2
- sqlite
- zlib))
+ `(#:tests? #f ;no "test" target
+ #:configure-flags (list "-DUSE_LZMA=OFF" ;do not use bundled LZMA
+ "-DUSE_LIBZIP=OFF"))) ;use "zlib" instead
+ (native-inputs (list pkg-config qttools-5))
+ (inputs (list ffmpeg
+ libedit
+ libelf
+ libepoxy
+ libpng
+ mesa
+ minizip
+ ncurses
+ qtbase-5
+ qtmultimedia-5
+ sdl2
+ sqlite
+ zlib))
(home-page "https://mgba.io")
(synopsis "Game Boy Advance emulator")
(description

base-commit: b96b82bcd4bc24529941ff74a91432481f1a71b5
--
2.40.1
N
N
Nicolas Goaziou wrote on 10 Jun 2023 21:14
(name . altadil via Guix-patches via)(address . guix-patches@gnu.org)
87v8fvb059.fsf@nicolasgoaziou.fr
Hello,

altadil via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emulators.scm (mgba): Update to 0.10.2.

I tweaked the commit message and applied your patch. Thank you.

Note that you don't need to change the whole indentation when updating
a package.

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63741@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63741
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch