[PATCH] gnu: cryptsetup: Update to 2.6.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal

Debbugs page

phodina wrote 2 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
9YPad3QREMEQfokRWfvOsjtpP5rFdlFr4HJ3evy8BkwdLwVoEu-lEwePSZi4E25yknJ6YhOJlg3y2e8x4oQWSeuZoc54OMctUWk2Z4OCIa8=@protonmail.com
Hello,

this updates the userspace tools for device mapper to the latest release.

----
Petr
Attachment: file
From 1f1e9343755a12f5902141f683ab3703d4b62a37 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Fri, 26 May 2023 14:53:12 +0200
Subject: [PATCH] gnu: cryptsetup: Update to 2.6.1.

* gnu/packages/cryptsetup.scm (cryptsetup): Update to 2.6.1.
[native-inputs]: Add ruby-asciidoctor.
[inputs]: Add libssh.

Toggle diff (50 lines)
diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index d8a6437259..9b2a9cd288 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -26,16 +26,18 @@ (define-module (gnu packages cryptsetup)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages password-utils)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
- #:use-module (gnu packages linux)
+ #:use-module (gnu packages ruby)
+ #:use-module (gnu packages ssh)
#:use-module (gnu packages web))
(define-public cryptsetup
(package
(name "cryptsetup")
- (version "2.3.7")
+ (version "2.6.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/cryptsetup/v"
@@ -43,7 +45,7 @@ (define-public cryptsetup
"/cryptsetup-" version ".tar.xz"))
(sha256
(base32
- "1a97rvi6arsj8dikh1qsvixx9rizm89k155q2ypifqlqllr530v1"))))
+ "14s6vbb9llpgnhmv0badxxzhi73jp4vyvp8swk4bjah7l5jys3a1"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -55,11 +57,12 @@ (define-public cryptsetup
;; GRUB 2.06 supports LUKS2, but does it reliably support all set-ups…?
"--with-default-luks-format=LUKS1")))
(native-inputs
- (list pkg-config))
+ (list pkg-config ruby-asciidoctor))
(inputs
(list argon2
json-c
libgcrypt
+ libssh
lvm2 ; device-mapper
popt
`(,util-linux "lib"))) ;libuuid
--
2.39.1
Nicolas Goaziou wrote 2 weeks ago
(address . 63737-done@debbugs.gnu.org)
87zfidt1id.fsf@nicolasgoaziou.fr
Hello,

Toggle quote (3 lines)
> this updates the userspace tools for device mapper to the latest
> release.

This patch was apparently applied. Closing.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 63737@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63737
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help