[PATCH 0/2] MPD update & fixes

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 25 May 2023 19:20
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cover.1685034837.git.mirai@makinata.eu
This patch series updates MPD to the latest available version (0.23.13)
whilst also:

* Properly enabling tests (these weren't being built and the build
system was a giving misleading answer for 'check phase)
* Removing unused inputs (cmake)
* Splitting the HTML manual from the main package since it accounts
for nearly half of its size.

Additionally tested with `make check-system TESTS=mpd`.


Bruno Victal (2):
gnu: mpd: Update to 0.23.13.
gnu: mpd: Split outputs.

gnu/packages/mpd.scm | 26 +++++++++++++++++++++-----
1 file changed, 21 insertions(+), 5 deletions(-)


base-commit: 0c662d570eec2fe8879e49bd4ccc31950aeb9ef8
--
2.39.2
B
B
Bruno Victal wrote on 25 May 2023 19:21
[PATCH 1/2] gnu: mpd: Update to 0.23.13.
(address . 63721@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
c595f32f3c5c2655c65c479e4f5192effc526398.1685035302.git.mirai@makinata.eu
Properly enable tests as well since meson misleadingly reported a success when
clearly no tests were performed:
````````````````````````````````````
starting phase `check'
ninja: no work to do.
No tests defined.
phase `check' succeeded after 0.2 seconds
starting phase `install'
````````````````````````````````````

* gnu/packages/mpd.scm (mpd): Update to 0.23.13.
[arguments]: Set #:configure-flags option to build tests.
[native-inputs]: Add googletest, zip. Remove unused cmake.
---
gnu/packages/mpd.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 5005da4e87..3259217989 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -118,7 +118,7 @@ (define-public libmpdclient
(define-public mpd
(package
(name "mpd")
- (version "0.23.12")
+ (version "0.23.13")
(source (origin
(method url-fetch)
(uri
@@ -127,12 +127,13 @@ (define-public mpd
"/mpd-" version ".tar.xz"))
(sha256
(base32
- "1rq2hyfvwwri3sivab747csza2i096y7m8563rl5mhpchhiadz5p"))))
+ "06fmy68lfrsi5y03l53dnwcynqhwh5f5vhdpbsr8lzmvzgk02sx9"))))
(build-system meson-build-system)
(arguments
(list
#:configure-flags #~(list "-Ddocumentation=enabled"
- "-Dsystemd=enabled")
+ "-Dsystemd=enabled"
+ "-Dtest=true")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'enable-elogind
@@ -182,7 +183,12 @@ (define-public mpd
yajl
zlib
zziplib)))
- (native-inputs (list cmake pkg-config python-sphinx))
+ (native-inputs (list pkg-config python-sphinx googletest
+ ;; See test/meson.build for information about these
+ ;; additional dependencies.
+ ;;
+ ;; Used when zziplib feature is enabled.
+ zip))
;; Missing optional inputs:
;; libcdio_paranoia
;; libmms

base-commit: 0c662d570eec2fe8879e49bd4ccc31950aeb9ef8
--
2.39.2
B
B
Bruno Victal wrote on 25 May 2023 19:21
[PATCH 2/2] gnu: mpd: Split outputs.
(address . 63721@debbugs.gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
cc7fe25fd94f6a77c2a7e41ae353a15968208e0e.1685035302.git.mirai@makinata.eu
The HTML manual accounts for more than 40% of the package size.

* gnu/packages/mpd.scm (mpd)[outputs]: Add 'html' output.
[arguments]: Add split-package phase.
---
gnu/packages/mpd.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 3259217989..fa16e60484 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -146,7 +146,16 @@ (define-public mpd
(("systemd_dep = declare_dependency" all)
(string-append "_" all)))
(substitute* "meson.build"
- (("systemd_dep,") "systemd_dep, _systemd_dep,")))))))
+ (("systemd_dep,") "systemd_dep, _systemd_dep,"))))
+ (add-after 'install 'split-package
+ (lambda _
+ ;; The HTML manual accounts for over 40% of the disk
+ ;; space used by the package.
+ (let* ((path "/share/doc/mpd/html")
+ (htmldir (string-append #$output path))
+ (htmldir* (string-append #$output:html path)))
+ (mkdir-p (dirname htmldir*))
+ (rename-file htmldir htmldir*)))))))
(inputs (append
(if (target-linux?) (list liburing) '())
(list ao
@@ -189,6 +198,7 @@ (define-public mpd
;;
;; Used when zziplib feature is enabled.
zip))
+ (outputs (list "out" "html"))
;; Missing optional inputs:
;; libcdio_paranoia
;; libmms
--
2.39.2
L
L
Liliana Marie Prikler wrote on 25 May 2023 21:47
1228109b770eefba4f0b741dee4ba413ab8c18c7.camel@gmail.com
Am Donnerstag, dem 25.05.2023 um 18:21 +0100 schrieb Bruno Victal:
Toggle quote (4 lines)
> The HTML manual accounts for more than 40% of the package size.
>
> * gnu/packages/mpd.scm (mpd)[outputs]: Add 'html' output.
> [arguments]: Add split-package phase.
Prefer “doc” as a separate output, as the logic for that is mostly
there already. Or use “doc” and “doc-html” if you really must.

Cheers
B
B
Bruno Victal wrote on 26 May 2023 09:06
[PATCH v2 1/2] gnu: mpd: Update to 0.23.13.
(address . 63721@debbugs.gnu.org)
36e30b607de74f1187d80ecc61adb54add2ab7b8.1685084781.git.mirai@makinata.eu
Properly enable tests as well since meson misleadingly reported a success when
clearly no tests were performed:
````````````````````````````````````
starting phase `check'
ninja: no work to do.
No tests defined.
phase `check' succeeded after 0.2 seconds
starting phase `install'
````````````````````````````````````

CMake was also removed from native inputs since it's only relevant when
building for Android or Windows.

* gnu/packages/mpd.scm (mpd): Update to 0.23.13.
[arguments]: Set #:configure-flags option to build tests.
[native-inputs]: Add googletest, zip. Remove cmake.
---
gnu/packages/mpd.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 5005da4e87..3259217989 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -118,7 +118,7 @@ (define-public libmpdclient
(define-public mpd
(package
(name "mpd")
- (version "0.23.12")
+ (version "0.23.13")
(source (origin
(method url-fetch)
(uri
@@ -127,12 +127,13 @@ (define-public mpd
"/mpd-" version ".tar.xz"))
(sha256
(base32
- "1rq2hyfvwwri3sivab747csza2i096y7m8563rl5mhpchhiadz5p"))))
+ "06fmy68lfrsi5y03l53dnwcynqhwh5f5vhdpbsr8lzmvzgk02sx9"))))
(build-system meson-build-system)
(arguments
(list
#:configure-flags #~(list "-Ddocumentation=enabled"
- "-Dsystemd=enabled")
+ "-Dsystemd=enabled"
+ "-Dtest=true")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'enable-elogind
@@ -182,7 +183,12 @@ (define-public mpd
yajl
zlib
zziplib)))
- (native-inputs (list cmake pkg-config python-sphinx))
+ (native-inputs (list pkg-config python-sphinx googletest
+ ;; See test/meson.build for information about these
+ ;; additional dependencies.
+ ;;
+ ;; Used when zziplib feature is enabled.
+ zip))
;; Missing optional inputs:
;; libcdio_paranoia
;; libmms

base-commit: 3299b40b3599371890816b52d65a6a5ada1b1131
--
2.39.2
B
B
Bruno Victal wrote on 26 May 2023 09:06
[PATCH v2 2/2] gnu: mpd: Split outputs.
(address . 63721@debbugs.gnu.org)
f00fb00bc933d03103927c449744b0099666c951.1685084781.git.mirai@makinata.eu
The HTML manual accounts for more than 40% of the package size.

* gnu/packages/mpd.scm (mpd)[outputs]: Add 'doc' output.
[arguments]: Add split-package phase.
---
gnu/packages/mpd.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 3259217989..d4654d4842 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -146,7 +146,16 @@ (define-public mpd
(("systemd_dep = declare_dependency" all)
(string-append "_" all)))
(substitute* "meson.build"
- (("systemd_dep,") "systemd_dep, _systemd_dep,")))))))
+ (("systemd_dep,") "systemd_dep, _systemd_dep,"))))
+ (add-after 'install 'split-package
+ (lambda _
+ ;; The HTML manual accounts for over 40% of the disk
+ ;; space used by the package.
+ (let* ((path "/share/doc/mpd/html")
+ (htmldir (string-append #$output path))
+ (htmldir* (string-append #$output:doc path)))
+ (mkdir-p (dirname htmldir*))
+ (rename-file htmldir htmldir*)))))))
(inputs (append
(if (target-linux?) (list liburing) '())
(list ao
@@ -189,6 +198,7 @@ (define-public mpd
;;
;; Used when zziplib feature is enabled.
zip))
+ (outputs (list "out" "doc"))
;; Missing optional inputs:
;; libcdio_paranoia
;; libmms
--
2.39.2
L
L
Liliana Marie Prikler wrote on 4 Jun 2023 08:28
Re: [bug#63809] [PATCH] gnu: MPD: Update to 0.23.13.
9a20388bd75b4f8af9f4c0a1f635ac0718c4b920.camel@gmail.com
Am Donnerstag, dem 01.06.2023 um 20:20 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (7 lines)
> Am Mittwoch, dem 31.05.2023 um 08:23 +0100 schrieb Bruno Victal:
> > Hi lfam,
> >
> > This is already included in #63721.
> That's fine, because your patch does two things in one.  I will
> rebase your changes on top of Leo's and presumably push them on
> Sunday.
Hi folks, it's Sunday :)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63721@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63721
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch