[PATCH] website: List languages in two columns.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pelzflorian (Florian Pelz)
Owner
unassigned
Submitted by
pelzflorian (Florian Pelz)
Severity
normal

Debbugs page

pelzflorian (Florian Pelz) wrote 2 years ago
(address . guix-patches@gnu.org)
878rdcxvt2.fsf@pelzflorian.de
* website/apps/base/templates/components.scm (navbar): Specify a CSS
class for the languages dropdown list.
* website/static/base/css/navbar.css (languages-dropdown-list): New
rule.
---

The translations dropdown is too long and high. It seems to me
adjusting the number of columns dynamically and limiting the height is
not possible, unless we rewrite dropdowns to use CSS flexbox in <div>
elements instead of lists. Instead, this patch sets a fixed column
number of two, which should be appropriate for the foreseeable future.

Also, there is only one languages dropdown, so this patch could
specify an id and not a new class for the languages dropdown. But a
class works too and works always, so using a class seems better (?).

website/apps/base/templates/components.scm | 3 ++-
website/static/base/css/navbar.css | 3 +++
2 files changed, 5 insertions(+), 1 deletion(-)

Toggle diff (37 lines)
diff --git a/website/apps/base/templates/components.scm b/website/apps/base/templates/components.scm
index 5f4af9c..241c27e 100644
--- a/website/apps/base/templates/components.scm
+++ b/website/apps/base/templates/components.scm
@@ -1,5 +1,5 @@
;;; GNU Guix web site
-;;; Copyright © 2019 Florian Pelz <pelzflorian@pelzflorian.de>
+;;; Copyright © 2019, 2023 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Initially written by sirgazil who waives all
;;; copyright interest on this file.
@@ -501,6 +501,7 @@ manual.
,(menu-dropdown #:label (locale-display-name) #:active-item active-item
#:items
(append
+ (list '(@ (class "languages-dropdown-list")))
(map-in-order
(lambda (ietf-info)
(let ((lingua (car ietf-info))
diff --git a/website/static/base/css/navbar.css b/website/static/base/css/navbar.css
index 974516a..c2dce90 100644
--- a/website/static/base/css/navbar.css
+++ b/website/static/base/css/navbar.css
@@ -117,6 +117,9 @@ label.menu-item {
display: none;
}
+.languages-dropdown-list {
+ columns: 2;
+}

base-commit: c4df5a59a97bce391e1be68dd8b4c1107cce4b23
--
2.39.2
Ludovic Courtès wrote 2 years ago
(name . pelzflorian (Florian Pelz))(address . pelzflorian@pelzflorian.de)(address . 63720@debbugs.gnu.org)
87jzwihy9j.fsf@gnu.org
Hi,

"pelzflorian (Florian Pelz)" <pelzflorian@pelzflorian.de> skribis:

Toggle quote (16 lines)
> * website/apps/base/templates/components.scm (navbar): Specify a CSS
> class for the languages dropdown list.
> * website/static/base/css/navbar.css (languages-dropdown-list): New
> rule.
> ---
>
> The translations dropdown is too long and high. It seems to me
> adjusting the number of columns dynamically and limiting the height is
> not possible, unless we rewrite dropdowns to use CSS flexbox in <div>
> elements instead of lists. Instead, this patch sets a fixed column
> number of two, which should be appropriate for the foreseeable future.
>
> Also, there is only one languages dropdown, so this patch could
> specify an id and not a new class for the languages dropdown. But a
> class works too and works always, so using a class seems better (?).

No opinion on this, but two columns sounds like a good idea to me.

Thanks,
Ludo’.
pelzflorian (Florian Pelz) wrote 2 years ago
(address . 63720-done@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
877cshw1c1.fsf@pelzflorian.de
Pushed as a076562297db72b45ac82f7627a23e4be615d558.

Thank you Ludo for confirming the columns number.

Regards,
Florian
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63720@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63720
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help