[PATCH] gnu: Add emacs-x509

  • Done
  • quality assurance status badge
Details
2 participants
  • David Conner
  • Nicolas Goaziou
Owner
unassigned
Submitted by
David Conner
Severity
normal

Debbugs page

David Conner wrote 2 years ago
(address . guix-patches@gnu.org)(name . David Conner)(address . dconner.pro@gmail.com)
20230525100859.2049132-1-aionfork@gmail.com
From: David Conner <dconner.pro@gmail.com>

* gnu/packages/emacs-xyz.scm (emacs-x509): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0ea9732bfa..e8965c7d90 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37093,6 +37093,32 @@ (define-public emacs-tintin-mode
accomplish different tasks.")
(license license:asl2.0))))
+(define-public emacs-x509-mode
+ (package
+ (name "emacs-x509-mode")
+ (version "20230430.1518")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://melpa.org/packages/x509-mode-"
+ version ".tar"))
+ (sha256
+ (base32 "195gn14qn22aqclwz2i9w2qq9bxabwcasfkna1fj41jwv2bpbykc"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:include (cons* "^keywords.txt"
+ "^keyword\\+constant.txt"
+ "^constants.txt"
+ "^long-name.txt"
+ %default-include)))
+ (home-page "https://github.com/jobbflykt/x509-mode")
+ (synopsis "Major mode for viewing certificates, CRLs, and other
+PKI-related files")
+ (description "Major mode for viewing certificates, CRLs, and other
+PKI-related files. Uses OpenSSL for viewing PEM and DER encoded PKI
+entities.")
+ (license license:expat)))
+
(define-public emacs-totp
(let ((commit "a5e059b8475b32bc7f5ddadda248cf84449ed722") ;no releases
(revision "0"))

base-commit: 0b0c2ef6381e05f87aa5c4a99d05054a0b677662
--
2.40.1
Nicolas Goaziou wrote 2 years ago
(name . David Conner)(address . aionfork@gmail.com)
878rdcf93l.fsf@nicolasgoaziou.fr
Hello,

David Conner <aionfork@gmail.com> writes:

Toggle quote (4 lines)
> From: David Conner <dconner.pro@gmail.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-x509): New variable.

Thank you. Some comments follow.

Toggle quote (5 lines)
> +(define-public emacs-x509-mode
> + (package
> + (name "emacs-x509-mode")
> + (version "20230430.1518")

Guix doesn't use versioning system from MELPA. Unfortunately, this
package doesn't seem to set a Version keyword. So the version should be "0".

Toggle quote (6 lines)
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://melpa.org/packages/x509-mode-"
> + version ".tar"))

Please use GitHub as upstream.

Toggle quote (7 lines)
> + (arguments
> + `(#:include (cons* "^keywords.txt"
> + "^keyword\\+constant.txt"
> + "^constants.txt"
> + "^long-name.txt"
> + %default-include)))

What about something like:

(list #:include (cons "\\.txt$" %default-include))

Toggle quote (4 lines)
> + (description "Major mode for viewing certificates, CRLs, and other
> +PKI-related files. Uses OpenSSL for viewing PEM and DER encoded PKI
> +entities.")

The description should consist of complete sentences.

Could you send an updated patch? Also, could you run tests?

Regards,
--
Nicolas Goaziou
David Conner wrote 2 years ago
[bug#63714] [PATCH] gnu: Add emacs-x509
(address . 63714@debbugs.gnu.org)
87h6rx3kmx.fsf@gmail.com
I'm still getting used to GNUS and debbugs. I've only just gotten GNUS
set up in Emacs with email.

Toggle quote (4 lines)
> Guix doesn't use versioning system from MELPA. Unfortunately, this
> package doesn't seem to set a Version keyword. So the version should
> be "0".

I can try to get in touch with the package maintainers to convince them
to add semantic versioning. I think the package was dormant for quite
some time until I created a Github issue on it. It appears to be active
again.

Toggle quote (2 lines)
> Could you send an updated patch? Also, could you run tests?

Yes, I'll take care of this soon.

As for tests, do you mean Guix tests or x509-mode.el tests? If the
latter, then I believe openssl should be a propagated input. I left it
out, as this should be a dependency on most machines anyways.

Thanks
Nicolas Goaziou wrote 2 years ago
(name . David Conner)(address . aionfork@gmail.com)(address . 63714-done@debbugs.gnu.org)
87fs6grq48.fsf@nicolasgoaziou.fr
Hello,

David Conner <aionfork@gmail.com> writes:

Toggle quote (20 lines)
> I'm still getting used to GNUS and debbugs. I've only just gotten GNUS
> set up in Emacs with email.
>
>> Guix doesn't use versioning system from MELPA. Unfortunately, this
>> package doesn't seem to set a Version keyword. So the version should
>> be "0".
>
> I can try to get in touch with the package maintainers to convince them
> to add semantic versioning. I think the package was dormant for quite
> some time until I created a Github issue on it. It appears to be active
> again.
>
>> Could you send an updated patch? Also, could you run tests?
>
> Yes, I'll take care of this soon.
>
> As for tests, do you mean Guix tests or x509-mode.el tests? If the
> latter, then I believe openssl should be a propagated input. I left it
> out, as this should be a dependency on most machines anyways.

I went ahead, applied suggested changes, added openssl as an input, and
ran tests.

Thank you for the initial work!

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63714@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63714
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help