[PATCH] gnu: Add font-ipa.

  • Done
  • quality assurance status badge
Details
3 participants
  • Nicolas Goaziou
  • Wolf
  • Tomas Volf
Owner
unassigned
Submitted by
Wolf
Severity
normal
W
(address . guix-patches@gnu.org)(name . Wolf)(address . wolf@wolfsden.cz)
cac4f8d139c62bae4464276a9a5e2bc71ea89fc8.1684963373.git.wolf@wolfsden.cz
* gnu/packages/fonts.scm (font-ipa): New variable.
---
gnu/packages/fonts.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 12c6b04bd7..b159eb7ab0 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2515,6 +2515,52 @@ (define-public font-meera-inimai
characteristic so that they sit smoothly with the Tamil glyphs.")
(license license:silofl1.1)))
+(define-public font-ipa
+ (package
+ (name "font-ipa")
+ (version "003.03")
+ (source (origin
+ (method url-fetch/zipbomb)
+ (uri (string-append
+ "https://moji.or.jp/wp-content/ipafont/IPAfont/" "IPAfont"
+ (string-join (string-split version #\.) "") ".zip"))
+ (sha256
+ (base32
+ "1rbgfq14ld0cwas6bx5h7pwyv2hkfa8ihnphsaz1brxqliwysmgp"))))
+ (build-system font-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'make-read-only
+ (lambda _
+ ;; Otherwise the files have the executable bit set.
+ (for-each (lambda (file)
+ (chmod file #o444))
+ (find-files "."
+ #:directories? #f))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((font+version #$(string-append "IPAfont"
+ (string-join (string-split
+ version
+ #\.)
+ "")))
+ (doc-dir (string-append #$output
+ "/share/doc/"
+ #$name)))
+ (with-directory-excursion font+version
+ (mkdir-p doc-dir)
+ (copy-file (string-append "Readme_"
+ font+version ".txt")
+ (string-append doc-dir "/README"))
+ (copy-file
+ "IPA_Font_License_Agreement_v1.0.txt"
+ (string-append doc-dir "/LICENSE")))))))))
+ (home-page "https://moji.or.jp/ipafont/")
+ (synopsis "Japanese font from the Information-technology Promotion Agency")
+ (description "Japanese outline fonts by Information-technology Promotion
+Agency, Japan (IPA)")
+ (license license:ipa)))
+
(define-public font-ipa-ex
(package
(name "font-ipa-ex")

base-commit: 6d0571215d661d21cac2150ca45906e77a79a5fb
--
2.40.1
W
Ping
(address . 63707@debbugs.gnu.org)
ZJMm_L2QwkjccqXQ@ws
Hi,

anything I can do to help this getting merged?

W.

--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEt4NJs4wUfTYpiGikL7/ufbZ/wakFAmSTJvwACgkQL7/ufbZ/
wal5fBAAtp/6L5alFoZtcLK5F8vdOxa3Auas2BHVwF+ggN4qQo1zPhPNv7xGnlFf
Dly7acQDdBzvH5cx0ZPrEbf1htXMZcZ0egAYQ5FpLgiu8S+5ifV3+G2Ayc3qDE0G
J4wCW0a11FSNBYR9IYi2f5fEdRZVir6z6EvV+yes3TIJJjv1G9FopsLWFbWnNDkf
OvfWV7E8MU6remkhuTDCABT7HD5RyJN1kS5PN0M0aclTGa1XNPcAaI56sZwtRwFI
Jq2ijFbaATqozb64H8wYhlXr+Tb/Do8NiykXmAoGV0YUmBzfXe8Xo6OjAERfrwnB
QwRdUYqZBgBdD7DjKdj5jqOezZqC/rCxDOTDWB0ButXujFVwMDm6vw0Ae3DbHg1I
tiVHx/99DHCpwhq3U/udVPayYVPDzvNl9jqFuNchTBDio3Fn9FNe5iVPGI9IWbhi
jdY4aicJ/JFZykIqHr6FNTaP3op8kv6OjFSRiiIzCqSvsot0F280sBSy3wnYn0en
xScZudc4Y2q3FJ0SgFISb8mZ4YaioMCgEG2fj8CPqfzRDarKUpZBedFprGfT+r/s
rpnLU0etoGPf35LUDsgYwNFYneoA3lb7mjkQLCjuI0DEda2+ikseZJUMpXTW3f1E
uq3K76OrhnAe+h9lkvC1n7fklGB9u6g+BiPIGBbLy1wr4cJnddo=
=NrKX
-----END PGP SIGNATURE-----


N
N
Nicolas Goaziou wrote on 1 Jul 2023 12:23
Re: [bug#63707] [PATCH] gnu: Add font-ipa.
(name . Wolf)(address . wolf@wolfsden.cz)
87jzvkj5g9.fsf@nicolasgoaziou.fr
Hello,

Wolf <wolf@wolfsden.cz> writes:

Toggle quote (2 lines)
> * gnu/packages/fonts.scm (font-ipa): New variable.

Applied with the changes below. Thank you.
Toggle quote (6 lines)
> ---
> + (build-system font-build-system)
> + (arguments
> + (list #:phases #~(modify-phases %standard-phases
> + (add-after 'unpack 'make-read-only

I fixed indentation, which consumes way too much horizontal space here.

Toggle quote (3 lines)
> + (add-after 'install 'install-doc
> + (lambda* (#:key outputs #:allow-other-keys)

outputs argument is not necessary when using G-expressions. You don't
use it either in your phases.

Toggle quote (3 lines)
> + (description "Japanese outline fonts by Information-technology Promotion
> +Agency, Japan (IPA)")

The description should consist of full sentences:

"These package provides Japanese outline fonts..."

Regards,
--
Nicolas Goaziou
Closed
W
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
ZKG9qG9IKomrnaVg@ws
On 2023-07-01 12:23:34 +0200, Nicolas Goaziou wrote:
Toggle quote (8 lines)
> Hello,
>
> Wolf <wolf@wolfsden.cz> writes:
>
> > * gnu/packages/fonts.scm (font-ipa): New variable.
>
> Applied with the changes below. Thank you.

Thank you for merging it.

Toggle quote (14 lines)
> > ---
> > + (build-system font-build-system)
> > + (arguments
> > + (list #:phases #~(modify-phases %standard-phases
> > + (add-after 'unpack 'make-read-only
>
> I fixed indentation, which consumes way too much horizontal space here.
>
> > + (add-after 'install 'install-doc
> > + (lambda* (#:key outputs #:allow-other-keys)
>
> outputs argument is not necessary when using G-expressions. You don't
> use it either in your phases.

I admit I just copied over the package for font-ipa-ex and adjusted it, not
realizing that this part is not necessary.

Toggle quote (8 lines)
>
> > + (description "Japanese outline fonts by Information-technology Promotion
> > +Agency, Japan (IPA)")
>
> The description should consist of full sentences:
>
> "These package provides Japanese outline fonts..."

Will keep that in mind.

Toggle quote (5 lines)
>
> Regards,
> --
> Nicolas Goaziou

Have a nice day,
W.

--
There are only two hard things in Computer Science:
cache invalidation, naming things and off-by-one errors.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEt4NJs4wUfTYpiGikL7/ufbZ/wakFAmShvagACgkQL7/ufbZ/
walhlRAAjBi6l5HCzgyqIymbp7ge2byVo7ZEPd8bSyv5D/X4mXO5GfFeBdGl5k/S
dCsQDE/lx7IkvUb5jOpj2NwCxMoOIX0BCt2bSGyJb7fbno1cXrgKD/FkK1kxvsk5
m6V6wutO1BVt3OJOQKRXdaAfpLeNG7SoYdUZAdDFey1ow9hvENrLX0YiIYlM/499
hzIf+bUILm0B1K8YLIvNvr6gzJIrUPY0p4yEJ0enQtlMH8o6G+PWCaSXcPm5WSsv
+j6OeiZNhrYOKV8KhoaRrwZ5wC7kNOSlPgJMP67T74pxUz+Umvmd1hE4Lk+X6eTl
GxLj6imh1XShKYEy3LhFGCBqcI0Wm959elEoDpuIXzK8s0G0Huuzj+NESgGzU+Cs
ln+Mc/mQIb51Uas3oDnQjhTJpZZpVWZQGcte6hHzMqD4t8NbiRIhpud4dPi7GZti
19wMjjjzGWc8KsUgJz/UOLiKCKw4GcJF3rzUt+MbX6efBihomX8AhgG1nyzoJxgm
BQS+QfeQR68ZbRVkVsuuTfEt2Je0J/FGA3hq23erbBZXC8y3lFUIIAgTM/8oyn2t
kX66HUOUsn9ch9qK73M69BuPGyj93kO6y9SnK1L4UblRbqTCz6Lkg9dTQb7hb+kR
tINhte6QI6uD4xTCxHBZKUfBxYlwn5HJX86iCmjA2s9gpQnIpnA=
=Mkbn
-----END PGP SIGNATURE-----


Closed
T
T
Tomas Volf wrote on 16 Feb 16:08 +0100
control message for bug #63707
(address . control@debbugs.gnu.org)
87h6i8zbt2.fsf@wolfsden.cz
submitter 63707 ~@wolfsden.cz
quit
T
T
Tomas Volf wrote on 16 Feb 17:09 +0100
(address . control@debbugs.gnu.org)
b27f31cf1e07c9db6727b97c5f831f8b@wolfsden.cz
unarchive 63707
quit
T
T
Tomas Volf wrote on 16 Feb 17:11 +0100
control message for bug #0
(address . control@debbugs.gnu.org)
87frxsz8w0.fsf@wolfsden.cz
submitter 63707 !
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63707@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63707
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch