[PATCH] gnu: Add bdf2sfd.

  • Done
  • quality assurance status badge
Details
2 participants
  • gemmaro
  • Ludovic Courtès
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote on 24 May 2023 17:43
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
1871f71718bb28933a661fc6e02ade8ed880283d.1684942960.git.gemmaro.dev@gmail.com
* gnu/packages/fontutils.scm (bdf2sfd): New variable.
---
gnu/packages/fontutils.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index ffaaa5cacab..1b4e0064f42 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1934,3 +1935,29 @@ (define-public lcdf-typetools
These tools are cfftot1, mmafm, mmpfb, otfinfo, otftotfm, t1dotlessj, t1lint,
t1rawfm, t1reencode, t1testpage and ttftotype42.")
(license license:gpl2+)))
+
+(define-public bdf2sfd
+ (package
+ (name "bdf2sfd")
+ (version "1.1.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fcambus/bdf2sfd")
+ (commit "1.1.8")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pa92gjiijp9xqnw9dcvz24s6qk11a4lp5q6s5psd6mpkhpd88zq"))))
+ (build-system cmake-build-system)
+ (home-page "https://github.com/fcambus/bdf2sfd")
+ (synopsis "BDF to SFD converter, allowing to vectorize bitmap fonts")
+ (description
+ "bdf2sfd is a
+@uref{https://en.wikipedia.org/wiki/Glyph_Bitmap_Distribution_Format,
+BDF} to @uref{https://fontforge.org/docs/techref/sfdformat.html, SFD}
+converter, allowing to vectorize bitmap fonts. It works by converting
+each pixel of a glyph to a polygon, which produces large and
+unoptimized SFD files that should be post-processed using
+@uref{https://fontforge.org, FontForge}.")
+ (license license:bsd-2)))

base-commit: 6d0571215d661d21cac2150ca45906e77a79a5fb
--
2.40.1
L
L
Ludovic Courtès wrote on 14 Jun 2023 23:12
(name . gemmaro)(address . gemmaro.dev@gmail.com)(address . 63688-done@debbugs.gnu.org)
87h6r9rbnd.fsf@gnu.org
gemmaro <gemmaro.dev@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/fontutils.scm (bdf2sfd): New variable.

Applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63688@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63688
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch