Manual: Example for multiple SLiM instances doesn't work

  • Open
  • quality assurance status badge
Details
One participant
  • Ivan Vilata i Balaguer
Owner
unassigned
Submitted by
Ivan Vilata i Balaguer
Severity
normal

Debbugs page

Ivan Vilata i Balaguer wrote 2 years ago
(address . bug-guix@gnu.org)
ZGypvogKSMDRmbP0@sax
Hi! Under section "X Window", the Guix Manual provides an example on "how to
replace the default GDM service with two SLiM services on tty7 and tty8":

```
(use-modules (gnu services)
(gnu services desktop)
(gnu services xorg))

(operating-system
;; ...
(services (cons* (service slim-service-type (slim-configuration
(display ":0")
(vt "vt7")))
(service slim-service-type (slim-configuration
(display ":1")
(vt "vt8")))
(modify-services %desktop-services
(delete gdm-service-type)))))
```

Unfortunately, reconfiguring a system (on commit 14c03807) reports the
following error:

guix system: error: service 'xorg-server' provided more than once

Actually, leaving just the first `service` entry still produces the same
error. One needs to also add a second argument to `xorg-configuration`, like
this:

```
(set-xorg-configuration
(xorg-configuration […])
slim-service-type)
```

And then the `service` entry can actually be removed. To summarize, these are
the changes that I needed for actually having *one* operational SLiM instance:

```
(operating-system
(packages (cons*
(specification->package "slim")
%base-packages))

(services (cons*
(set-xorg-configuration
(xorg-configuration […])
slim-service-type)

(modify-services
%desktop-services
(delete gdm-service-type)))))
```

For completeness sake, adding the two `service` entries causes the error:

guix system: error: more than one target service of type 'slim'

as already discussed in https://issues.guix.gnu.org/55391. There's a
possible workaround explained there which implies duplicating the Xorg server
configuration.

But maybe I missed some point in the instructions. Otherwise, I wonder
whether they should be either fixed, or updated for a single-instance example
that does work (which may be ok as that's probably the most common use case).

Thanks, and cheers!

--
Ivan Vilata i Balaguer -- https://elvil.net/
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEHpvwBPZcchIQr6TuPezBBfXdI4IFAmRsqb4ACgkQPezBBfXd
I4IpyRAAnnZwL0oASvD8PLc3s+qt+Cxmc3B1zOGBTL9mHKgANZCWZhXaAVdURCi8
JzH5FnWlxNWUqkWqsxjih4ildppdhXso3sDEHwq7sUvotwiH3MJvZ2rdsbktbSZP
OPPbMTB9mbeYcHVLNOL3Pb9d+1lwfmQ3dcOzKoff+YkDW9XpRSZajdHiw0xHVqPs
G48XVdLqdQj3dI4Pt1xdIqEt7hgliNwj6UmRmXF7oRL4im4aPezLOApyWQ4mWQiB
xO40gc4eX7MUoIjVyUQq2AGT0oPFYHazTjqbMt0VHEQ0FVphAuA87VJeCqA74lNH
k3dkkDmmQ+60X2A7g2SRvxkolrzMGaxeVUVWNuw6CjuxO+mljI7upJYmNgUkAnqA
/aFZkzpwgbcSClh4mpFRNmJ8UiPpIumAQ8cPFo7yHbEqIh1RXMHcxD4pyWdnZoY4
cSZS2z2NA3NxIEy1sE8r2a1iebfJH4brX1z0XasEn301EAsWYcVOl0629lGOgmJX
7/XDNXRp6ANsnz4FGAZau/kWPnC0r/sVkbukjAEeMD4A4mqvjlmPg4mxpzPBbKQZ
wWreREm8EFPO+pbm7T7ND6ot3GBV6HiV3dfds8BKTwVqpgZhYvv3SQH48PqFm+kc
ogR1sm0ZLCOPg3SlSDQ2o3qvniJBR7sqtJGsPbYJLvwqJ81H71M=
=/5Z2
-----END PGP SIGNATURE-----


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 63660@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63660
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help