[PATCH core-updates 0/2] pcre2: update to 10.42.

  • Done
  • quality assurance status badge
Details
2 participants
  • Z572
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Z572
Severity
normal
Z
(address . guix-patches@gnu.org)
tencent_0009506DFDA66E6A4F16D0DFA58E49795306@qq.com
*** BLURB HERE ***

Zheng Junjie (2):
gnu: pcre2: Update to 10.42.
gnu: pcre2: use git source.

gnu/packages/pcre.scm | 21 +++++++++++++--------
1 file changed, 13 insertions(+), 8 deletions(-)


base-commit: 8659f5e3ee1872da0a853ca6f839eb6f90e10c3d
--
2.40.1
Z
[PATCH 1/2] gnu: pcre2: Update to 10.42.
(address . 63636@debbugs.gnu.org)
tencent_C7EA6056D19F850E6B396B094B6DCDE67906@qq.com
* gnu/packages/pcre.scm (pcre2): Update to 10.42.
[arguments]: <#:configure-flags>: enable jit when target to riscv64.
---
gnu/packages/pcre.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 7c53a27685..769738c3d5 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -93,7 +94,7 @@ (define-public pcre
(define-public pcre2
(package
(name "pcre2")
- (version "10.40")
+ (version "10.42")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/PCRE2Project/pcre2"
@@ -101,7 +102,7 @@ (define-public pcre2
"/pcre2-" version ".tar.bz2"))
(sha256
(base32
- "0s4x2l6g0sb9piwkr3sxqwdswz2g6bk1hhwngv0kv4w38wybir0l"))))
+ "0h78np8h3dxlmvqvpnj558x67267n08n9zsqncmlqapans6csdld"))))
(build-system gnu-build-system)
(inputs (list bzip2 readline zlib))
(arguments
@@ -113,8 +114,7 @@ (define-public pcre2
"--enable-pcre2-16"
"--enable-pcre2-32"
;; pcre2_jit_test fails on powerpc32.
- ;; riscv64-linux is an unsupported architecture.
- #$@(if (or (target-ppc32?) (target-riscv64?))
+ #$@(if (target-ppc32?)
#~()
#~("--enable-jit"))
"--disable-static")
--
2.40.1
Z
[PATCH 2/2] gnu: pcre2: use git source.
(address . 63636@debbugs.gnu.org)
tencent_308A6B7F3627535DB222FE1C7440CAAF4B09@qq.com
* gnu/packages/pcre.scm[source]: use GIT-FETCH.
[native-inputs]: add AUTOCONF AUTOMAKE LIBTOOL.
---
gnu/packages/pcre.scm | 15 ++++++++++-----
1 file changed, 10 insertions(+), 5 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 769738c3d5..84ca7292b4 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -28,12 +28,14 @@
(define-module (gnu packages pcre)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages readline)
#:use-module (gnu packages)
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix build-system gnu))
@@ -96,14 +98,17 @@ (define-public pcre2
(name "pcre2")
(version "10.42")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/PCRE2Project/pcre2"
- "/releases/download/pcre2-" version
- "/pcre2-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/PCRE2Project/pcre2")
+ (commit (string-append "pcre2-" version))))
+ (file-name
+ (git-file-name name version))
(sha256
(base32
- "0h78np8h3dxlmvqvpnj558x67267n08n9zsqncmlqapans6csdld"))))
+ "1d2kiavdn0wyxv168sz9wd77m3hl46i51fmx4pqya99ydnimpxzb"))))
(build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
(inputs (list bzip2 readline zlib))
(arguments
(list #:configure-flags
--
2.40.1
M
M
Maxim Cournoyer wrote on 22 Jan 05:32 +0100
(name . Z572)(address . 873216071@qq.com)(address . 63636-done@debbugs.gnu.org)
87jzo256ol.fsf@gmail.com
Hi,

Z572 <873216071@qq.com> writes:

Toggle quote (3 lines)
> * gnu/packages/pcre.scm[source]: use GIT-FETCH.
> [native-inputs]: add AUTOCONF AUTOMAKE LIBTOOL.

I've pushed the update in 388bdc495d, but not the switch to git fetch as
this would increase the closure of core packages such as grep.

That would need to be investigated whether it'd cause a bootstrapping
problem.

--
Thanks,
Maxim
Closed
?