[PATCH 0/4] Add MetPy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 21 May 2023 07:35
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20230521053542.1504723-1-monego@posteo.net
Vinicius Monego (4):
gnu: python-sparse: Fix build.
gnu: python-sparse: Update to 0.14.0.
gnu: python-pint: Fix build.
gnu: Add python-metpy.

gnu/packages/geo.scm | 51 +++++++++++++++++++++++++++++++++++++
gnu/packages/python-xyz.scm | 22 +++++++++-------
2 files changed, 64 insertions(+), 9 deletions(-)

--
2.34.1
V
V
Vinicius Monego wrote on 21 May 2023 07:37
[PATCH 1/4] gnu: python-sparse: Fix build.
(address . 63623@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20230521053726.1507055-1-monego@posteo.net
* gnu/packages/python-xyz.scm (python-sparse)[native-inputs]: Add
python-importlib-metadata.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c7a31e40a1..9fbae71a6c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7036,8 +7036,8 @@ (define-public python-sparse
(propagated-inputs
(list python-numba python-numpy python-scipy))
(native-inputs
- (list python-dask python-pytest python-pytest-black
- python-pytest-cov))
+ (list python-dask python-importlib-metadata python-pytest
+ python-pytest-black python-pytest-cov))
(home-page "https://github.com/pydata/sparse/")
(synopsis "Library for multi-dimensional sparse arrays")
(description
--
2.34.1
V
V
Vinicius Monego wrote on 21 May 2023 07:37
[PATCH 2/4] gnu: python-sparse: Update to 0.14.0.
(address . 63623@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20230521053726.1507055-2-monego@posteo.net
* gnu/packages/python-xyz.scm (python-sparse): Update to 0.14.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9fbae71a6c..3788cefda2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7017,14 +7017,14 @@ (define-public python-colormath
(define-public python-sparse
(package
(name "python-sparse")
- (version "0.13.0")
+ (version "0.14.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sparse" version))
(sha256
(base32
- "05ar1lhq1yy4nb78s7vpb1wz4ac4kj0r4lrd7yrf23kpmaacjpb8"))))
+ "1600xad37mff46xg80cy6bi3l2n6jm69j7sl19rzdmkcgyijfn2z"))))
(build-system python-build-system)
(arguments
`(#:phases
--
2.34.1
V
V
Vinicius Monego wrote on 21 May 2023 07:37
[PATCH 3/4] gnu: python-pint: Fix build.
(address . 63623@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20230521053726.1507055-3-monego@posteo.net
* gnu/packages/python-xyz (python-pint)[build-system]: Switch to
pyproject-build-system.
[arguments]: Skip a failing test.
[native-inputs]: Sort alphabetically and add python-importlib-metadata.
---
gnu/packages/python-xyz.scm | 14 +++++++++-----
1 file changed, 9 insertions(+), 5 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3788cefda2..3dba197a94 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1066,17 +1066,21 @@ (define-public python-pint
(sha256
(base32
"0rv0cbala7ibjbaf6kkcn0mdhqdbajnvlcw0f15gwzfwg10g0z1q"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
+ (arguments
+ ;; This single test tries to write to $HOME/.cache/pint.
+ (list #:test-flags #~'("-k" "not test_auto")))
(native-inputs
- (list python-pytest ;for pytest-subtests
+ (list python-dask
+ python-distributed
+ python-importlib-metadata
+ python-pytest ;for pytest-subtests
python-pytest-cov
python-pytest-mpl
python-pytest-subtests
python-setuptools-scm
python-sparse
- python-dask
- python-xarray
- python-distributed))
+ python-xarray))
(home-page "https://github.com/hgrecco/pint")
(synopsis "Physical quantities module")
(description
--
2.34.1
V
V
Vinicius Monego wrote on 21 May 2023 07:37
[PATCH 4/4] gnu: Add python-metpy.
(address . 63623@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20230521053726.1507055-4-monego@posteo.net
* gnu/packages/geo.scm (python-metpy): New variable.
---
gnu/packages/geo.scm | 51 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 345f9dfcf5..df898e462a 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1483,6 +1483,57 @@ (define-public imposm3
license:bsd-2
license:bsd-3))))
+(define-public python-metpy
+ (package
+ (name "python-metpy")
+ (version "1.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "MetPy" version))
+ (sha256
+ (base32
+ "0g9m8qb920mvi0kqw7vbagj08xvv96zj6gjyc7dawlvh15vb55qq"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; Too many of the tests in the files below require online data.
+ (list
+ #:test-flags
+ #~(list "--ignore" "tests/io/test_nexrad.py"
+ "--ignore" "tests/plots/test_declarative.py"
+ "--ignore" "tests/io/test_gempak.py"
+ "--ignore" "tests/io/test_gini.py"
+ "--ignore" "tests/io/test_metar.py"
+ "--ignore" "tests/io/test_station_data.py"
+ "--ignore" "tests/interpolate/test_grid.py"
+ "--ignore" "tests/interpolate/test_points.py"
+ "--ignore" "tests/test_xarray.py"
+ "--ignore" "tests/calc/test_indices.py"
+ "--ignore" "tests/calc/test_kinematics.py"
+ "-k" (string-append ; more tests that require online data
+ "not test_parse_grid_arguments_xarray"
+ " and not test_absolute_momentum_xarray_units_attr"
+ " and not test_zoom_xarray"
+ " and not test_parse_wpc_surface_bulletin"
+ " and not test_add_timestamp_xarray"
+ " and not test_parse_wpc_surface_bulletin_highres"))))
+ (propagated-inputs (list python-importlib-resources
+ python-matplotlib
+ python-numpy
+ python-pandas
+ python-pint
+ python-pooch
+ python-pyproj
+ python-scipy
+ python-traitlets
+ python-xarray))
+ (native-inputs (list python-cartopy python-netcdf4 python-pytest
+ python-pytest-mpl python-shapely))
+ (home-page "https://github.com/Unidata/MetPy")
+ (synopsis "Collection of tools to deal with weather data")
+ (description "MetPy is a collection of tools in Python for reading,
+visualizing and performing calculations with weather data.")
+ (license license:bsd-3)))
+
(define-public libosmium
(package
(name "libosmium")
--
2.34.1
M
M
Maxim Cournoyer wrote on 4 Sep 2023 05:22
Re: bug#63623: [PATCH 0/4] Add MetPy.
(name . Vinicius Monego)(address . monego@posteo.net)(address . 63623-done@debbugs.gnu.org)
87y1hmsjvn.fsf@gmail.com
Hi,

Vinicius Monego <monego@posteo.net> writes:

Toggle quote (6 lines)
> Vinicius Monego (4):
> gnu: python-sparse: Fix build.
> gnu: python-sparse: Update to 0.14.0.
> gnu: python-pint: Fix build.
> gnu: Add python-metpy.

Installed :-).

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63623@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63623
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch