[PATCH 0/2] Restyle and update xmrig to 6.19.2

  • Done
  • quality assurance status badge
Details
3 participants
  • Ahmad Draidi
  • A
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cover.1684611004.git.a.r.draidi@redscript.org
Ahmad Draidi (2):
gnu: xmrig: Run 'guix style' over the package.
gnu: xmrig: Update to 6.19.2.

gnu/packages/finance.scm | 66 ++++++++++++++++++----------------------
1 file changed, 30 insertions(+), 36 deletions(-)


base-commit: 24b6f94cf9b4ab97ef2eb70d05b2104a06776e62
--
2.40.1
Ahmad Draidi wrote 2 years ago
[PATCH 1/2] gnu: xmrig: Run 'guix style' over the package.
(address . 63615@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
b40356a7c9164ebe3de48f1cf8dba39caedc2fa4.1684611004.git.a.r.draidi@redscript.org
* gnu/packages/finance.scm (xmrig): Restyle.
---
gnu/packages/finance.scm | 61 ++++++++++++++++++----------------------
1 file changed, 28 insertions(+), 33 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 559b22257b..71d80bd081 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -2266,44 +2266,39 @@ (define-public xmrig
(package
(name "xmrig")
(version "6.19.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/xmrig/xmrig")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256 (base32 "10vaq6ld4sddnpmv9dg71fjvw1jrfaddrp3bq6p3dxhsl153khm4"))
- (modules '((guix build utils)))
- (snippet
- ;; TODO: Try to use system libraries instead of bundled ones in
- ;; "src/3rdparty/". It requires changes to some "cmake/..." scripts
- ;; and to some source files.
- #~(begin
- (delete-file-recursively "src/3rdparty/hwloc")
- (substitute* "src/donate.h"
- (("constexpr const int kDefaultDonateLevel = 1;")
- "constexpr const int kDefaultDonateLevel = 0;")
- (("constexpr const int kMinimumDonateLevel = 1;")
- "constexpr const int kMinimumDonateLevel = 0;"))))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xmrig/xmrig")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10vaq6ld4sddnpmv9dg71fjvw1jrfaddrp3bq6p3dxhsl153khm4"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; TODO: Try to use system libraries instead of bundled ones in
+ ;; "src/3rdparty/". It requires changes to some "cmake/..." scripts
+ ;; and to some source files.
+ #~(begin
+ (delete-file-recursively "src/3rdparty/hwloc")
+ (substitute* "src/donate.h"
+ (("constexpr const int kDefaultDonateLevel = 1;")
+ "constexpr const int kDefaultDonateLevel = 0;")
+ (("constexpr const int kMinimumDonateLevel = 1;")
+ "constexpr const int kMinimumDonateLevel = 0;"))))))
(build-system cmake-build-system)
- (inputs
- (list
- `(,hwloc "lib")
- libuv
- openssl))
+ (inputs (list `(,hwloc "lib") libuv openssl))
(arguments
(list
;; There are no tests.
#:tests? #f
- #:phases
- #~(modify-phases
- %standard-phases
- (replace 'install
- ;; There is no 'install' target, we must install xmrig manually
- (lambda* (#:key #:allow-other-keys)
- (install-file "xmrig"
- (string-append #$output "/bin")))))))
+ #:phases #~(modify-phases %standard-phases
+ (replace 'install
+ ;; There is no 'install' target, we must install xmrig manually
+ (lambda* (#:key #:allow-other-keys)
+ (install-file "xmrig"
+ (string-append #$output "/bin")))))))
(home-page "https://xmrig.com/")
(synopsis "Monero miner")
(description
--
2.40.1
Ahmad Draidi wrote 2 years ago
[PATCH 2/2] gnu: xmrig: Update to 6.19.2.
(address . 63615@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
b933234e8fc1db2c139052bb216d24a3b4adcb44.1684611004.git.a.r.draidi@redscript.org
* gnu/packages/finance.scm (xmrig): Update to 6.19.2.
[description]: Update supported algorithms.
---
gnu/packages/finance.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 71d80bd081..c7fe996568 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -2265,7 +2265,7 @@ (define-public python-mt-940
(define-public xmrig
(package
(name "xmrig")
- (version "6.19.0")
+ (version "6.19.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2274,7 +2274,7 @@ (define-public xmrig
(file-name (git-file-name name version))
(sha256
(base32
- "10vaq6ld4sddnpmv9dg71fjvw1jrfaddrp3bq6p3dxhsl153khm4"))
+ "1hgcfq79d5060iryr34bpwf1dvgqmbmn9mm4ccfvp896r10j482h"))
(modules '((guix build utils)))
(snippet
;; TODO: Try to use system libraries instead of bundled ones in
@@ -2303,8 +2303,7 @@ (define-public xmrig
(synopsis "Monero miner")
(description
"XMRig is a high performance, cross platform RandomX, KawPow,
-CryptoNight, AstroBWT and GhostRider unified CPU/GPU miner and RandomX
-benchmark.
+ CryptoNight and GhostRider unified CPU/GPU miner and RandomX benchmark.
Warning: upstream, by default, receives a percentage of the mining time. This
anti-functionality has been neutralised in Guix, but possibly not in all other
--
2.40.1
Ahmad Draidi wrote 2 years ago
[PATCH v2 0/2] Restyle and update xmrig to 6.19.2
(address . 63615@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
cover.1684647790.git.a.r.draidi@redscript.org
Version 2 fixes a few typos and grammatical mistakes in the description.
I spotted these after v1 was out. Sorry for the inconvenience.

Ahmad Draidi (2):
gnu: xmrig: Run 'guix style' over the package.
gnu: xmrig: Update to 6.19.2.

gnu/packages/finance.scm | 74 ++++++++++++++++++----------------------
1 file changed, 34 insertions(+), 40 deletions(-)


base-commit: 24b6f94cf9b4ab97ef2eb70d05b2104a06776e62
--
2.40.1
Ahmad Draidi wrote 2 years ago
[PATCH v2 1/2] gnu: xmrig: Run 'guix style' over the package.
(address . 63615@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
b40356a7c9164ebe3de48f1cf8dba39caedc2fa4.1684647790.git.a.r.draidi@redscript.org
* gnu/packages/finance.scm (xmrig): Restyle.
---
gnu/packages/finance.scm | 61 ++++++++++++++++++----------------------
1 file changed, 28 insertions(+), 33 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 559b22257b..71d80bd081 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -2266,44 +2266,39 @@ (define-public xmrig
(package
(name "xmrig")
(version "6.19.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/xmrig/xmrig")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256 (base32 "10vaq6ld4sddnpmv9dg71fjvw1jrfaddrp3bq6p3dxhsl153khm4"))
- (modules '((guix build utils)))
- (snippet
- ;; TODO: Try to use system libraries instead of bundled ones in
- ;; "src/3rdparty/". It requires changes to some "cmake/..." scripts
- ;; and to some source files.
- #~(begin
- (delete-file-recursively "src/3rdparty/hwloc")
- (substitute* "src/donate.h"
- (("constexpr const int kDefaultDonateLevel = 1;")
- "constexpr const int kDefaultDonateLevel = 0;")
- (("constexpr const int kMinimumDonateLevel = 1;")
- "constexpr const int kMinimumDonateLevel = 0;"))))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xmrig/xmrig")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10vaq6ld4sddnpmv9dg71fjvw1jrfaddrp3bq6p3dxhsl153khm4"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; TODO: Try to use system libraries instead of bundled ones in
+ ;; "src/3rdparty/". It requires changes to some "cmake/..." scripts
+ ;; and to some source files.
+ #~(begin
+ (delete-file-recursively "src/3rdparty/hwloc")
+ (substitute* "src/donate.h"
+ (("constexpr const int kDefaultDonateLevel = 1;")
+ "constexpr const int kDefaultDonateLevel = 0;")
+ (("constexpr const int kMinimumDonateLevel = 1;")
+ "constexpr const int kMinimumDonateLevel = 0;"))))))
(build-system cmake-build-system)
- (inputs
- (list
- `(,hwloc "lib")
- libuv
- openssl))
+ (inputs (list `(,hwloc "lib") libuv openssl))
(arguments
(list
;; There are no tests.
#:tests? #f
- #:phases
- #~(modify-phases
- %standard-phases
- (replace 'install
- ;; There is no 'install' target, we must install xmrig manually
- (lambda* (#:key #:allow-other-keys)
- (install-file "xmrig"
- (string-append #$output "/bin")))))))
+ #:phases #~(modify-phases %standard-phases
+ (replace 'install
+ ;; There is no 'install' target, we must install xmrig manually
+ (lambda* (#:key #:allow-other-keys)
+ (install-file "xmrig"
+ (string-append #$output "/bin")))))))
(home-page "https://xmrig.com/")
(synopsis "Monero miner")
(description
--
2.40.1
Ahmad Draidi wrote 2 years ago
[PATCH v2 2/2] gnu: xmrig: Update to 6.19.2.
(address . 63615@debbugs.gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
1f01ffae1b7bc0f6b35b21d5bd3092b98e571c71.1684647790.git.a.r.draidi@redscript.org
* gnu/packages/finance.scm (xmrig): Update to 6.19.2.
[description]: Update supported algorithms and fix grammar..
---
gnu/packages/finance.scm | 15 +++++++--------
1 file changed, 7 insertions(+), 8 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 71d80bd081..20fd501a41 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -2265,7 +2265,7 @@ (define-public python-mt-940
(define-public xmrig
(package
(name "xmrig")
- (version "6.19.0")
+ (version "6.19.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2274,7 +2274,7 @@ (define-public xmrig
(file-name (git-file-name name version))
(sha256
(base32
- "10vaq6ld4sddnpmv9dg71fjvw1jrfaddrp3bq6p3dxhsl153khm4"))
+ "1hgcfq79d5060iryr34bpwf1dvgqmbmn9mm4ccfvp896r10j482h"))
(modules '((guix build utils)))
(snippet
;; TODO: Try to use system libraries instead of bundled ones in
@@ -2302,16 +2302,15 @@ (define-public xmrig
(home-page "https://xmrig.com/")
(synopsis "Monero miner")
(description
- "XMRig is a high performance, cross platform RandomX, KawPow,
-CryptoNight, AstroBWT and GhostRider unified CPU/GPU miner and RandomX
-benchmark.
+ "XMRig is a high-performance, cross-platform RandomX, KawPow,
+ CryptoNight and GhostRider unified CPU/GPU miner and RandomX benchmark.
Warning: upstream, by default, receives a percentage of the mining time. This
-anti-functionality has been neutralised in Guix, but possibly not in all other
+anti-functionality has been neutralized in Guix, but possibly not in all other
distributions.
-Warning: this software, because of it's nature, has high energy consumption.
-Also, the energy expenses might be higher that the cryptocurrency gained by
+Warning: this software, because of its nature, has high energy consumption.
+Also, the energy expenses might be higher than the cryptocurrency gained by
mining.")
(license license:gpl3+)))
--
2.40.1
Guillaume Le Vaillant wrote 2 years ago
Re: [bug#63615] [PATCH v2 0/2] Restyle and update xmrig to 6.19.2
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)(address . 63615-done@debbugs.gnu.org)
87y1li3wys.fsf@kitej
I didn't apply patch 1, as the restyling doesn't seem necessary in this
case.
Patch 2 applied as 7b3f571fc8e3fbb3fefc30ebe53ad074c30653a8 with
a complete commit message.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZGnXWw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8gwAD+Lzctxmj1xy7sPEgM7a2m8ygrQUWV5N/k24P8
eAVgHl8A/1R1Vonoo9ajZYgdEAqxjva1Kz+gz21k1R+jPSTjy/Up
=KNZe
-----END PGP SIGNATURE-----

Closed
A wrote 2 years ago
(address . 63615-done@debbugs.gnu.org)
7a61dcd0-4257-6376-2f70-b236b6dbfd9e@redscript.org
Hello,

On 5/21/23 12:30, Guillaume Le Vaillant wrote:
Toggle quote (2 lines)
> I didn't apply patch 1, as the restyling doesn't seem necessary in this
> case.
Out of curiosity, when would it be appropriate to send a "restyle" patch?
Toggle quote (3 lines)
> Patch 2 applied as 7b3f571fc8e3fbb3fefc30ebe53ad074c30653a8 with
> a complete commit message.
> Thanks.
Thanks!
Closed
Guillaume Le Vaillant wrote 2 years ago
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)(address . 63615@debbugs.gnu.org)
87ttw5538x.fsf@kitej
A <a@redscript.org> skribis:

Toggle quote (11 lines)
> Hello,
>
> On 5/21/23 12:30, Guillaume Le Vaillant wrote:
>> I didn't apply patch 1, as the restyling doesn't seem necessary in this
>> case.
> Out of curiosity, when would it be appropriate to send a "restyle" patch?
>> Patch 2 applied as 7b3f571fc8e3fbb3fefc30ebe53ad074c30653a8 with
>> a complete commit message.
>> Thanks.
> Thanks!

Restyling is usually done when a package is still using the old style
with labels for inputs, when it is using quasiquote forms for arguments
and using gexps would simplify things, or when it has very long lines
(more than 80 characters).
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63615@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63615
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help