[PATCH 0/6] Update searx and dependencies.

  • Open
  • quality assurance status badge
Details
One participant
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 20 May 2023 18:42
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
cover.1684600821.git.kiasoc5@disroot.org
kiasoc5 (6):
gnu: Add python-ephemeral-port-reserve.
gnu: python-watchdog: Update to 3.0.0.
gnu: python-jinja2: Update to 3.1.2.
gnu: python-werkzeug: Update to 2.2.3.
gnu: python-flask: Update to 2.2.2.
gnu: searx: Update to 1.1.0.

gnu/packages/python-web.scm | 62 +++++++++++++++++++++++--------------
gnu/packages/python-xyz.scm | 36 +++++++++------------
gnu/packages/search.scm | 42 +++++++++++++------------
3 files changed, 75 insertions(+), 65 deletions(-)


base-commit: 0aab24855238cc7c7a31066ab39cd94e534b857f
--
2.40.1
K
K
kiasoc5 wrote on 20 May 2023 18:44
[PATCH 1/6] gnu: Add python-ephemeral-port-reserve.
(address . 63612@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
027691fe563599ebf8d49e15bac000a01ae6ddd5.1684600821.git.kiasoc5@disroot.org
* gnu/packages/python-web.scm (python-ephemeral-port-reserve): New variable.
---
gnu/packages/python-web.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b6ad489626..337c2b72c0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5802,6 +5802,26 @@ (define-public python-port-for
association.")
(license license:expat)))
+(define-public python-ephemeral-port-reserve
+ (package
+ (name "python-ephemeral-port-reserve")
+ (version "1.1.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "ephemeral_port_reserve" version))
+ (sha256
+ (base32
+ "1chl9hil7ggz6l4sfhmp0l2j55qcskbc3pj9360b0309jwndmxxq"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/Yelp/ephemeral-port-reserve/")
+ (synopsis
+ "Find an unused port, reliably.")
+ (description
+ "@code{ephemeral-port-reserve} provides a reliable and race-free
+implementation of the ``port 0 trick'': bind to an ephemeral port, force it into
+the TIME_WAIT state, and unbind it.")
+ (license license:expat)))
+
(define-public python-livereload
(package
(name "python-livereload")
--
2.40.1
K
K
kiasoc5 wrote on 20 May 2023 18:44
[PATCH 2/6] gnu: python-watchdog: Update to 3.0.0.
(address . 63612@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
4526a21c0c97d1db4cfaa0b4f175cf7d97a32780.1684600821.git.kiasoc5@disroot.org
* gnu/packages/python-xyz.scm (python-watchdog): Update to 3.0.0.
[build-system]: Switch to pyproject-build-system.
[arguments]: Delete check phase. Add #:test-flags. Skip more tests.
---
gnu/packages/python-xyz.scm | 23 +++++++++++------------
1 file changed, 11 insertions(+), 12 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f7e3f6f538..80d5085f3b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26953,24 +26953,23 @@ (define-public python-android-stringslib
(define-public python-watchdog
(package
(name "python-watchdog")
- (version "2.1.6")
+ (version "3.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "watchdog" version))
(sha256
- (base32 "1rx2nyl0cyj0v4ja795cl3gi26577c5wg48syr3byz3ndkgpavm3"))))
- (build-system python-build-system)
+ (base32 "1y9kk9hbyhidyhpaqg7rg3d3rry26fv8ri4gl72sg9sxb4ha762d"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest" "-k"
- ;; This test failed.
- "not test_kill_auto_restart")))))))
+ (list
+ #:test-flags
+ '(list "-k"
+ (string-join '("not test_inotify_buffer"
+ "test_unmount_watched_directory_filesystem"
+ "test_auto_restart_on_file_change_debounce"
+ "test_kill_auto_restart")
+ " and not "))))
(propagated-inputs
(list python-pathtools python-pyyaml))
(native-inputs
--
2.40.1
K
K
kiasoc5 wrote on 20 May 2023 18:44
[PATCH 4/6] gnu: python-werkzeug: Update to 2.2.3.
(address . 63612@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
07ca6d2acf1f56fcf0bae35cac3eaec622e916cb.1684600821.git.kiasoc5@disroot.org
* gnu/packages/python-web.scm (python-werkzeug): Update to 2.2.3.
[build-system]: Switch to pyproject-build-system.
[arguments]: Delete check phase. Use test flags. Skip another test.
[propagated-inputs]: Add python-markupsafe.
[native-inputs]: Add python-cryptography, python-ephemeral-port-reserve,
python-greenlet, and python-watchdog.
---
gnu/packages/python-web.scm | 29 +++++++++++++++--------------
1 file changed, 15 insertions(+), 14 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 337c2b72c0..b675edab12 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4625,29 +4625,30 @@ (define-public python-publicsuffix2
(define-public python-werkzeug
(package
(name "python-werkzeug")
- (version "2.0.2")
+ (version "2.2.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Werkzeug" version))
(sha256
(base32
- "16nvv9dh37ssf5pkny9yj2li0n6wyzsygh8a9i86r3gfipybcaxa"))))
- (build-system python-build-system)
+ "1zhaznfq2pc6czbg5gjg3pm92hq9mkip9wg6kn5kbnnl2yacq71f"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest"
- ;; Test tries to use the network.
- "-k not test_reloader_sys_path")))))))
+ (list
+ #:test-flags
+ ;; Test tries to use the network.
+ '(list "-k" "not test_exclude_patterns and not test_reloader_sys_path")))
(propagated-inputs
- (list python-requests))
+ (list python-requests python-markupsafe))
(native-inputs
- (list python-pytest python-pytest-timeout python-pytest-xprocess))
+ (list python-cryptography
+ python-ephemeral-port-reserve
+ python-greenlet
+ python-pytest
+ python-pytest-timeout
+ python-pytest-xprocess
+ python-watchdog))
(home-page "https://palletsprojects.com/p/werkzeug/")
(synopsis "Utilities for WSGI applications")
(description "One of the most advanced WSGI utility modules. It includes a
--
2.40.1
K
K
kiasoc5 wrote on 20 May 2023 18:44
[PATCH 3/6] gnu: python-jinja2: Update to 3.1.2.
(address . 63612@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
492b2d8d0c6c25b548ec1de476226bfff4924440.1684600821.git.kiasoc5@disroot.org
* gnu/packages/python-xyz.scm (python-jinja2): Update to 3.1.2.
[build-system]: Switch to pyproject-build-system.
[arguments]: Delete them.
---
gnu/packages/python-xyz.scm | 13 +++----------
1 file changed, 3 insertions(+), 10 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 80d5085f3b..d5e2de18ee 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5040,22 +5040,15 @@ (define-public python-markupsafe
(define-public python-jinja2
(package
(name "python-jinja2")
- (version "3.1.1")
+ (version "3.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Jinja2" version))
(sha256
(base32
- "1saawzys14l1p4kafs7hkihmnvqjq8fwxjmkjiqx3jq1nm5ys2v4"))))
- (build-system python-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-vv")
- (format #t "test suite not run~%")))))))
+ "0lp86yadzf8dph67f6g3yxmvnhrzzi863z58jmsrx2j059q1ld9i"))))
+ (build-system pyproject-build-system)
(native-inputs (list python-pytest))
(propagated-inputs (list python-markupsafe))
(home-page "https://jinja.palletsprojects.com/")
--
2.40.1
K
K
kiasoc5 wrote on 20 May 2023 18:44
[PATCH 5/6] gnu: python-flask: Update to 2.2.2.
(address . 63612@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
2964789af39f9a0cd12097118fa89f6ea0d9b56b.1684600821.git.kiasoc5@disroot.org
* gnu/packages/python-web.scm (python-flask): Update to 2.2.2.
[build-system]: Switch to pyproject-build-system.
[arguments]: Delete it.
---
gnu/packages/python-web.scm | 13 +++----------
1 file changed, 3 insertions(+), 10 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b675edab12..f20a7432f9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3624,21 +3624,14 @@ (define-public python-webtest
(define-public python-flask
(package
(name "python-flask")
- (version "2.1.1")
+ (version "2.2.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "Flask" version))
(sha256
(base32
- "1j0rjly2yhbm566lq2s8543fs7fz86f77abps539djcfalzbvjd8"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "tests")))))))
+ "0ayadjqn8lky9rmly7r33sm589fkysld56vjjqplibf4346lab34"))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-pytest))
(propagated-inputs
--
2.40.1
K
K
kiasoc5 wrote on 20 May 2023 18:44
[PATCH 6/6] gnu: searx: Update to 1.1.0.
(address . 63612@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
dbf791d67c929222ca260054dbee3e76566d0107.1684600821.git.kiasoc5@disroot.org
* gnu/packages/search.scm (searx): Update to 1.1.0.
[source](version): append "v" to commit tag.
[build-system]: Use pyproject-build-system.
[arguments](phases): Use G-expression.
[propagated-inputs]: Add python-brotli, python-setproctitle, and python-pysocks.
---
gnu/packages/search.scm | 42 ++++++++++++++++++++++-------------------
1 file changed, 23 insertions(+), 19 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index 04e03a55b1..947d191858 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -39,6 +39,7 @@ (define-module (gnu packages search)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system meson)
#:use-module (gnu packages)
#:use-module (gnu packages adns)
@@ -263,34 +264,35 @@ (define-public tocc
(define-public searx
(package
(name "searx")
- (version "1.0.0")
+ (version "1.1.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/searx/searx")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0ghkx8g8jnh8yd46p4mlbjn2zm12nx27v7qflr4c8xhlgi0px0mh"))))
- (build-system python-build-system)
+ (base32 "070kxivn1nxn3klmnqarr2zldyfpyllpv5cnjdp5kqz19zb20szr"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:tests? #f ;what tests do is make online requests to each engine
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- ;; Tests can run after build with 'searx-checker' tool in /bin.
- ;; allow using a higher dependency version
- (substitute* "requirements.txt"
- (("==") ">="))))
- (add-before 'sanity-check 'set-debug
- (lambda _
- ;; the user will need to change the secret key
- ;; https://github.com/searx/searx/issues/2278
- (setenv "SEARX_DEBUG" "1"))))))
+ (list #:tests? #f ;what tests do is make online requests to each engine
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ ;; Tests can run after build with 'searx-checker' tool in /bin.
+ ;; allow using a higher dependency version
+ (substitute* "requirements.txt"
+ (("==") ">="))))
+ (add-before 'sanity-check 'set-debug
+ (lambda _
+ ;; the user will need to change the secret key
+ ;; https://github.com/searx/searx/issues/2278
+ (setenv "SEARX_DEBUG" "1"))))))
(propagated-inputs
(list python-babel
+ python-brotli
python-certifi
python-dateutil
python-flask
@@ -301,7 +303,9 @@ (define-public searx
python-lxml
python-pygments
python-pyyaml
- python-requests))
+ python-requests
+ python-setproctitle
+ python-pysocks))
(home-page "https://searx.github.io/searx/")
(synopsis "Privacy-respecting metasearch engine")
(description "Searx is a privacy-respecting, hackable metasearch engine.")
--
2.40.1
?