[PATCH] gnu: lolcat: Update to 1.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • 宋文武
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 2 years ago
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
3d015742e5788ca771da94bd2f46f9c5dbf89661.1684473806.git.kiasoc5@disroot.org
* gnu/packages/toys.scm (lolcat): Update to 1.4.
[version]: Switch to release tag.
[arguments]: Use G-expressions. Remove trailing #t.
<#:phases>: Replace assoc-ref with #$output.
---
gnu/packages/toys.scm | 70 +++++++++++++++++++++----------------------
1 file changed, 34 insertions(+), 36 deletions(-)

Toggle diff (87 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 8967c0c25b..ca2abc8ac9 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -137,44 +137,42 @@ (define-public fortunes-jkirchartz
(license license:unlicense))))
(define-public lolcat
- (let ((commit "35dca3d0a381496d7195cd78f5b24aa7b62f2154")
- (revision "0"))
- (package
- (name "lolcat")
- (version (git-version "1.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jaseg/lolcat")
- (commit commit)))
- (sha256
- (base32
- "0jjbkqcc2ikjxd1xgdyv4rb0vsw218181h89f2ywg29ffs3ypd8g"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:make-flags
- (list ,(string-append "CC=" (cc-for-target)))
- #:phases
- (modify-phases %standard-phases
- (delete 'bootstrap)
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dest (string-append out "/bin")))
- (mkdir-p dest)
- (install-file "lolcat" dest)
- (install-file "censor" dest)
- #t))))))
- (home-page "https://github.com/jaseg/lolcat")
- (synopsis "Rainbow coloring effect for text console display")
- (description "@command{lolcat} concatenates files and streams like
+ (package
+ (name "lolcat")
+ (version "1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaseg/lolcat")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0wyx184072z820njlc6qkvpxwcpjhj25gq4j0iw3jqzv3sk7mg7q"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no check target
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (dest (string-append out "/bin")))
+ (mkdir-p dest)
+ (install-file "lolcat" dest)
+ (install-file "censor" dest)))))))
+ (home-page "https://github.com/jaseg/lolcat")
+ (synopsis "Rainbow coloring effect for text console display")
+ (description "@command{lolcat} concatenates files and streams like
regular @command{cat}, but it also adds terminal escape codes between
characters and lines resulting in a rainbow effect.")
- (license license:wtfpl2))))
+ (license license:wtfpl2)))
(define-public oneko
(package

base-commit: 321ae25a26986c4ac06e5c0c99d19e1c808da6ac
--
2.40.1
kiasoc5 wrote 2 years ago
[PATCH v2] gnu: lolcat: Update to 1.4.
(address . 63580@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
d78247bea565ecde03c04653ba831fbd05016325.1684474172.git.kiasoc5@disroot.org
Forgot to add the #$output part last time.

* gnu/packages/toys.scm (lolcat): Update to 1.4.
[version]: Switch to release tag.
[arguments]: Use G-expressions. Remove trailing #t.
<#:phases>: Replace assoc-ref with #$output.
---
gnu/packages/toys.scm | 69 +++++++++++++++++++++----------------------
1 file changed, 33 insertions(+), 36 deletions(-)

Toggle diff (86 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 8967c0c25b..21d5279e85 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -137,44 +137,41 @@ (define-public fortunes-jkirchartz
(license license:unlicense))))
(define-public lolcat
- (let ((commit "35dca3d0a381496d7195cd78f5b24aa7b62f2154")
- (revision "0"))
- (package
- (name "lolcat")
- (version (git-version "1.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jaseg/lolcat")
- (commit commit)))
- (sha256
- (base32
- "0jjbkqcc2ikjxd1xgdyv4rb0vsw218181h89f2ywg29ffs3ypd8g"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no check target
- #:make-flags
- (list ,(string-append "CC=" (cc-for-target)))
- #:phases
- (modify-phases %standard-phases
- (delete 'bootstrap)
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dest (string-append out "/bin")))
- (mkdir-p dest)
- (install-file "lolcat" dest)
- (install-file "censor" dest)
- #t))))))
- (home-page "https://github.com/jaseg/lolcat")
- (synopsis "Rainbow coloring effect for text console display")
- (description "@command{lolcat} concatenates files and streams like
+ (package
+ (name "lolcat")
+ (version "1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaseg/lolcat")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0wyx184072z820njlc6qkvpxwcpjhj25gq4j0iw3jqzv3sk7mg7q"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ; no check target
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (let ((dest (string-append #$output "/bin")))
+ (mkdir-p dest)
+ (install-file "lolcat" dest)
+ (install-file "censor" dest)))))))
+ (home-page "https://github.com/jaseg/lolcat")
+ (synopsis "Rainbow coloring effect for text console display")
+ (description "@command{lolcat} concatenates files and streams like
regular @command{cat}, but it also adds terminal escape codes between
characters and lines resulting in a rainbow effect.")
- (license license:wtfpl2))))
+ (license license:wtfpl2)))
(define-public oneko
(package

base-commit: 321ae25a26986c4ac06e5c0c99d19e1c808da6ac
--
2.40.1
宋文武 wrote 2 years ago
Re: bug#63580: [PATCH] gnu: lolcat: Update to 1.4.
(name . kiasoc5)(address . kiasoc5@disroot.org)(address . 63580-done@debbugs.gnu.org)
878rdddhvm.fsf_-_@envs.net
kiasoc5 <kiasoc5@disroot.org> writes:

Toggle quote (2 lines)
> * gnu/packages/toys.scm (lolcat): Update to 1.4.

Pushed, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63580@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63580
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help