(address . guix-patches@gnu.org)(name . Skylar "The Cobra" Widulski)(address . cobra@vern.cc)
From: "Skylar \"The Cobra\" Widulski" <cobra@vern.cc>
Signed-off-by: Skylar "The Cobra" Widulski <cobra@vern.cc>
---
gnu/packages/video.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (55 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0abc153c60..f31eee4a43 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -64,6 +64,7 @@
;;; Copyright © 2022 Chadwain Holness <chadwainholness@gmail.com>
;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;; Copyright © 2023 Ott Joon <oj@vern.cc>
+;;; Copyright © 2023 Skylar Widulski <cobra@vern.cc>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -202,6 +203,7 @@ (define-module (gnu packages video)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages wget)
+ #:use-module (gnu packages wm)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xiph)
@@ -5658,3 +5660,32 @@ (define-public svtplay-dl
broadcasters including SVT Play, Sveriges Radio, TV4 Play, along with many
others.")
(license license:expat)))
+
+(define-public wf-shadow
+ (package
+ (name "wf-shadow")
+ (version "1.5.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/cobra/wf-shadow")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qyf1w9vw5xswf9vw1267l5zh1dckilbmcm7qj1v762n2saw103p"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("wf-shadow" "bin/")
+ ("wf-shadow-tui" "bin/")
+ ("doc/wf-shadow.1" "share/man/man1/")
+ ("doc/wf-shadow-tui.1" "share/man/man1/"))))
+ (inputs (list bash wf-recorder wofi dialog wlr-randr))
+ (home-page "https://codeberg.org/cobra/wf-shadow")
+ (synopsis "Make instant-replay easy on wlroots based compositors")
+ (description
+ "@code{wf-shadow} is a script written in order to fill the void in
+instant-replay software for Wayland, specifically wlroots compositors. It uses
+wf-recorder and wofi in order to accomplish the task.")
+ (license license:gpl3+)))
--
2.40.1