[PATCH] gnu: add tcptrack

  • Done
  • quality assurance status badge
Details
3 participants
  • Jakob Kirsch
  • Jelle Licht
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Jakob Kirsch
Severity
normal

Debbugs page

Jakob Kirsch wrote 2 years ago
(address . guix-patches@gnu.org)(name . Jakob Kirsch)(address . jakob.kirsch@web.de)
3e95e1934550698a5ce8b2395ac591df6c5fe9b3.1684348522.git.jakob.kirsch@web.de
---
gnu/packages/admin.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 047b0ebcc6..0ae883e0b4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4255,6 +4255,30 @@ (define-public thermald
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:gpl2)))

+(define-public tcptrack
+ (package
+ (name "tcptrack")
+ (version "1.4.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bchretien/tcptrack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08lh3l67wn4kq9q0nfspc7rj0jvp9dzwjgxpvqliwcif8cy5mi45"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f))
+ (inputs (list libpcap ncurses))
+ (synopsis "Display information about TCP connections")
+ (description
+ "A sniffer which displays information about TCP connections it
+sees on a network interface. (backup from Steve Bensons's tcptrack)")
+ (home-page "https://github.com/bchretien/tcptrack")
+ (license license:lgpl2.1)))
+
(define-public masscan
(package
(name "masscan")

base-commit: c8e599b9391f789a8a3e2183fc8f0c2a5061ceb0
--
2.39.2
Jelle Licht wrote 2 years ago
(name . Jakob Kirsch)(address . jakob.kirsch@web.de)
87a5wt7u8a.fsf@fsfe.org
Hi Jakob,

Thank you for the patch! Delayed as it may be, I have some small points
of order to share.

We try to follow the Changelog format in commit logs, see
for the thorough explanation (or just have a look at commit logs for
some of the other packages that were added by people).

Jakob Kirsch <jakob.kirsch@web.de> writes:
Toggle quote (28 lines)
> ---
> gnu/packages/admin.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index 047b0ebcc6..0ae883e0b4 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -4255,6 +4255,30 @@ (define-public thermald
> (supported-systems '("i686-linux" "x86_64-linux"))
> (license license:gpl2)))
>
> +(define-public tcptrack
> + (package
> + (name "tcptrack")
> + (version "1.4.3")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/bchretien/tcptrack")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "08lh3l67wn4kq9q0nfspc7rj0jvp9dzwjgxpvqliwcif8cy5mi45"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f))
Please add a comment explaining why tests are disabled (e.g. `; no
tests')

Toggle quote (6 lines)
> + (inputs (list libpcap ncurses))
> + (synopsis "Display information about TCP connections")
> + (description
> + "A sniffer which displays information about TCP connections it
> +sees on a network interface. (backup from Steve Bensons's tcptrack)")

The description should contain complete sentences, if possible.
How about something like this:

Tcptrack is a sniffer which displays information about TCP connections
it sees on a network interface. This is a fork of Steve Benson’s
tcptrack.

(Note the double spacing after the .)

Toggle quote (3 lines)
> + (license license:lgpl2.1)))

Having looked at the source archives, I think there are a bunch of
GPLv2+ licensed source files in the tarball (note the missing L). Could
you perhaps open an issue so the author(s) could (re)confirm the status
of these source files? The folks over at [1] also indicate the package
is licensed as GPLv2+, so there may be some confusion about the
licensing status of the package.

Cheers,
Jelle

Jakob Kirsch wrote 2 years ago
[PATCH v1] gnu: add tcptrack
(address . 63566@debbugs.gnu.org)(name . Jakob Kirsch)(address . jakob.kirsch@web.de)
bdc9794ec379bee1c8f695dffeba60c2e3032c6d.1687378487.git.jakob.kirsch@web.de
* gnu/packages/admin.scm (tcptrack): New variable
---
gnu/packages/admin.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 529a477ed0..3dd8b25836 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4256,6 +4256,29 @@ (define-public thermald
(supported-systems '("i686-linux" "x86_64-linux"))
(license license:gpl2)))

+(define-public tcptrack
+ (package
+ (name "tcptrack")
+ (version "1.4.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bchretien/tcptrack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08lh3l67wn4kq9q0nfspc7rj0jvp9dzwjgxpvqliwcif8cy5mi45"))))
+ (build-system gnu-build-system)
+ (inputs (list libpcap ncurses))
+ (synopsis "Display information about TCP connections")
+ (description
+ "Tcptrack is a sniffer which displays information about TCP connections
+it sees on a network interface. This is a fork of Steve Benson’s tcptrack.")
+ (home-page "https://github.com/bchretien/tcptrack")
+ ; the COPYING file states the following license but the tcptrack.spec states just 'GPL'
+ (license license:lgpl2.1)))
+
(define-public masscan
(package
(name "masscan")

base-commit: dcca13ed7340f17a33a4c0907c13b64d5da66a8e
--
2.39.3
Maxim Cournoyer wrote 2 years ago
Re: bug#63566: [PATCH] gnu: add tcptrack
(name . Jakob Kirsch)(address . jakob.kirsch@web.de)
87h6oe2c1x.fsf_-_@gmail.com
Hi,

Jakob Kirsch <jakob.kirsch@web.de> writes:

Toggle quote (36 lines)
> * gnu/packages/admin.scm (tcptrack): New variable
> ---
> gnu/packages/admin.scm | 23 +++++++++++++++++++++++
> 1 file changed, 23 insertions(+)
>
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index 529a477ed0..3dd8b25836 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -4256,6 +4256,29 @@ (define-public thermald
> (supported-systems '("i686-linux" "x86_64-linux"))
> (license license:gpl2)))
>
> +(define-public tcptrack
> + (package
> + (name "tcptrack")
> + (version "1.4.3")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/bchretien/tcptrack")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "08lh3l67wn4kq9q0nfspc7rj0jvp9dzwjgxpvqliwcif8cy5mi45"))))
> + (build-system gnu-build-system)
> + (inputs (list libpcap ncurses))
> + (synopsis "Display information about TCP connections")
> + (description
> + "Tcptrack is a sniffer which displays information about TCP connections
> +it sees on a network interface. This is a fork of Steve Benson’s tcptrack.")
> + (home-page "https://github.com/bchretien/tcptrack")
> + ; the COPYING file states the following license but the tcptrack.spec states just 'GPL'
> + (license license:lgpl2.1)))

I've made the following small changes:

Toggle snippet (19 lines)
modified gnu/packages/admin.scm
@@ -4291,13 +4291,12 @@ (define-public tcptrack
"08lh3l67wn4kq9q0nfspc7rj0jvp9dzwjgxpvqliwcif8cy5mi45"))))
(build-system gnu-build-system)
(inputs (list libpcap ncurses))
- (synopsis "Display information about TCP connections")
+ (synopsis "TCP connections sniffer")
(description
"Tcptrack is a sniffer which displays information about TCP connections
it sees on a network interface. This is a fork of Steve Benson’s tcptrack.")
(home-page "https://github.com/bchretien/tcptrack")
- ; the COPYING file states the following license but the tcptrack.spec states just 'GPL'
- (license license:lgpl2.1)))
+ (license license:lgpl2.1+)))
(define-public masscan
(package

Fixing the license (note the + which means 'or later'). Conventionally
the synopsis is worded to describe what it *is* rather than what it
does (the later is kept for the description).

I've now installed the change, thank you!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63566@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63566
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help