cpp-mustache-4.1 build fails

  • Done
  • quality assurance status badge
Details
3 participants
  • Denis 'GNUtoo' Carikli
  • Giovanni Biscuolo
  • hub.lombard
Owner
unassigned
Submitted by
Giovanni Biscuolo
Severity
normal
G
G
Giovanni Biscuolo wrote on 17 May 2023 12:06
(address . bug-guix@gnu.org)
878rdnjmq9.fsf@xelera.eu
Hello,

using Guix at commit c8e599b939, cpp-mustache build is failing with this
error:

Toggle snippet (86 lines)
The following derivation will be built:
/gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv

[...]

building /gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv...

[...]

starting phase `configure'
source directory: "/tmp/guix-build-cpp-mustache-4.1.drv-0/source" (relative from build: "../source")
build directory: "/tmp/guix-build-cpp-mustache-4.1.drv-0/build"
running 'cmake' with arguments ("../source" "-DCMAKE_BUILD_TYPE=RelWithDebInfo" "-DCMAKE_INSTALL_PREFIX=/gnu/store/2c9hzfc1d8k3x2h0rw3jfwd3w1nbvwqf-cpp-mustache-4.1" "-DCMAKE_INSTALL_LIBDIR=lib" "-DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE" "-DCMAKE_INSTALL_RPATH=/gnu/store/2c9hzfc1d8k3x2h0rw3jfwd3w1nbvwqf-cpp-mustache-4.1/lib" "-DCMAKE_VERBOSE_MAKEFILE=ON")
CMake Deprecation Warning at CMakeLists.txt:1 (cmake_minimum_required):
Compatibility with CMake < 2.8.12 will be removed from a future version of
CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell
CMake that the project does not need compatibility with older versions.


-- The C compiler identification is GNU 11.3.0
-- The CXX compiler identification is GNU 11.3.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/gcc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Configuring done
-- Generating done
CMake Warning:
Manually-specified variables were not used by the project:

CMAKE_INSTALL_LIBDIR


-- Build files have been written to: /tmp/guix-build-cpp-mustache-4.1.drv-0/build
phase `configure' succeeded after 0.8 seconds
starting phase `patch-generated-file-shebangs'
phase `patch-generated-file-shebangs' succeeded after 0.0 seconds
starting phase `build'
/gnu/store/ygab8v4ci9iklaykapq52bfsshpvi8pw-cmake-minimal-3.24.2/bin/cmake -S/tmp/guix-build-cpp-mustache-4.1.drv-0/source -B/tmp/guix-build-cpp-mustache-4.1.drv-0/build --check-build-system CMakeFiles/Makefile.cmake 0
/gnu/store/ygab8v4ci9iklaykapq52bfsshpvi8pw-cmake-minimal-3.24.2/bin/cmake -E cmake_progress_start /tmp/guix-build-cpp-mustache-4.1.drv-0/build/CMakeFiles /tmp/guix-build-cpp-mustache-4.1.drv-0/build//CMakeFiles/progress.marks
make -f CMakeFiles/Makefile2 all
make[1]: Entering directory '/tmp/guix-build-cpp-mustache-4.1.drv-0/build'
make -f CMakeFiles/mustache.dir/build.make CMakeFiles/mustache.dir/depend
make[2]: Entering directory '/tmp/guix-build-cpp-mustache-4.1.drv-0/build'
cd /tmp/guix-build-cpp-mustache-4.1.drv-0/build && /gnu/store/ygab8v4ci9iklaykapq52bfsshpvi8pw-cmake-minimal-3.24.2/bin/cmake -E cmake_depends "Unix Makefiles" /tmp/guix-build-cpp-mustache-4.1.drv-0/source /tmp/guix-build-cpp-mustache-4.1.drv-0/source /tmp/guix-build-cpp-mustache-4.1.drv-0/build /tmp/guix-build-cpp-mustache-4.1.drv-0/build /tmp/guix-build-cpp-mustache-4.1.drv-0/build/CMakeFiles/mustache.dir/DependInfo.cmake --color=
make[2]: Leaving directory '/tmp/guix-build-cpp-mustache-4.1.drv-0/build'
make -f CMakeFiles/mustache.dir/build.make CMakeFiles/mustache.dir/build
make[2]: Entering directory '/tmp/guix-build-cpp-mustache-4.1.drv-0/build'
[ 50%] Building CXX object CMakeFiles/mustache.dir/tests.cpp.o
/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/c++ -O2 -g -DNDEBUG -Wall -Wextra -Werror -std=c++11 -MD -MT CMakeFiles/mustache.dir/tests.cpp.o -MF CMakeFiles/mustache.dir/tests.cpp.o.d -o CMakeFiles/mustache.dir/tests.cpp.o -c /tmp/guix-build-cpp-mustache-4.1.drv-0/source/tests.cpp
In file included from /gnu/store/gsjczqir1wbz8p770zndrpw4rnppmxi3-glibc-2.35/include/signal.h:328,
from /tmp/guix-build-cpp-mustache-4.1.drv-0/source/catch.hpp:6520,
from /tmp/guix-build-cpp-mustache-4.1.drv-0/source/tests.cpp:32:
/tmp/guix-build-cpp-mustache-4.1.drv-0/source/catch.hpp:6543:33: error: size of array ?altStackMem? is not an integral constant-expression
6543 | static char altStackMem[SIGSTKSZ];
| ^~~~~~~~
/tmp/guix-build-cpp-mustache-4.1.drv-0/source/catch.hpp:6594:45: error: size of array ?altStackMem? is not an integral constant-expression
6594 | char FatalConditionHandler::altStackMem[SIGSTKSZ] = {};
| ^~~~~~~~
make[2]: *** [CMakeFiles/mustache.dir/build.make:79: CMakeFiles/mustache.dir/tests.cpp.o] Error 1
make[2]: Leaving directory '/tmp/guix-build-cpp-mustache-4.1.drv-0/build'
make[1]: *** [CMakeFiles/Makefile2:86: CMakeFiles/mustache.dir/all] Error 2
make[1]: Leaving directory '/tmp/guix-build-cpp-mustache-4.1.drv-0/build'
make: *** [Makefile:94: all] Error 2
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("-j" "8") exit-status: 2 term-signal: #f stop-signal: #f>
phase `build' failed after 2.7 seconds
command "make" "-j" "8" failed with status 2
builder for `/gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv' failed with exit code 1
@ build-failed /gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv - 1 builder for `/gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv' failed with exit code 1
derivation '/gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv' offloaded to 'batondor' failed: build of `/gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv' failed
build of /gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv failed
Could not find build log for '/gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv'.
guix build: error: build of `/gnu/store/s9qrl5dmbgqikhc9k07qcwhb2w8mk1g0-cpp-mustache-4.1.drv' failed


Happy hacking! Gio'

--
Giovanni Biscuolo

Xelera IT Infrastructures
-----BEGIN PGP SIGNATURE-----

iQJABAEBCgAqFiEERcxjuFJYydVfNLI5030Op87MORIFAmRkpy4MHGdAeGVsZXJh
LmV1AAoJENN9DqfOzDkS6CcP/1Pl5FnkOcvWMgPEEaj95h5avLX2MUUVVpkd384E
k20xnyEvAC9e9otZacDr9nQP9I6HaUmzCarycIaeTSZwn0RYvCtRAK352gbPT5Ce
j/w42uwSNtVA4g0/PipC4w538AqYGkVD6Tsi6lqLHSTcePnDJBHJWJa2OBsiGcpo
+YIqtxkQEOJp9TybREjIB+LPMGXceCzawrJM+THVcQk0YHXYxbhN9xM3fmTb5YFV
+stSQ0PX5XAyOHPV8yVLaA/2JP+b1OmUY3v8JtNSJ6+K7Gm1I8/EF57m2CLnKJn3
fADRtY3tyrE2gbCsK2Kc84E7er2BWsyy9rz65HuqvyoVtouxBksJJnIHS7Ka+lot
PfKP2yxbxayWyE+gTcRbZvgkOYCyEPqQpP0oxDBRoCnraWk8FtWrP/2c0zAZ++Pp
gkzhicIpwSl6/g1Hw5y7VF0xTMO5ybtutP6dV4AiZCGHTl76VVDIJr/yFjIbQ02n
E3NWWLHqtTUi74Nm1sgrom/6bV4xHm7tJbaHYPdZ5y3CifD0SgdIbt6li/Md2SwZ
z0mMFn8q2sfN9ITB0u7TB5RiZzgCLJMGO55OCWXfUUi63yxIgaWBLNCngV8aUwte
T/f7t5tpLSJbQoyl4F5ndVUn/W1ByBLw1pbYRaKPAfMa36zT6U6Mw+xdgCsSzhwT
Sqd0
=l3dh
-----END PGP SIGNATURE-----

G
G
Giovanni Biscuolo wrote on 17 May 2023 12:44
(address . 63551@debbugs.gnu.org)
877ct7jkyd.fsf@xelera.eu
Hello

thank you very much Hubert for your report: errors like the one you
found (packages build failures) are bugs, next time please report them
to bug-guix@gnu.org; better to close a non-bug than to miss an actual
one ;-)

As you can see I've now filed a new bug: bug#63551

Thank you also to Vagrant and Denis for the heads up, please submit
further comments or patches to 63551@debbugs.gnu.org

Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> writes:

[...]

Toggle quote (17 lines)
> There are several approaches here and I've patches for two of them if
> needed (I've attached them):
> (1) backport some upstream patches:
> - There are 2 catch2 updates, they can be squashed into 1 patch
> - We also need a patch for fixing unused variables.
> (2) Update cpp-mustache: There is an upstream commit
> (https://github.com/kainjow/Mustache/commit/4ed8c0b5a2a43d59394bd6900dc04e738dbf8c02)
> that change some version string. I've asked upstream if that was
> the 5.0.0 release but so far I got no answer.
> https://github.com/kainjow/Mustache/issues/65
>
> (1) is 0001-gnu-cpp-mustache-fix-build-with-newer-glibc.patch
> (2) is 0001-bug-reported-upstream-for-release-info-gnu-cpp-musta.patch
>
> I didn't share the patches yet because I was waiting on upstream to
> clarify the situation with the lack of 5.0.0 tag.

Please do not wait for an official upstream "release" (git tag,
actually) for cpp-mustache, I guess upstream just forgot to tag it: Guix
is full of "not officially" released or properly tagged packages,
sources are often taken from carefully selected git commits (I've
recently proposed a patch for dia, that is in a very similar situation)

Since commit 4ed8c0b is setting version to 5.0.0 and that version works
(does it?), I'd go for an "update to 5.0.0" patch

My two cents.

[...]

Happy hacking! Gio'

--
Giovanni Biscuolo

Xelera IT Infrastructures
-----BEGIN PGP SIGNATURE-----

iQJABAEBCgAqFiEERcxjuFJYydVfNLI5030Op87MORIFAmRksCoMHGdAeGVsZXJh
LmV1AAoJENN9DqfOzDkSHYYQAMDvLV5uqSW6WRtpjXJPOPMh+4mU7VEtqhRRn/iz
b8CeqP3xjb7FIB/cgShmxacWQaHGBYtWYaY2PqUhU/xobPI7v7NQigM8/blIJA66
UTWo9v5t7pw1LEIwba1LbmTEjJgM0alUVhYM5VTnoQAyvvJPIbnBSF/k46Eysdfn
rKC+mO3Cweabp4ckiv3MAr1Spvr+TkLU8DXCQfejYGOCpVd8Tv8/acFnlT5G75B7
jLS4RZaNywwMStqA+vaH5D80wO8GVMAsnlvSkIfeSYquI+AF2HzlqDUUcs43A0YY
DfA2gBRlkZoXKmwEgSyvBpPZO6mdK5JI0CtO3BD0QOM6hPpI8XiBOg7cJR5gkuX0
EXs+kkC7PyY5JHYZR1smJYiCp8Jb5j2Fpgs4cR2OiIVGLOj8Xbj00LZGyPc50T7c
JBV90D234rt4cM3zFewxQw8V/MQk8TuOxsZPE1tK8s4G3ZXLP4zBVbNQK1g3QpBr
SE9nrgsDDblDl1KR/fOasZqlx6R1sljXL8/cSBbt7cxZdKR6JAG8pYGh773bR4TO
/fYAPRQL/hV3LL4XFNSvjcvzXqzYd/Q39QAlRxXsRkad8dK2zkEsDotn9VHmBnaH
+hJZsi6eGE2odn8iXpCbQxAMA2J1395SZDqpLWbzw6Ng3lsvLi+JVzsgAO53E8Vy
KQYP
=GFTw
-----END PGP SIGNATURE-----

D
D
Denis 'GNUtoo' Carikli wrote on 17 May 2023 14:07
(name . Giovanni Biscuolo)(address . g@xelera.eu)
20230517140722.4e47f582@primary_laptop
On Wed, 17 May 2023 12:44:58 +0200
Giovanni Biscuolo <g@xelera.eu> wrote:
Toggle quote (2 lines)
> Since commit 4ed8c0b is setting version to 5.0.0 and that version
> works (does it?), I'd go for an "update to 5.0.0" patch
It at least builds fine.

Thanks a lot for the advises.

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmRkw3oACgkQX138wUF3
4mOPVhAAldIuCQnYHMNZcN6CTLH+siHeHPbqf5TPj6WnBAuXxN91FoRxP2IIeBer
UWmzq/9TJERFqZ7gaXOFs1DADdLLMXAx6RNBxd6DrPzpte6a5uHkbhyuFbroOT/7
8Ohxt8oIyEKVNVXFzNQiMcQj8wCfij3Zd+vvuXC4aPIkZR+JH0gXb2f67BHHiN9+
XZrxC37I4wbMzH0pcrgA/iA4mR+rR8aglzMfEp059pMyVYUtjkW2J76LyOuZ3NMF
3Y6mhYMhX2REHlNVspfEd1J3/hnEqqdFH0QGhkjKAiJXrSyAG7qPx2NT5MAhwwin
bMghuUBEyNkLKpjxu+YIBEVxBqYkEBGxZma0u86wISoeaSDMtaUxKA7r1077/hFp
cfPEdIiv2rqiGMdnOOaw7x6aQG5X8kB5PqeUr0zMJwSbSsDVp3YKgz367oKp0KIw
swJyLib9tGrKu+lubbIQgss7IBReYAJGhH9Jvf5O28/rPHwf1JVEQiUdOjZi3KUH
NtmKJCYcRcnyv6/Q/hQziF2ccsyD2kovJY4W4auqOoxFNE66Va3gjbKDZhYKBLWf
bOljKWK5SzdM/RGeb6XJZrOwDELMR8jktUWb3iXhb0xeCq7y8IPnuQj9UrVZYhQd
YN2yKtNlFWO7G9HwIJ6Z9Et0EH7ndCTEhk/Mzp8o7II5GyjZGo0=
=dgyY
-----END PGP SIGNATURE-----


H
H
hub.lombard wrote on 17 May 2023 15:35
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
1500510256.722667843.1684330519587.JavaMail.root@zimbra49-e8.priv.proxad.net
Hi,

----- Mail original -----
De: "Denis 'GNUtoo' Carikli" <GNUtoo@cyberdimension.org>
À: "Giovanni Biscuolo" <g@xelera.eu>
Cc: 63551@debbugs.gnu.org, "hub lombard" <hub.lombard@free.fr>, help-guix@gnu.org, "Vagrant Cascadian" <vagrant@debian.org>
Envoyé: Mercredi 17 Mai 2023 14:07:22
Objet: Re: cpp-mustache-4.1 build fails

On Wed, 17 May 2023 12:44:58 +0200
Giovanni Biscuolo <g@xelera.eu> wrote:
Toggle quote (2 lines)
> Since commit 4ed8c0b is setting version to 5.0.0 and that version
> works (does it?), I'd go for an "update to 5.0.0" patch
It at least builds fine.

Thanks a lot for the advises.

Toggle quote (2 lines)
>>> Good to know, thxs! Will investigate and report advices.

Denis.
D
D
Denis 'GNUtoo' Carikli wrote on 23 Nov 2023 17:41
(no subject)
(address . 63551@debbugs.gnu.org)
20231123174148.7d312799@primary_laptop
Hi,

Guix now has cpp-mustanche 5.0 so I think we can close that bug.

Denis.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmVfgMwACgkQX138wUF3
4mN1MQ//U7LWhWq4SPxGGTmFAVPs6x40NooaG9bQf4r/y0yxZzJSj5EJCQtq3oni
YnbAO5W65LRPYnFuUvKejs5d1oy33i9LRXRx6XQRNHJxs3u6tVEHOqjMs14vEypj
pHXyeSbyecMM5Q0+FYrA1IB3UCIln7qDUdA3/HRVsj030iKQs0ciJW2XMPGR2pZl
7Ewy01248hMx1GKepDZqR/DWGBnzlsGGTYKUzgx8jfydoofRYRN+cqSzdR5sooCd
MLD5WcllSx5WKvwgjkNBv5s5BuKv3BkKy/FgRI+glbgn+19MBAES91DoujJLJoi0
6oqrdp2zirN030YysVDRx98DQS0VUtXrCPeVG0Z6ZhD48J7qmKQxEv5eglABCeF6
nlbbTS8qLP1f1s9p5JtHLm/auyd9+8cubtpToHoLvfq92vVak5OkjU1+tIzG2B3x
GZI/e0ugig9cXcaKsfiXvtapKQMJxPVJUZ4X86sFPzFdHbZkF/KDQTjnH4Ngs8QR
Zwub2uNFOsEMQTto4f1hiJFmuwtzZoRbc0YNHHvJAhZyO210f5KvMWEUj4fCxySw
gRouh9XNpX+mhPvdMUEqcpbPHfuRjkCkKIh9ofB8S/yDX8UmD41NtY2wsk5l+gP7
ODj307S6noP848in8bmbv85nQ2lKVXucduDJWs0z+CRX0G7l+14=
=JfEV
-----END PGP SIGNATURE-----


D
D
Denis 'GNUtoo' Carikli wrote on 23 Nov 2023 17:43
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
20231123174342.3130324c@primary_laptop
close 63551
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEeC+d2+Nrp/PU3kkGX138wUF34mMFAmVfgT4ACgkQX138wUF3
4mN4ug/9EoJLVJozaAr8qZe7fjIbfwyADvjpSQFr+ZkXhUxvpYq1+vje23nO0MO7
d7PSTg1U3zgQdJmR46GEurF4hQHoPlItKZEBf6peYO2p1OZXySNJVbTjhLF71Si/
voYQ/BrQWxZ0tpb0TT7rjNaJhHUp8PMv+ly2vKOrRHz1jQLBXMHTHE0Htb8FXE1h
y9o6kJJjYcqW9GGOd0dFfFBcy95uv/iL0H8C/xruRPWM6gfjauUTAv5eFUklTQxe
5mb+7Z/z8kztchDml8A8/ERfdcE6+X0XxTTqAomW7CF9bfu7no4BsoK12BBhSkRe
z118Zi5nuV3c1tPG6d2bn+0hCv9+OQIT0j3s5O7/V0LvN4yHTpoWhca3x2Y7Y3q0
cRAfTsrqh0MqnAYZVsVBZlV0lkiiwhoxteF2VaoN3J+3yc7HmqccJtyHSn2LcqMa
rbwzsaLdAgkw6LHG8OuHC4ScgDZ5mSw/244KjhkScrW0g+/3qYnGa0SvdJKXw7Ma
8oZtFkuL7GgqfLiIeWIY0FkpoupqRjVzfTKcIt5tU94ALvKZr4OKdaeR47+htqYs
bXfIneG1fo3i/VEJqC5kv04J7XHPO4I1ZjlQ6c8IkRyY2GAJi5wgfh3Qg+QsA/Li
msia+YBUDAPOdZzx1Z6+PAXxSpHNuStSuPJ3rfG3WUwpTfgPYyU=
=ALp4
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 63551@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63551
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch