(address . bug-guix@gnu.org)
Hello,
I'm using guix commit fe01acea56, python-pyportmidi-217 fails with the
following error (same derivation failing on data.guix-gnu.org [1])
Toggle snippet (170 lines)
[...]
offloading '/gnu/store/chqv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv' to 'batondor'...
offloading build of /gnu/store/chqv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv to 'batondor'
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://bordeaux.guix.gnu.org'... 100.0%
@ build-started /gnu/store/chqv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv - x86_64-linux /var/log/guix/drvs/ch//qv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv.gz 24023
starting phase `set-SOURCE-DATE-EPOCH'
phase `set-SOURCE-DATE-EPOCH' succeeded after 0.0 seconds
starting phase `set-paths'
[...]
starting phase `build'
running "python setup.py" with command "build" and parameters ()
Assuming Linux platform
running build
running build_py
creating build
creating build/lib.linux-x86_64-cpython-310
creating build/lib.linux-x86_64-cpython-310/pyportmidi
copying pyportmidi/__init__.py -> build/lib.linux-x86_64-cpython-310/pyportmidi
copying pyportmidi/midi.py -> build/lib.linux-x86_64-cpython-310/pyportmidi
warning: build_py: byte-compiling is disabled, skipping.
running build_ext
skipping 'pyportmidi/_pyportmidi.c' Cython extension (up-to-date)
building 'pyportmidi._pyportmidi' extension
creating build/temp.linux-x86_64-cpython-310
creating build/temp.linux-x86_64-cpython-310/pyportmidi
gcc -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -fno-semantic-interposition -fPIC -I/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10 -c pyportmidi/_pyportmidi.c -o build/temp.linux-x86_64-cpython-310/pyportmidi/_pyportmidi.o
pyportmidi/_pyportmidi.c: In function ?__pyx_tp_dealloc_11_pyportmidi_Output?:
pyportmidi/_pyportmidi.c:3455:5: error: lvalue required as increment operand
3455 | ++Py_REFCNT(o);
| ^~
pyportmidi/_pyportmidi.c:3458:5: error: lvalue required as decrement operand
3458 | --Py_REFCNT(o);
| ^~
pyportmidi/_pyportmidi.c: In function ?__pyx_tp_dealloc_11_pyportmidi_Input?:
pyportmidi/_pyportmidi.c:3634:5: error: lvalue required as increment operand
3634 | ++Py_REFCNT(o);
| ^~
pyportmidi/_pyportmidi.c:3637:5: error: lvalue required as decrement operand
3637 | --Py_REFCNT(o);
| ^~
pyportmidi/_pyportmidi.c: In function ?__Pyx_ParseOptionalKeywords?:
pyportmidi/_pyportmidi.c:4554:21: warning: ?_PyUnicode_get_wstr_length? is deprecated [-Wdeprecated-declarations]
4554 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:446:26: note: declared here
446 | static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4554:21: warning: ?PyUnicode_AsUnicode? is deprecated [-Wdeprecated-declarations]
4554 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:580:45: note: declared here
580 | Py_DEPRECATED(3.3) PyAPI_FUNC(Py_UNICODE *) PyUnicode_AsUnicode(
| ^~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4554:21: warning: ?_PyUnicode_get_wstr_length? is deprecated [-Wdeprecated-declarations]
4554 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:446:26: note: declared here
446 | static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4554:21: warning: ?_PyUnicode_get_wstr_length? is deprecated [-Wdeprecated-declarations]
4554 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:446:26: note: declared here
446 | static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4554:21: warning: ?PyUnicode_AsUnicode? is deprecated [-Wdeprecated-declarations]
4554 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:580:45: note: declared here
580 | Py_DEPRECATED(3.3) PyAPI_FUNC(Py_UNICODE *) PyUnicode_AsUnicode(
| ^~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4554:21: warning: ?_PyUnicode_get_wstr_length? is deprecated [-Wdeprecated-declarations]
4554 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:446:26: note: declared here
446 | static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4568:25: warning: ?_PyUnicode_get_wstr_length? is deprecated [-Wdeprecated-declarations]
4568 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:446:26: note: declared here
446 | static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4568:25: warning: ?PyUnicode_AsUnicode? is deprecated [-Wdeprecated-declarations]
4568 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:580:45: note: declared here
580 | Py_DEPRECATED(3.3) PyAPI_FUNC(Py_UNICODE *) PyUnicode_AsUnicode(
| ^~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4568:25: warning: ?_PyUnicode_get_wstr_length? is deprecated [-Wdeprecated-declarations]
4568 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:446:26: note: declared here
446 | static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4568:25: warning: ?_PyUnicode_get_wstr_length? is deprecated [-Wdeprecated-declarations]
4568 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:446:26: note: declared here
446 | static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4568:25: warning: ?PyUnicode_AsUnicode? is deprecated [-Wdeprecated-declarations]
4568 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:580:45: note: declared here
580 | Py_DEPRECATED(3.3) PyAPI_FUNC(Py_UNICODE *) PyUnicode_AsUnicode(
| ^~~~~~~~~~~~~~~~~~~
pyportmidi/_pyportmidi.c:4568:25: warning: ?_PyUnicode_get_wstr_length? is deprecated [-Wdeprecated-declarations]
4568 | if (PyUnicode_GET_SIZE(**name) == PyUnicode_GET_SIZE(key) &&
| ^~
In file included from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/unicodeobject.h:1046,
from /gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/Python.h:83,
from pyportmidi/_pyportmidi.c:4:
/gnu/store/dy3xh053ahkhrp2jamggq8cpsyvp8mg0-python-3.10.7/include/python3.10/cpython/unicodeobject.h:446:26: note: declared here
446 | static inline Py_ssize_t _PyUnicode_get_wstr_length(PyObject *op) {
| ^~~~~~~~~~~~~~~~~~~~~~~~~~
error: command '/gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/gcc' failed with exit code 1
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "build") exit-status: 1 term-signal: #f stop-signal: #f>
phase `build' failed after 0.4 seconds
command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "build" failed with status 1
builder for `/gnu/store/chqv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv' failed with exit code 1
@ build-failed /gnu/store/chqv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv - 1 builder for `/gnu/store/chqv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv' failed with exit code 1
derivation '/gnu/store/chqv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv' offloaded to 'batondor' failed: build of `/gnu/store/chqv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv' failed
build of /gnu/store/chqv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv failed
Could not find build log for '/gnu/store/chqv2117qwm6n7d106f9s88az8j70g93-python-pyportmidi-217.drv'.
cannot build derivation `/gnu/store/icqc5kiigmafxkgg147h2bnhxmsja386-frescobaldi-3.3.0.drv': 1 dependencies couldn't be built
guix build: error: build of `/gnu/store/icqc5kiigmafxkgg147h2bnhxmsja386-frescobaldi-3.3.0.drv' failed
Happy hacking! Gio'
--
Giovanni Biscuolo
Xelera IT Infrastructures
-----BEGIN PGP SIGNATURE-----
iQJABAEBCgAqFiEERcxjuFJYydVfNLI5030Op87MORIFAmRkh/kMHGdAeGVsZXJh
LmV1AAoJENN9DqfOzDkSxeAP/jHHNa0uNOpjYi8oOOjHEE/d4hyOQowmZQaPtAUb
8P3UFxNs/yswWJkLfLdjFpvG2TARuMrABK7EwYVKBO4AELKwW7erUJSimBme6IQC
gNsoVH2592oCkNjZXUHy3anzroCMFgIzRSrbaHrbhLBr9jbXyvakYDIhzqrsPxju
gcv6HOuOUDrGBXDyQ5G6lIHZD6WqrLJfaDKQLfVv8ERpH05PkNJzT/H6guWWHVDJ
ux7Px3JJfpHp1qdgVTzI97VFx1U776aKN0PPEUefKcAuhSfssZYOpGUL1VbCRfkF
jb25WCGdvftwamIkRuX7UUtBfi5lAdSpIVG5QAP3bqRb+VYyAnwvLOzE02gzhOt4
eju1+TPzgd4FmxjJC6QuDliHPnB+eeno15tFcsyA3WxPFp9jTlsy3UXh2dbF+T7y
UpsLq9Kl4J9D6sNAOaZlRKCbk3H8aaTXrEJEMPCO7ncm9cXejhJRvEuS2UOBtZZr
Ik+YjuTgllPs+OP6weHEE3b+1f4LxdbjDCxxXzT1Tuc0mhqRTCMnxlAiDQVpP5+X
3fkjmwTfkhpOcvp0xfElD+JhN0eI3gdGu3FfqMJPubB+idVJw4fdupd0Nwt3K9+U
apSLXzopAIQQhNQCVi48ZqFX8SO0lj8zq81djYnDtfW/cswmS8oxtCBV6kNLbSdQ
pND7
=UZ/J
-----END PGP SIGNATURE-----