[PATCH 0/3] gnu: heimdal: Drop obsolete user tools.

  • Done
  • quality assurance status badge
Details
2 participants
  • Josselin Poiret
  • Felix Lechner
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 17 May 2023 06:19
(address . guix-patches@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
cover.1684296904.git.felix.lechner@lease-up.com
This patch stops Guix from shipping user tools that, according to two Heimdal
maintainers have been obsolete for over five years.

While mostly harmless, those tools shadowed legitimate tools like 'su' from
core-utils. [1]


Felix Lechner (3):
gnu: heimdal: Build from Git.
gnu: heimdal: Drop obsolete and insecure user tools.
gnu: heimdal: Re-indent code; no functional change.

gnu/packages/kerberos.scm | 202 +++++++++++++++++++-------------------
1 file changed, 103 insertions(+), 99 deletions(-)


base-commit: 6e38ec447f98383e0722ac300734f8d7c8c5c7b0
--
2.40.1
F
F
Felix Lechner wrote on 17 May 2023 06:20
[PATCH 1/3] gnu: heimdal: Build from Git.
(address . 63545@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
2262ef65f5191b0c3d925ea6688c1bd8bf0587d0.1684296904.git.felix.lechner@lease-up.com
This is in preparation to drop obsolete tools from the Automake files. The
tarball comes with a ./configure script. It was not clear to the author what
the best way was to run 'autoreconf -f -i' with the tarball in Guix's
gnu-build-system.

* gnu/packages/kerberos (heimdal): Build from Git; prepare to drop obsolete
tools from Automake.
---
gnu/packages/kerberos.scm | 39 +++++++++++++++++++++++----------------
1 file changed, 23 insertions(+), 16 deletions(-)

Toggle diff (88 lines)
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index c553f8180a..af67bff6c9 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -56,6 +56,7 @@ (define-module (gnu packages kerberos)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix gexp)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system gnu))
@@ -171,26 +172,22 @@ (define-public shishi
(license license:gpl3+)))
(define-public heimdal
+ (let ((commit "a6cf94577c0d1e5bca5304342e4ddffb18255afe")
+ (revision "1"))
(package
(name "heimdal")
- (version "7.8.0")
+ (version (git-version "7.8.0" revision commit))
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/heimdal/heimdal/releases/download/"
- "heimdal-" version "/" "heimdal-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/heimdal/heimdal")
+ (commit commit)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0f4dblav859p5hn7b2jdj1akw6d8p32as6bj6zym19kghh3s51zx"))
+ "0df646hzi10s0w07kqzj10aniv6jsbmlpx6j3lqjvpsjpmm9lww9"))
(patches
- (search-patches "heimdal-CVE-2022-45142.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "configure"
- (("User=.*$") "User=Guix\n")
- (("Host=.*$") "Host=GNU")
- (("Date=.*$") "Date=2022\n"))))))
+ (search-patches "heimdal-CVE-2022-45142.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -224,6 +221,10 @@ (define-public heimdal
(add-before 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "configure"
+ ;; Reproducible build date, etc.
+ (("User=.*$") "User=Guix\n")
+ (("Host=.*$") "Host=GNU")
+ (("Date=.*$") "Date=2022\n")
;; The e2fsprogs input is included for libcom_err,
;; let's use it even if cross-compiling.
(("test \"\\$\\{krb_cv_com_err\\}\" = \"yes\"")
@@ -255,12 +256,17 @@ (define-public heimdal
(format #t "#!~a~%exit 1~%" (which "sh")))))))
;; Tests fail when run in parallel.
#:parallel-tests? #f))
- (native-inputs (list bison
+ (native-inputs (list autoconf
+ automake
+ bison
e2fsprogs ;for 'compile_et'
flex
+ libtool
texinfo
unzip ;for tests
pkg-config
+ perl
+ perl-json
python))
(inputs (list readline
bash-minimal
@@ -274,4 +280,5 @@ (define-public heimdal
(description
"Heimdal is an implementation of Kerberos 5 network authentication
service.")
- (license license:bsd-3)))
+ (license license:bsd-3))))
+
--
2.40.1
F
F
Felix Lechner wrote on 17 May 2023 06:20
[PATCH 2/3] gnu: heimdal: Drop obsolete and insecure user tools.
(address . 63545@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
08b45237b932692ab246f0a0e36da4fcdb67988b.1684296904.git.felix.lechner@lease-up.com
According to messages from the Heimdal maintainers Brian May and Nico
Williams, no one should be using their version of 'su' anymore. It was deleted
from the development branch five years ago [1] and is only being shipped
because the 7.8.0 is based on an older, stable branch.


Following the directions from the maintainers, this commit drops all
executables built from the ./appl folder via deletion of that SUBDIR from
the top-level Makefile.am.

Unfortunately, the heimdal-discuss mailing list does not appear to have a
public archive. The relevant SMTP Message-Id was:

<MDAEMON-F202305111940.AA401569md5001000003030@sequoia-grove.ad.secure-endpoints.com>

Since the 7.8.0 tarball shipped with all the files generated by 'autoreconf'
it seemed superior to build from Git instead. For that, please see the
preceeding commit.

* gnu/packages/kerberos.scm (heimdal): Drop obsolete and insecure user tools.
---
gnu/packages/kerberos.scm | 15 ++++++---------
1 file changed, 6 insertions(+), 9 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index af67bff6c9..cc5f3f9ef2 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -218,6 +218,12 @@ (define-public heimdal
"/libexec/heimdal")))
#~()))
#:phases (modify-phases %standard-phases
+ ;; Skip the appl folder as obsolete per message from Brian May <brian@linuxpenguins.xyz>
+ ;; <MDAEMON-F202305111940.AA401569md5001000003030@sequoia-grove.ad.secure-endpoints.com>
+ (add-after 'unpack 'drop-obsolete-executables
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("Makefile.am")
+ (("appl") ""))))
(add-before 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "configure"
@@ -233,15 +239,6 @@ (define-public heimdal
;; which confuses heimdal.
(("ac_cv_prog_COMPILE_ET=\\$\\{with_cross_tools\\}compile_et")
"ac_cv_PROG_COMPILE_ET=compile_et"))
- (substitute* '("appl/afsutil/pagsh.c" "appl/su/su.c")
- (("/bin/sh")
- (search-input-file inputs "bin/sh"))
- ;; Use the cross-compiled bash instead of the
- ;; native bash (XXX shouldn't _PATH_BSHELL point
- ;; to a cross-compiled bash?).
- (("_PATH_BSHELL")
- (string-append
- "\"" (search-input-file inputs "bin/sh") "\"")))
(substitute* '("tools/Makefile.in")
(("/bin/sh") (which "sh")))))
(add-before 'check 'pre-check
--
2.40.1
F
F
Felix Lechner wrote on 17 May 2023 06:20
[PATCH 3/3] gnu: heimdal: Re-indent code; no functional change.
(address . 63545@debbugs.gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
28905e7dadc7acfe4abf335bdaf30d8925503570.1684296904.git.felix.lechner@lease-up.com
* gnu/packages/kerberos (heimdal): Re-indent code; no functional change.
---
gnu/packages/kerberos.scm | 198 +++++++++++++++++++-------------------
1 file changed, 99 insertions(+), 99 deletions(-)

Toggle diff (214 lines)
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index cc5f3f9ef2..3bfeefd558 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -174,108 +174,108 @@ (define-public shishi
(define-public heimdal
(let ((commit "a6cf94577c0d1e5bca5304342e4ddffb18255afe")
(revision "1"))
- (package
- (name "heimdal")
- (version (git-version "7.8.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/heimdal/heimdal")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0df646hzi10s0w07kqzj10aniv6jsbmlpx6j3lqjvpsjpmm9lww9"))
- (patches
- (search-patches "heimdal-CVE-2022-45142.patch"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- ,#~(list
- ;; Avoid 7 MiB of .a files.
- "--disable-static"
+ (package
+ (name "heimdal")
+ (version (git-version "7.8.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/heimdal/heimdal")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0df646hzi10s0w07kqzj10aniv6jsbmlpx6j3lqjvpsjpmm9lww9"))
+ (patches
+ (search-patches "heimdal-CVE-2022-45142.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ ,#~(list
+ ;; Avoid 7 MiB of .a files.
+ "--disable-static"
- ;; Do not build libedit.
- (string-append
- "--with-readline-lib="
- (assoc-ref %build-inputs "readline") "/lib")
- (string-append
- "--with-readline-include="
- (assoc-ref %build-inputs "readline") "/include")
+ ;; Do not build libedit.
+ (string-append
+ "--with-readline-lib="
+ (assoc-ref %build-inputs "readline") "/lib")
+ (string-append
+ "--with-readline-include="
+ (assoc-ref %build-inputs "readline") "/include")
- ;; Do not build sqlite.
- (string-append
- "--with-sqlite3="
- (assoc-ref %build-inputs "sqlite"))
+ ;; Do not build sqlite.
+ (string-append
+ "--with-sqlite3="
+ (assoc-ref %build-inputs "sqlite"))
- #$@(if (%current-target-system)
- ;; The configure script is too pessimistic.
- ;; Setting this also resolves a linking error.
- #~("ac_cv_func_getpwnam_r_posix=yes"
- ;; Allow 'slc' and 'asn1_compile' to be found.
- (string-append "--with-cross-tools="
- #+(file-append this-package
- "/libexec/heimdal")))
- #~()))
- #:phases (modify-phases %standard-phases
- ;; Skip the appl folder as obsolete per message from Brian May <brian@linuxpenguins.xyz>
- ;; <MDAEMON-F202305111940.AA401569md5001000003030@sequoia-grove.ad.secure-endpoints.com>
- (add-after 'unpack 'drop-obsolete-executables
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* '("Makefile.am")
- (("appl") ""))))
- (add-before 'configure 'pre-configure
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "configure"
- ;; Reproducible build date, etc.
- (("User=.*$") "User=Guix\n")
- (("Host=.*$") "Host=GNU")
- (("Date=.*$") "Date=2022\n")
- ;; The e2fsprogs input is included for libcom_err,
- ;; let's use it even if cross-compiling.
- (("test \"\\$\\{krb_cv_com_err\\}\" = \"yes\"")
- ":")
- ;; Our 'compile_et' is not in --with-cross-tools,
- ;; which confuses heimdal.
- (("ac_cv_prog_COMPILE_ET=\\$\\{with_cross_tools\\}compile_et")
- "ac_cv_PROG_COMPILE_ET=compile_et"))
- (substitute* '("tools/Makefile.in")
- (("/bin/sh") (which "sh")))))
- (add-before 'check 'pre-check
- (lambda _
- ;; For 'getxxyyy-test'.
- (setenv "USER" (passwd:name (getpwuid (getuid))))
+ #$@(if (%current-target-system)
+ ;; The configure script is too pessimistic.
+ ;; Setting this also resolves a linking error.
+ #~("ac_cv_func_getpwnam_r_posix=yes"
+ ;; Allow 'slc' and 'asn1_compile' to be found.
+ (string-append "--with-cross-tools="
+ #+(file-append this-package
+ "/libexec/heimdal")))
+ #~()))
+ #:phases (modify-phases %standard-phases
+ ;; Skip the appl folder as obsolete per message from Brian May <brian@linuxpenguins.xyz>
+ ;; <MDAEMON-F202305111940.AA401569md5001000003030@sequoia-grove.ad.secure-endpoints.com>
+ (add-after 'unpack 'drop-obsolete-executables
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("Makefile.am")
+ (("appl") ""))))
+ (add-before 'configure 'pre-configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "configure"
+ ;; Reproducible build date, etc.
+ (("User=.*$") "User=Guix\n")
+ (("Host=.*$") "Host=GNU")
+ (("Date=.*$") "Date=2022\n")
+ ;; The e2fsprogs input is included for libcom_err,
+ ;; let's use it even if cross-compiling.
+ (("test \"\\$\\{krb_cv_com_err\\}\" = \"yes\"")
+ ":")
+ ;; Our 'compile_et' is not in --with-cross-tools,
+ ;; which confuses heimdal.
+ (("ac_cv_prog_COMPILE_ET=\\$\\{with_cross_tools\\}compile_et")
+ "ac_cv_PROG_COMPILE_ET=compile_et"))
+ (substitute* '("tools/Makefile.in")
+ (("/bin/sh") (which "sh")))))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; For 'getxxyyy-test'.
+ (setenv "USER" (passwd:name (getpwuid (getuid))))
- ;; Skip 'db' and 'kdc' tests for now.
- ;; FIXME: figure out why 'kdc' tests fail.
- (with-output-to-file "tests/db/have-db.in"
- (lambda ()
- (format #t "#!~a~%exit 1~%" (which "sh")))))))
- ;; Tests fail when run in parallel.
- #:parallel-tests? #f))
- (native-inputs (list autoconf
- automake
- bison
- e2fsprogs ;for 'compile_et'
- flex
- libtool
- texinfo
- unzip ;for tests
- pkg-config
- perl
- perl-json
- python))
- (inputs (list readline
- bash-minimal
- bdb
- e2fsprogs ;for libcom_err
- libcap-ng
- openldap
- sqlite))
- (home-page "http://www.h5l.org/")
- (synopsis "Kerberos 5 network authentication")
- (description
- "Heimdal is an implementation of Kerberos 5 network authentication
+ ;; Skip 'db' and 'kdc' tests for now.
+ ;; FIXME: figure out why 'kdc' tests fail.
+ (with-output-to-file "tests/db/have-db.in"
+ (lambda ()
+ (format #t "#!~a~%exit 1~%" (which "sh")))))))
+ ;; Tests fail when run in parallel.
+ #:parallel-tests? #f))
+ (native-inputs (list autoconf
+ automake
+ bison
+ e2fsprogs ;for 'compile_et'
+ flex
+ libtool
+ texinfo
+ unzip ;for tests
+ pkg-config
+ perl
+ perl-json
+ python))
+ (inputs (list readline
+ bash-minimal
+ bdb
+ e2fsprogs ;for libcom_err
+ libcap-ng
+ openldap
+ sqlite))
+ (home-page "http://www.h5l.org/")
+ (synopsis "Kerberos 5 network authentication")
+ (description
+ "Heimdal is an implementation of Kerberos 5 network authentication
service.")
- (license license:bsd-3))))
+ (license license:bsd-3))))
--
2.40.1
J
J
Josselin Poiret wrote on 17 May 2023 22:20
Re: [bug#63545] [PATCH 1/3] gnu: heimdal: Build from Git.
(name . Felix Lechner)(address . felix.lechner@lease-up.com)
87wn161zi4.fsf@jpoiret.xyz
Hi Felix,

I am no user of Heimdal, but this looks good to me apart from some
nitpicks below.

Felix Lechner via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (4 lines)
> (define-public heimdal
> + (let ((commit "a6cf94577c0d1e5bca5304342e4ddffb18255afe")
> + (revision "1"))

No need to use commit+revision for fixed releases, unless upstream has
the bad habit of moving their upstream tags. I see the tag
heimdal-7.8.0, which you should use in (commit ...), possibly with
(commit (string-append "heimdall-" version)).

Toggle quote (5 lines)
> (package
> (name "heimdal")
> - (version "7.8.0")
> + (version (git-version "7.8.0" revision commit))

This would lead to a very ugly version string for what is actually
7.8.0, no need to change this.

The other patches seem fine, although I think you don't need to go as
far as make the indentation change its own patch (and by dropping the
commit+revision thing, there shouldn't be one).

I haven't tried building this yet though, will let QA go over it.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmRlNwMQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcailfQDACcfWKScDjfg6OuiGeMg3ZqKaBfNQxdVA69
7fA8AKeVkD3so4eSR1nxbStNi5tZFHG/wqLHcF5hxMEan7lgJ8n9B0+BiZTOM4BJ
8IB8KkkuDLNmiv2qsv1bQTEvUgR0dsk4N72qn9z46J7ZrIaqoT7XDNKZnZIMxhps
Ww8U2j+Yvqx4AxTZPWQo7N1egJKWFj8OhOlM0IU0CU6C+DlQ10eeKfjuePOJOP/Z
G1+DF0k9mwWWvSIxHN9uj480IAk42WyvNLXEeq5zOzA2Z+ZYbKAY3eFPkWNqG5F4
TmTdzKlJRmh0jGqj7tb5vipfEvJdxcF5mC7b0GK5eilltg6ApGnXHeyrdqqHwcvU
Jws8g0luXwWvUFYwieClmRxdqhDGk4H4In+gVm2Y88B1oQgdg5rlzbYScxCd3l1O
e2lR9oio+NyXbj7OeVAVIuDepKyKm1D0a5X98Sq392MDleWxID1RSTm1iDt8tkRV
gD7EBprxSzT87n61+WlmcotbcyudbjQ=
=j2aT
-----END PGP SIGNATURE-----

F
F
Felix Lechner wrote on 29 May 2023 02:19
[PATCH v2 1/2] gnu: heimdal: Run autoreconf.
(address . 63545@debbugs.gnu.org)
700bdb497cd0431ea9f3d71516f4168f55882ce4.1685319429.git.felix.lechner@lease-up.com
* gnu/packages/kerberos.scm (heimdal): Run autoreconf.
---
Hi Josselin,

Thanks for your review! I sidestepped your suggestions by continuing
to build from the tarball, and running 'autoreconf.'

Kind regards
Felix

gnu/packages/kerberos.scm | 21 ++++++++++++---------
1 file changed, 12 insertions(+), 9 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index c553f8180a..f06410b8f8 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -183,14 +183,7 @@ (define-public heimdal
(base32
"0f4dblav859p5hn7b2jdj1akw6d8p32as6bj6zym19kghh3s51zx"))
(patches
- (search-patches "heimdal-CVE-2022-45142.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "configure"
- (("User=.*$") "User=Guix\n")
- (("Host=.*$") "Host=GNU")
- (("Date=.*$") "Date=2022\n"))))))
+ (search-patches "heimdal-CVE-2022-45142.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -223,7 +216,12 @@ (define-public heimdal
#:phases (modify-phases %standard-phases
(add-before 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
+ (invoke (search-input-file inputs "bin/autoreconf") "--install" "--force")
(substitute* "configure"
+ ;; Reproducible build date, etc.
+ (("User=.*$") "User=Guix\n")
+ (("Host=.*$") "Host=GNU\n")
+ (("Date=.*$") "Date=2022\n")
;; The e2fsprogs input is included for libcom_err,
;; let's use it even if cross-compiling.
(("test \"\\$\\{krb_cv_com_err\\}\" = \"yes\"")
@@ -255,12 +253,17 @@ (define-public heimdal
(format #t "#!~a~%exit 1~%" (which "sh")))))))
;; Tests fail when run in parallel.
#:parallel-tests? #f))
- (native-inputs (list bison
+ (native-inputs (list autoconf
+ automake
+ bison
e2fsprogs ;for 'compile_et'
flex
+ libtool
texinfo
unzip ;for tests
pkg-config
+ perl
+ perl-json
python))
(inputs (list readline
bash-minimal

base-commit: d64d6ea2cf5a1be801be355031fb2cfa5901a92a
--
2.40.1
F
F
Felix Lechner wrote on 29 May 2023 02:19
[PATCH v2 2/2] gnu: heimdal: Drop obsolete and insecure user tools.
(address . 63545@debbugs.gnu.org)
fa765891cffcc51d2c0b6449a1f7df809ecf6dc3.1685319429.git.felix.lechner@lease-up.com
According to messages from the Heimdal maintainers Brian May and Nico
Williams, no one should be using their version of 'su' anymore. It was deleted
from the development branch five years ago [1] and is only being shipped
because the 7.8.0 is based on an older, stable branch.


Following the directions from the maintainers, this commit drops all
executables built from the ./appl folder via deletion of that SUBDIR from
the top-level Makefile.am.

Unfortunately, the heimdal-discuss mailing list does not appear to have a
public archive. The relevant SMTP Message-Id was:

<MDAEMON-F202305111940.AA401569md5001000003030@sequoia-grove.ad.secure-endpoints.com>

Since the 7.8.0 tarball shipped with all the files generated by 'autoreconf'
it seemed superior to build from Git instead. For that, please see the
preceeding commit.

* gnu/packages/kerberos.scm (heimdal): Drop obsolete and insecure user tools.
---
gnu/packages/kerberos.scm | 15 ++++++---------
1 file changed, 6 insertions(+), 9 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index f06410b8f8..241881ea47 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -214,6 +214,12 @@ (define-public heimdal
"/libexec/heimdal")))
#~()))
#:phases (modify-phases %standard-phases
+ ;; Skip the appl folder as obsolete per message from Brian May <brian@linuxpenguins.xyz>
+ ;; <MDAEMON-F202305111940.AA401569md5001000003030@sequoia-grove.ad.secure-endpoints.com>
+ (add-after 'unpack 'drop-obsolete-executables
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("Makefile.am")
+ (("appl") ""))))
(add-before 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
(invoke (search-input-file inputs "bin/autoreconf") "--install" "--force")
@@ -230,15 +236,6 @@ (define-public heimdal
;; which confuses heimdal.
(("ac_cv_prog_COMPILE_ET=\\$\\{with_cross_tools\\}compile_et")
"ac_cv_PROG_COMPILE_ET=compile_et"))
- (substitute* '("appl/afsutil/pagsh.c" "appl/su/su.c")
- (("/bin/sh")
- (search-input-file inputs "bin/sh"))
- ;; Use the cross-compiled bash instead of the
- ;; native bash (XXX shouldn't _PATH_BSHELL point
- ;; to a cross-compiled bash?).
- (("_PATH_BSHELL")
- (string-append
- "\"" (search-input-file inputs "bin/sh") "\"")))
(substitute* '("tools/Makefile.in")
(("/bin/sh") (which "sh")))))
(add-before 'check 'pre-check
--
2.40.1
J
J
Josselin Poiret wrote on 4 Jun 2023 11:39
Re: [PATCH v2 1/2] gnu: heimdal: Run autoreconf.
(name . Felix Lechner)(address . felix.lechner@lease-up.com)
87cz2befc0.fsf@jpoiret.xyz
Hi Felix,

Felix Lechner <felix.lechner@lease-up.com> writes:

Toggle quote (8 lines)
> Hi Josselin,
>
> Thanks for your review! I sidestepped your suggestions by continuing
> to build from the tarball, and running 'autoreconf.'
>
> Kind regards
> Felix

Thanks, pushed as d89247150fe6e97c2fceed8d578fd119a782624d. I removed
the last sentence of the second commit message, as it was no longer
applicable.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmR8W98QHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaioZCDACOs4a6C101r8ojPzm9XGsUebZZgLzs8+tY
7yS+CFI2EOlQJPi+AGrslve7PADiwfGp8l1cKxvxQd8VOqzKFHXSAOcqmiC4OBnX
a/MDszzh6i6uttvj8KjwPApT2hCueq4bI9F/2iVeNWZ/pnxU+RFDEK1k5aKQrhyr
zMAfh8n9koXcJWS+ltHx6DSkPVBwv6mppFL2IzsVAOzJ7XXeBF+HIA+eHrg+sHiJ
Pql1vFMQQ3MrXnJW1V7r7EDPom/q9q1yKsgN5VXG3M2qAr4pEXkFlF2U5X8035xm
QR/AN09K3QpPmF781TAm6ydzZrSuZj1+CMhvbpWbNRdh7/wl9ZsZBNYv1TFlho4m
3Lh1XbKuL10oY5Y+IkVbyUO6n/bgsmWMPzYdoI3ES9Afjh7Bes2ULPwWvSYAt5qm
Q4O6FX3jQgQsM5xfDLVCbsR9uAl1PX26bR0AC0koK1lYbisBFK2mz3+7anYq5CFq
tdkPURynWr1SBERjakEEMV/Vwy0rn3g=
=W055
-----END PGP SIGNATURE-----

Closed
?