[PATCH] gnu: cl-croatoan: Update to 0.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • cage
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
cage
Severity
normal

Debbugs page

cage wrote 2 years ago
(address . guix-patches@gnu.org)
c896f1c44de4def3d468edf35809dfdeff6f7913.1684173126.git.cage-dev@twistfold.it
---
gnu/packages/lisp-xyz.scm | 62 +++++++++++++++++++--------------------
1 file changed, 30 insertions(+), 32 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 8bed746669..c8e8cd47e3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18512,39 +18512,37 @@ (define-public cl-tooter
(sbcl-package->cl-source-package sbcl-tooter))

(define-public sbcl-croatoan
- (let ((commit "42e474f4dffe2f4e429905a612be5736c2c3e374")
- (revision "7"))
- (package
- (name "sbcl-croatoan")
- (version (git-version "0.0.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/McParen/croatoan")
- (commit commit)))
- (file-name (git-file-name "cl-croatoan" version))
- (sha256
- (base32 "12hnj8gwk2600j3kn778xvvpx3y6z0428v5dq2qbf4vbzj66vcxj"))))
- (build-system asdf-build-system/sbcl)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "ncurses/ncurses.lisp"
- (("libncursesw.so")
- (search-input-file inputs "/lib/libncursesw.so"))))))))
- (inputs
- (list ncurses
- sbcl-cffi
- sbcl-trivial-gray-streams
- sbcl-bordeaux-threads))
- (synopsis "Common Lisp bindings for the ncurses terminal library")
- (description "Croatoan provides high-level Common Lisp CLOS bindings for
+ (package
+ (name "sbcl-croatoan")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/McParen/croatoan")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "cl-croatoan" version))
+ (sha256
+ (base32 "1whbvwc4df7zz0002xy3aczrpf4s3vk6kmyh9wydgwl112h060pd"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "ncurses/ncurses.lisp"
+ (("libncursesw.so")
+ (search-input-file inputs "/lib/libncursesw.so"))))))))
+ (inputs
+ (list ncurses
+ sbcl-cffi
+ sbcl-trivial-gray-streams
+ sbcl-bordeaux-threads))
+ (synopsis "Common Lisp bindings for the ncurses terminal library")
+ (description "Croatoan provides high-level Common Lisp CLOS bindings for
the ncurses terminal library.")
- (home-page "https://github.com/McParen/croatoan")
- (license license:expat))))
+ (home-page "https://github.com/McParen/croatoan")
+ (license license:expat)))

(define-public ecl-croatoan
(sbcl-package->ecl-package sbcl-croatoan))

base-commit: f0b4cfb475cd4a3c147a9ccb90ddb3610df1954b
--
2.34.0
Guillaume Le Vaillant wrote 2 years ago
(name . cage)(address . cage-dev@twistfold.it)(address . 63524-done@debbugs.gnu.org)
87pm6zozdx.fsf@kitej
Patch applied as ed60a524fbb34b0b37799c556f2516c06d050af3.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZGTX2g8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8ZywD/YpWFm/88cCvEkVpd4KF78KVDY2lu3mCnE8ei
Z9IriKcA/RV9nPLeAu518hLipP2ehVceLNaDFFs3gShgloAfqCP5
=Dj2o
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63524@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63524
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help