[PATCH] gnu: Add font-scientifica.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ahmad Draidi
  • 宋文武
Owner
unassigned
Submitted by
Ahmad Draidi
Severity
normal

Debbugs page

Ahmad Draidi wrote 2 years ago
(address . guix-patches@gnu.org)(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
0d0d6f46c5515a0fbb7b3f9b63600f2872a3c90d.1684095647.git.a.r.draidi@redscript.org
* gnu/packages/fonts.scm (font-scientifica): New variable.
---
gnu/packages/fonts.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index e4c53dbc73..c5bbce2592 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3152,3 +3152,55 @@ (define-public font-spleen
Spleen also has support for Powerline symbols out of the box.")
(license license:bsd-2)))
+
+(define-public font-scientifica
+ (package
+ (name "font-scientifica")
+ (version "2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/nerdypepper/scientifica/releases/download/"
+ "v" version "/scientifica.tar"))
+ (sha256
+ (base32
+ "0zwa3s75lvbky2vn73i1fmxa37hi3zfm7f6wfpqwcip8l1lpi1gh"))))
+ (build-system font-build-system)
+ (outputs '("out" ;OTB
+ "bdf" "ttf"))
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((otb (assoc-ref outputs "out"))
+ (bdf (assoc-ref outputs "bdf"))
+ (ttf (assoc-ref outputs "ttf"))
+ (otb-font-dir (string-append (assoc-ref
+ outputs "out")
+ "/share/fonts/misc"))
+ (ttf-font-dir (string-append (assoc-ref
+ outputs "ttf")
+ "/share/fonts/truetype"))
+ (bdf-font-dir (string-append (assoc-ref
+ outputs "bdf")
+ "/share/fonts/misc")))
+ (mkdir-p otb-font-dir)
+ (mkdir-p bdf-font-dir)
+ (mkdir-p ttf-font-dir)
+ (for-each (lambda (otb)
+ (install-file otb otb-font-dir))
+ (find-files "." "\\.otb$"))
+ (for-each (lambda (bdf)
+ (install-file bdf bdf-font-dir))
+ (find-files "." "\\.bdf$"))
+ (for-each (lambda (ttf)
+ (install-file ttf ttf-font-dir))
+ (find-files "." "\\.ttf$"))) #t)))))
+ (home-page "https://github.com/nerdypepper/scientifica")
+ (synopsis "Tall and condensed bitmap font for geeks")
+ (description
+ "@code{scientifica} is largely based on
+@url{https://github.com/romeovs/creep, @code{creep}}, with a number of
+minor tweaks to improve readability (a matter of taste of course).
+Most characters are just 4px wide, which is brilliant for low dpi(90-120) displays.")
+ (license license:silofl1.1)))

base-commit: 7b00b155d8f474d493a22ff7cccbeec311b9bbc8
--
2.40.1
宋文武 wrote 2 years ago
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)
87bkil7whj.fsf@envs.net
Ahmad Draidi <a.r.draidi@redscript.org> writes:

Toggle quote (2 lines)
> * gnu/packages/fonts.scm (font-scientifica): New variable.

Pushed to master now, thank you!
宋文武 wrote 2 years ago
Re: bug#63506: [PATCH] gnu: Add font-scientifica.
(name . Ahmad Draidi)(address . a.r.draidi@redscript.org)(address . 63506-done@debbugs.gnu.org)
874jod7w7w.fsf_-_@envs.net
Forgot to close the issue :\
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63506@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63506
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help